Author Topic: Component clearance after rotating by 45°  (Read 2892 times)

0 Members and 1 Guest are viewing this topic.

Offline bene86

  • Newbie
  • Posts: 3
Component clearance after rotating by 45°
« on: February 10, 2014, 08:24:24 PM »
Hi,

I have a design where I need SMD-resistors rotated by 45°. However I have a problem with the clearance rule placing these rotated resistors. I attached a figure to illustrate my problem. The "bounding box" of the device remains a rectangular which is not rotated and therefore exceeds the device's dimensions. How is it possible to rotate the whole device in such a way that clearance won't be a problem anymore?
 

Offline Psi

  • Super Contributor
  • ***
  • Posts: 6243
  • Country: nz
Re: Component clearance after rotating by 45°
« Reply #1 on: February 10, 2014, 09:17:39 PM »
I've come across this problem as well and never found a solution (I didn't really look hard for one though)
Greek letter 'Psi' (not Pounds per Square Inch)
 

Offline CM800

  • Frequent Contributor
  • **
  • Posts: 753
  • Country: 00
Re: Component clearance after rotating by 45°
« Reply #2 on: February 10, 2014, 09:37:27 PM »
I would guess, draw your own pads?
 

Offline bene86

  • Newbie
  • Posts: 3
Re: Component clearance after rotating by 45°
« Reply #3 on: February 10, 2014, 10:04:36 PM »
Actually I did draw this footprint by myself.

Do you mean to draw a separate footprint for rotated (by 45°) 0603-devices?
 

Online NANDBlog

  • Super Contributor
  • ***
  • Posts: 3523
  • Country: be
Re: Component clearance after rotating by 45°
« Reply #4 on: February 10, 2014, 11:36:37 PM »
Your Pad-Pad clearance is fine, so it must be the component clearance. I think if you add 3D layer or STEP information to the footprint, that will solve the problem.
 

Offline 8086

  • Super Contributor
  • ***
  • Posts: 1081
  • Country: gb
    • Circuitology - Electronics Assembly
Re: Component clearance after rotating by 45°
« Reply #5 on: February 11, 2014, 12:57:00 AM »
I had this problem. You need to add a 3D body to the library part.
 

Offline bene86

  • Newbie
  • Posts: 3
Re: Component clearance after rotating by 45°
« Reply #6 on: February 11, 2014, 01:56:54 AM »
Thanks, I solved the problem by adding an Component Body.
 

Offline ^_^

  • Regular Contributor
  • *
  • Posts: 73
  • Country: au
  • EE
Re: Component clearance after rotating by 45°
« Reply #7 on: July 18, 2017, 06:56:54 PM »
It's 2017, I'm using AD 17.0.11 and the problem is still here !
And, yes, I do have 3D bodies.

The only "solution" I've found is to change the mode with "R" key, to enter "Ignore obstacles" instead of "Avoid obstacles".
But then I can place a component totally inside another component.

There's no problem however for components that are "right angle".
Any suggestions?
 

Offline Pseudobyte

  • Contributor
  • Posts: 42
  • Country: us
Re: Component clearance after rotating by 45°
« Reply #8 on: July 19, 2017, 12:01:41 AM »
I am confused. The picture you gave us shows no component clearance violation. It is not a problem, nor was it ever a problem in the context of this thread. Check the value of the ComponentClearance Rule, and make sure that you have the online DRC enabled for component clearance. (unless your computer can't handle it  :horse:)
“They Don’t Think It Be Like It Is, But It Do”
 

Offline ^_^

  • Regular Contributor
  • *
  • Posts: 73
  • Country: au
  • EE
Re: Component clearance after rotating by 45°
« Reply #9 on: July 19, 2017, 01:23:53 AM »
Because it's about moving the components closer to each other.

In the picture I've attached you can see that there's significant space between the IC and the capacitors. In "avoid obstacles" mode I simply cannot move the component closer to the IC! I have to switch to "ignore obstacles" mode. And this only happens for components that are 45*. For "straight" components it's allright and I can move them as close as specified in component clearance rules.
 

Offline Pseudobyte

  • Contributor
  • Posts: 42
  • Country: us
Re: Component clearance after rotating by 45°
« Reply #10 on: July 19, 2017, 07:14:26 AM »
Ahhh, I see what you mean. I don't know anybody who uses that placement feature, it is disabled by default so I am curious why you turned it on. Place with ignore obstacles on a grid. Placing on a grid will ensure a nice looking board and that the clearances will be ok. But yes I guess it is an issue, although not the issue this thread was originally about.
“They Don’t Think It Be Like It Is, But It Do”
 
The following users thanked this post: ^_^


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf