Low Cost PCB's Low Cost Components

Author Topic: Error DRC footprint  (Read 688 times)

0 Members and 1 Guest are viewing this topic.

Offline alex934

  • Contributor
  • Posts: 20
  • Country: fr
Error DRC footprint
« on: July 18, 2017, 01:09:54 AM »
Hi everyone,
I want to superpose an electrode on the bottom layer and a footprint of a microcontroler on the top layer.
I don't understand why when I superpose them, It start to be green like there were thru hole pad or something conflicting, but my footprint are SMD so nothing touch?!
Thank you for your help
 

Offline Pseudobyte

  • Contributor
  • Posts: 42
  • Country: us
Re: Error DRC footprint
« Reply #1 on: July 18, 2017, 11:49:15 PM »
I would imagine that the "Bottom" pad you are trying to place is actually a multilayer pad, which will generate pads on all layers. (or however you have the stack configured) I am also confused though because your color scheme reminds me of the keepout outline that appears when you define shapes as keepouts.
“They Don’t Think It Be Like It Is, But It Do”
 

Offline alex934

  • Contributor
  • Posts: 20
  • Country: fr
Re: Error DRC footprint
« Reply #2 on: July 19, 2017, 01:40:50 AM »
Well thank you for you answer,
What I do is: first I draw my shape of the electrode on the mechanical, then Tools->Convert->Create polygon from primitives, fill it with copper on the bottom layer. Then I add a pad SMD on the bottom layer.
« Last Edit: July 19, 2017, 06:26:20 AM by alex934 »
 

Offline Pseudobyte

  • Contributor
  • Posts: 42
  • Country: us
Re: Error DRC footprint
« Reply #3 on: July 19, 2017, 11:15:22 PM »
Ahhhhh I know what it is, how could I be so dumb. I should have known as soon as you said bottom layer, and when I saw your silkscreen.

Ok, so you really should build all of your footprints on the top layer, regardless of whether they will be on the bottom of the board. Here is why, when you build a footprint on the top layers you are consistent across all of your libraries, and pretty much any library you will find. This is important because when you place a component whether you built it on the bottom or top, it will be placed on the top of the board. This means that the component body clearance is on the top of the board. This is why you are getting a collision error. Altium thinks that component is on the top of the board, when in reality you want it on the bottom. The solution is to draw your footprint on the top layers and then place and lower it to the bottom of the board pressing the L key while dragging it. Note the difference between the custom pad I made and then lowered.
“They Don’t Think It Be Like It Is, But It Do”
 
The following users thanked this post: Someone

Offline alex934

  • Contributor
  • Posts: 20
  • Country: fr
Re: Error DRC footprint
« Reply #4 on: July 22, 2017, 03:15:18 AM »
Oww, you are right, that's explain lot of things, when I was looking at the property of my component I did understand why it was on "top layer"  while my actual footprint was on the bottom.
Thank you very much
 

Offline SVFeingold

  • Regular Contributor
  • *
  • Posts: 109
  • Country: us
Re: Error DRC footprint
« Reply #5 on: July 25, 2017, 03:04:38 PM »
I'm curious why you used local fiducials on this part, it doesn't seem too fine pitch.
 

Offline T3sl4co1l

  • Super Contributor
  • ***
  • Posts: 8687
  • Country: us
  • Expert, Analog Electronics, PCB Layout, EMC
    • Seven Transistor Labs
Re: Error DRC footprint
« Reply #6 on: July 25, 2017, 11:29:13 PM »
Speaking of layers: if you are using mechanical layers for assembly or 3D information, don't forget to go to the Layers dialog, show unused mechanical layers, and enable a few extras.  Then, on the PCB view, right-click the layer tabs and select Mechanical Layer Pairs.  Add pairs for each layer in use.

Now when you flip a component, its mechanical layers will flip to another layer.  Use those layers for assembly outputs to show only components on the top or bottom.

If you placed components on the bottom before assigning pairs, you will need to update those footprints from the library.

Tim
Seven Transistor Labs, LLC
Electronic Design, from Concept to Layout.
Need engineering assistance? Drop me a message!
 

Offline NANDBlog

  • Super Contributor
  • ***
  • Posts: 3259
  • Country: be
Re: Error DRC footprint
« Reply #7 on: July 25, 2017, 11:39:45 PM »
Then, on the PCB view, right-click the layer tabs and select Mechanical Layer Pairs.  Add pairs for each layer in use.
Wow, useful feature that I havent used yet. I'm gonna check it out.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf