Low Cost PCB's Low Cost Components

Author Topic: Problem with deleting polygon pours  (Read 446 times)

0 Members and 1 Guest are viewing this topic.

Offline knapik

  • Contributor
  • Posts: 7
  • Country: au
Problem with deleting polygon pours
« on: August 07, 2017, 08:29:00 PM »
I'm a bit stumped having a problem with polygon pours, I can see in the polygon manager that I have polygon pours, however I can't see or select them. How would I go about in deleting them as I currently don't want them?
 

Offline Pseudobyte

  • Contributor
  • Posts: 42
  • Country: us
Re: Problem with deleting polygon pours
« Reply #1 on: August 07, 2017, 10:36:43 PM »
Just right click the polygon in the manager and hit delete.
« Last Edit: August 07, 2017, 10:39:49 PM by Pseudobyte »
“They Don’t Think It Be Like It Is, But It Do”
 

Offline mrjiffy6

  • Contributor
  • Posts: 10
  • Country: ca
Re: Problem with deleting polygon pours
« Reply #2 on: August 07, 2017, 10:59:06 PM »
Make sure you have the right layer selected in order to be able to select/delete them (in the PCB editing view).

EDIT: if you are strictly talking about the Polygon Manager, if you can't see them it is likely that there are no vertices in the polygon pour!. I don't know your altium version, but in v16 the delete key does not seem to work. However, if you select the polygon pour in the upper list (make sure you click anywhere but the first column because it will edit the pour name), right click -> delete works.
« Last Edit: August 07, 2017, 11:05:22 PM by mrjiffy6 »
 

Offline kiran_shrestha

  • Regular Contributor
  • *
  • Posts: 58
  • Country: kr
  • Kiran
    • shorted wire
Re: Problem with deleting polygon pours
« Reply #3 on: August 08, 2017, 02:51:01 PM »
Hey, may be you have disabled the polygon layers, try hitting L and then make the polygons radio to FINAL.
-------------------------------------------------------------
Thats all
 

Online T3sl4co1l

  • Super Contributor
  • ***
  • Posts: 8701
  • Country: us
  • Expert, Analog Electronics, PCB Layout, EMC
    • Seven Transistor Labs
Re: Problem with deleting polygon pours
« Reply #4 on: August 09, 2017, 11:30:54 AM »
If they are shelved, they won't show up in the workspace.

You can also select polygons with the PCB Filter Panel and the query: IsPoly

Tim
Seven Transistor Labs, LLC
Electronic Design, from Concept to Layout.
Need engineering assistance? Drop me a message!
 

Offline knapik

  • Contributor
  • Posts: 7
  • Country: au
Re: Problem with deleting polygon pours
« Reply #5 on: August 09, 2017, 07:51:26 PM »
Yeah, I must not have tried right clicking and instead mashed the delete key, but that solved that problem. Thank you.

However, I'm unfortunately still having some issues. I've noticed that now, the interactive routing net lines aren't displaying for nets other than ground, and that if I were to actually create another ground plane polygon pour, I can't actually see it in the 2d view.
 

Online T3sl4co1l

  • Super Contributor
  • ***
  • Posts: 8701
  • Country: us
  • Expert, Analog Electronics, PCB Layout, EMC
    • Seven Transistor Labs
Re: Problem with deleting polygon pours
« Reply #6 on: August 09, 2017, 08:02:34 PM »
Ratsnesting is a net property.  You can find this under Design / Edit Nets, or by inspecting net objects.  Nets aren't physical objects on the PCB, but you can still query, select and edit them with the Filter, List and Inspector panels.  There's also the N shortcut (show/hide nets) which may be most helpful.

Tim
Seven Transistor Labs, LLC
Electronic Design, from Concept to Layout.
Need engineering assistance? Drop me a message!
 

Offline knapik

  • Contributor
  • Posts: 7
  • Country: au
Re: Problem with deleting polygon pours
« Reply #7 on: August 09, 2017, 08:17:08 PM »
Ah, yep, hiding and showing all connections seemed to do the trick for the rats nesting, thank you.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf