Author Topic: EEVblog #1035 - Flaming DIY Power Supply  (Read 9940 times)

0 Members and 1 Guest are viewing this topic.

Offline Valley

  • Contributor
  • Posts: 5
  • Country: hu
Re: EEVblog #1035 - Flaming DIY Power Supply
« Reply #50 on: November 20, 2017, 06:47:09 am »
I have a PS built on an earlier DPS5015 (non communicating) model fed from a 750VA torroid. It is working perfect.

I have measured with my scope the output of the PS (attached is a screenshot). CH1 is connected to DPS5015 negative, CH2 probe to +. Crocodile clips are attached to the scope earth (same potential as the metal case of the PS as Dave earlier showed in his video about scope safety).

What I see is when PS power is on (DC output of DPS5015 is still off) on both channels there is a sine wave: Pk-Pk=278V, Max=142V, Min=-138V, RMS=94V, f=49.85Hz absolutely overlaping. So, there is no potential difference between the thwo output leads.

When I turn the DC output on and crank the voltage up, the two waves are separating as you can see on the sreenshot. Mesurment is on for CH1, MATH is calculating CH1-CH2.

Readings of CH1 and CH2 (not visible on the picture) at 50VDC output with no load: CH1/CH2, Pk-Pk=278/278V,  Max=166/116V, Min=-112/-166V, Ampl=280/280V, RMS=98.9/96.8V.

MATH: Pk-Pk=4V, Max=52V, Min=48V, Ampl=4V, Mean=50V. This is the white line. So, there you have the 50VDC output.

Question: DPS5015 is said to be a buck converter, but it seems to (me) operate different.

Could someone more experienced put some light on basic operating principle, please or direct me to a site describing it.

If it is unic, we may ask Dave to do a review sometimes.



 

Offline plazma

  • Frequent Contributor
  • **
  • Posts: 434
  • Country: fi
    • Homepage
Re: EEVblog #1035 - Flaming DIY Power Supply
« Reply #51 on: November 20, 2017, 08:49:10 am »
I have a PS built on an earlier DPS5015 (non communicating) model fed from a 750VA torroid. It is working perfect.

I have measured with my scope the output of the PS (attached is a screenshot). CH1 is connected to DPS5015 negative, CH2 probe to +. Crocodile clips are attached to the scope earth (same potential as the metal case of the PS as Dave earlier showed in his video about scope safety).

What I see is when PS power is on (DC output of DPS5015 is still off) on both channels there is a sine wave: Pk-Pk=278V, Max=142V, Min=-138V, RMS=94V, f=49.85Hz absolutely overlaping. So, there is no potential difference between the thwo output leads.

When I turn the DC output on and crank the voltage up, the two waves are separating as you can see on the sreenshot. Mesurment is on for CH1, MATH is calculating CH1-CH2.

Readings of CH1 and CH2 (not visible on the picture) at 50VDC output with no load: CH1/CH2, Pk-Pk=278/278V,  Max=166/116V, Min=-112/-166V, Ampl=280/280V, RMS=98.9/96.8V.

MATH: Pk-Pk=4V, Max=52V, Min=48V, Ampl=4V, Mean=50V. This is the white line. So, there you have the 50VDC output.

Question: DPS5015 is said to be a buck converter, but it seems to (me) operate different.

Could someone more experienced put some light on basic operating principle, please or direct me to a site describing it.

If it is unic, we may ask Dave to do a review sometimes.
Looks strange. How did you rectify the toroid output?
 

Offline Valley

  • Contributor
  • Posts: 5
  • Country: hu
Re: EEVblog #1035 - Flaming DIY Power Supply
« Reply #52 on: November 20, 2017, 11:28:54 pm »
Have full wave rectifier and a big electrolite cap. On primary installed a soft starter circuit. Otput is 60.5VDC. Just at the max. input for DPS5015.
The measured voltages look really stange. The freq is equal to the mains. As soon it was a used transformer now I suspect it leaking mains  voltage to the ground (metal case of the unit). Maybe caused by insufficient insulation resistance of the transformer or other short. I think this is a possible fault. If there is not enough current flowing to blow the fuse, it may continue working, but if so it is life dangerous. So, I plan to open up, disconnect sensitive parts, make an insulation resistance test of the toroid.
Do you think I am on the right track? Many thanks for you help.
Sorry, that it is out of topic here, because I am moving from DPS5015 to troubleshooting the PSU supplying the input to it.
 

Offline StillTrying

  • Super Contributor
  • ***
  • Posts: 1415
  • Country: gb
  • 100% Brand New and High Quality, in theory.
Re: EEVblog #1035 - Flaming DIY Power Supply
« Reply #53 on: November 21, 2017, 12:09:22 am »
Have full wave rectifier and a big electrolite cap. On primary installed a soft starter circuit. Otput is 60.5VDC. Just at the max. input for DPS5015.
The measured voltages look really stange. The freq is equal to the mains. As soon it was a used transformer now I suspect it leaking mains  voltage to the ground (metal case of the unit). Maybe caused by insufficient insulation resistance of the transformer or other short. I think this is a possible fault. If there is not enough current flowing to blow the fuse, it may continue working, but if so it is life dangerous. So, I plan to open up, disconnect sensitive parts, make an insulation resistance test of the toroid.

If you have everything floating on the TX secondary side it could be just normal mains leakage across the transformer.
You could try a 10k between the scope probe's signal and GND clip to see if there's any current behind it.

Offline ogden

  • Super Contributor
  • ***
  • Posts: 1128
  • Country: lv
Re: EEVblog #1035 - Flaming DIY Power Supply
« Reply #54 on: November 21, 2017, 01:11:57 am »
If you have everything floating on the TX secondary side it could be just normal mains leakage across the transformer.

Exactly.

I have measured with my scope the output of the PS (attached is a screenshot). CH1 is connected to DPS5015 negative, CH2 probe to +. Crocodile clips are attached to the scope earth (same potential as the metal case of the PS as Dave earlier showed in his video about scope safety).

You misenterpreted scope safety video. In short - you are measuring isolation leakage using scope. Usually you will find some, especially using 1:10 probe, but this is not how it shall be measured. Better check isolation of your supply (transformer) using just multimeter in AC current mode.

To see output ripple of isolated ([edit] with both "+" and "-" terminals floating against scope ground ) supply, you just use single channel of the scope, AC coupling, 1:1 probe. Tip to "+" and ground crocodile/clip to "-".
« Last Edit: November 21, 2017, 01:35:02 am by ogden »
 

Offline Valley

  • Contributor
  • Posts: 5
  • Country: hu
Re: EEVblog #1035 - Flaming DIY Power Supply
« Reply #55 on: November 21, 2017, 05:53:54 am »
Made some checks as directed.
Everything is floating on the secondary, it is sure.
Mesurments taken at unit power on, DC output off:
No current flows from any of the DC outputs to the ground.
Voltmeter still mesures 101VAC between both, - and + DC leads and ground (=PSU metal case=earth).

So, is that correct I am seeing on the scope CH1 and CH2 (picture in the first post) normal mains leakage across the transformer going through the full wave rectifier, elco cap, DPS5015 and so to both, + and - DC output leads?

Leak of mains through the failing isolation of the transformer to the ground is excluded?

If that is correct the unit is working perfect and we should not repair what never went wrong? :-)

Made a a ripple test far all interested in DPS5015 performance. Load is a 12V, 10W halogen bulb.
Screenshot of the scope is attached with maths on. Ripple=around 400mV

Thank you all helping.


 

Offline ChrisLX200

  • Supporter
  • ****
  • Posts: 462
  • Country: gb
Re: EEVblog #1035 - Flaming DIY Power Supply
« Reply #56 on: November 21, 2017, 06:49:14 am »
Frequency is similar to what I saw (67KHz) but ripple is more than 10x what I get @ 31mV
 

Offline plazma

  • Frequent Contributor
  • **
  • Posts: 434
  • Country: fi
    • Homepage
Re: EEVblog #1035 - Flaming DIY Power Supply
« Reply #57 on: November 21, 2017, 07:02:59 am »
Frequency is similar to what I saw (67KHz) but ripple is more than 10x what I get @ 31mV
Maybe the probe setting is wrong 1x vs. 10x.
 

Offline ChrisLX200

  • Supporter
  • ****
  • Posts: 462
  • Country: gb
Re: EEVblog #1035 - Flaming DIY Power Supply
« Reply #58 on: November 21, 2017, 07:12:09 am »
Quote from: plazma on Today at 07:02:59 AM>Quote from: ChrisLX200 on Today at 06:49:14 AM
Frequency is similar to what I saw (67KHz) but ripple is more than 10x what I get @ 31mV
Maybe the probe setting is wrong 1x vs. 10x.



My Tek TDS3014B scope automatically detects if I'm using 1x or 10x probes, can't make that mistake..
 

Offline ogden

  • Super Contributor
  • ***
  • Posts: 1128
  • Country: lv
Re: EEVblog #1035 - Flaming DIY Power Supply
« Reply #59 on: November 21, 2017, 07:14:48 am »
Voltmeter still mesures 101VAC between both, - and + DC leads and ground (=PSU metal case=earth).

Voltage measurement does not tell much. You have to measure AC current. Shall not exceed 210 micro amperes:  https://en.wikipedia.org/wiki/Electrical_safety_testing

Regarding supply noise cannot comment - because do not have such (kind).
 

Offline plazma

  • Frequent Contributor
  • **
  • Posts: 434
  • Country: fi
    • Homepage
Re: EEVblog #1035 - Flaming DIY Power Supply
« Reply #60 on: November 21, 2017, 07:17:38 am »
Quote from: plazma on Today at 07:02:59 AM>Quote from: ChrisLX200 on Today at 06:49:14 AM
Frequency is similar to what I saw (67KHz) but ripple is more than 10x what I get @ 31mV
Maybe the probe setting is wrong 1x vs. 10x.



My Tek TDS3014B scope automatically detects if I'm using 1x or 10x probes, can't make that mistake..

I mean you and I got the ripple about the same and Valley got the probe settings wrong.
 

Offline Valley

  • Contributor
  • Posts: 5
  • Country: hu
Re: EEVblog #1035 - Flaming DIY Power Supply
« Reply #61 on: November 21, 2017, 08:08:45 am »
Probe is set to 1x (on the probe and the scope), but it is perhaps picking noise from all around.

You can see here in Dave's video, how much stuff is influencing this kind of mesurement and how to do it properly:



 Excellent work.
 

Offline Valley

  • Contributor
  • Posts: 5
  • Country: hu
Re: EEVblog #1035 - Flaming DIY Power Supply
« Reply #62 on: November 21, 2017, 10:38:51 am »
Made some checks as directed.
Everything is floating on the secondary, it is sure.
Mesurments taken at unit power on, DC output off:
No current flows from any of the DC outputs to the ground.
Voltmeter still mesures 101VAC between both, - and + DC leads and ground (=PSU metal case=earth).

So, is that correct I am seeing on the scope CH1 and CH2 (picture in the first post) normal mains leakage across the transformer going through the full wave rectifier, elco cap, DPS5015 and so to both, + and - DC output leads?

Leak of mains through the failing isolation of the transformer to the ground is excluded?

If that is correct the unit is working perfect and we should not repair what never went wrong? :-)

Made a a ripple test far all interested in DPS5015 performance. Load is a 12V, 10W halogen bulb.
Screenshot of the scope is attached with maths on. Ripple=around 400mV

Thank you all helping.

Voltmeter still mesures 101VAC between both, - and + DC leads and ground (=PSU metal case=earth).

Voltage measurement does not tell much. You have to measure AC current. Shall not exceed 210 micro amperes:  https://en.wikipedia.org/wiki/Electrical_safety_testing

Regarding supply noise cannot comment - because do not have such (kind).

I have done some more mesurements according to helping friends here in order to be on the safe side.

PSU power is on, voltmeter, AC current set to the smallest 2mA range gives on both leads 0.04mA. This is about five times less then 210microA, mentioned by ogden. If we divide the 101VAC RMS by this, we get 2.5MOhm. This is an acceptable velue for insulation resistance as well, I believe.

Also, I have done an insulation resistance test on the primary between the ground and the pins of the plug (mains switch on, of course) at 500VDC with Voltcraft ET-200 tester. It gives me resistance above range, 500MOhm, which is excellent.

If we would open it up one more insulation resistance test could be performed between primary and secondary windings, but for now I skip this. Do not want to dig into it, othervise testing could damage the converter.

Based on the above information perhaps we can conclude that the unit is not dangerous.

Thank you all again.

 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf