Author Topic: Element14 survey fail...  (Read 1228 times)

0 Members and 1 Guest are viewing this topic.

Online Geoff_S

  • Contributor
  • Posts: 47
  • Country: au
Element14 survey fail...
« on: May 03, 2017, 08:38:53 AM »
Anyone else receive an email from Element14 with the subject "Help Make CircuitStudio a Better Product & Receive 10% Off" ?  I received one yesterday, saying that if I completed the survey, they'd offer 10% off CircuitStudio.  Although I'm not really that interested in CS, I thought I'd provide some feedback so I clicked on the link to the survey, but the resulting web page says that it's unable to find the survey.  Perhaps it's just my PC...


Offline Dubbie

  • Supporter
  • ****
  • Posts: 595
Re: Element14 survey fail...
« Reply #1 on: May 03, 2017, 08:52:28 AM »
I get broken links all the time from them in their marketing emails.
I got one today "Click to see T&M stuff that has had massive price cuts!"

Nice job Element14 marketing..


Offline bill.coghill

  • Contributor
  • Posts: 13
Re: Element14 survey fail...
« Reply #2 on: May 03, 2017, 11:25:27 AM »
Also the fact the email talks about the new v1.3 coming soon.  I've been running 1.4 for couple of months now.
Maybe it got caught in their own spam filter !


Offline pwenzel

  • Newbie
  • Posts: 3
  • Country: us
Re: Element14 survey fail...
« Reply #3 on: May 05, 2017, 09:17:23 AM »

Apologies, this is an error on our end that is being fixed.  If you would like to take advantage of the 10% discount you are more then welcome too; it is "ACS10".

Pete Wenzel

Offline onesixright

  • Frequent Contributor
  • **
  • Posts: 377
  • Country: nl
Re: Element14 survey fail...
« Reply #4 on: May 14, 2017, 03:30:19 AM »
Yup got the same email (and error).

I already bought a license, but with a different email. So whats the reward if you already bought  ;) ?

They still think (not so strange) i'm in trial mode  :D

Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo