Author Topic: Ground plane not connecting with pin  (Read 10550 times)

0 Members and 1 Guest are viewing this topic.

Offline joegtp

  • Contributor
  • Posts: 30
Ground plane not connecting with pin
« on: February 29, 2012, 09:03:46 am »
I tried asking this question over here: but that forum seems to be a bit of a ghost town.

I'm trying to connect my ground to a LQFP-64 (10x10mm) but it doesn't seem to want to connect in Eagle 6.1.0. This used to work fine in 5.10.0. I have the polygon isolate set to 0. My DRC supply thermal isolation is set to 10mil. I've tried reducing the isolation but it still won't connect. Here is a screenshot of what I'm seeing.  If I route a wire from the pin to anywhere on the ground plane and then run DRC it works fine but this is kind of a pain.

See the attached image

Offline Neganur

  • Supporter
  • ****
  • Posts: 1083
  • Country: fi
Re: Ground plane not connecting with pin
« Reply #1 on: February 29, 2012, 08:07:20 pm »
Not sure I understood your problem: you don't like the ratnest-airwire still showing even though the plane is properly connected?

I had to use eagle in a recent joint venture university project. I ended up right-clicking the GND connection and hide all airwires for that signal.

Online senso

  • Frequent Contributor
  • **
  • Posts: 861
  • Country: pt
    • My AVR tutorials
Re: Ground plane not connecting with pin
« Reply #2 on: March 01, 2012, 12:52:46 am »
Usually when I have those strange ground ratsnest in Eagle is because somewhere there is a break in the ground-plane, or between the top and bottom groundplane, yes Eagle is not very smart giving some indications.

Offline joegtp

  • Contributor
  • Posts: 30
Re: Ground plane not connecting with pin
« Reply #3 on: March 01, 2012, 10:40:59 am »
@Neganur That is correct. The ground plane is connected correctly and it's still showing an airwire for that connection. If I create a small wire coming from the package out to the ground plane it connect correctly but that's a pain especially as you move the part around.

Turning off airwires for GND doesn't seem like a good idea to me. When running the ratsnest tool you loose the ability to tell when all the airwires are connected.

Offline Write_to_Smokegenerator

  • Regular Contributor
  • *
  • Posts: 52
  • Country: at
  • enthused hobbyist
Re: Ground plane not connecting with pin
« Reply #4 on: March 02, 2012, 08:25:23 pm »
ohh that problem, i encountered it last week so many times, i'm still not quite sure what it is, but i had diffrent solutions, here are my thoughts:

Is the Ground plane really connected or is there a break so the entire area is not connected to the GND (had that problem a few times because i rerouted lines)?
Sometimes it does that because there is a little bit of an unrouted line left (f.e if you routed a line and moved it arround and after a few tries you deleted it, there can be a little line left and Eagle wants that line connected)
and finally sometimes i didn't come up with an explanation and it miracally solved itselve  ::)

Maybe this helps you a little
Wondering about my Username have a look at:

Offline andersendr

  • Regular Contributor
  • *
  • Posts: 56
  • Country: us
Re: Ground plane not connecting with pin
« Reply #5 on: March 04, 2012, 12:12:53 pm »
I think the solution is quite clear.  Eagle needs to have the PCB trace go to the center of the pad.  Even though the trace in the picture is touching the pad, it does not consider it connected.  I would rip up what is there, start the trace from the pad, and then draw out to the GND plane.  Make sure you use the Ratsnest command to make it re calculate the airwire if it is still there.  Another option is to just manually run the wire, then if it is connected and you use the Ratsnest command, the airwire will go away.  Now this is all for Eagle 5, but I would assume it's the same.

Offline joegtp

  • Contributor
  • Posts: 30
Re: Ground plane not connecting with pin
« Reply #6 on: March 04, 2012, 12:39:21 pm »
@andersendr that's the thing I tried recreating the problem in Eagle 5 and couldn't.  I created a PCB layout with the LQFP and resistor just what I have shown and it doesn't show an airwire.  I then took that same layout and opened it in Eagle 6 and it shows the airwire. I think I'm just going to stick with Eagle 5 for now.

Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo