Author Topic: Rat's nest doesn't see ground pour? - Eagle 7.0  (Read 2686 times)

0 Members and 1 Guest are viewing this topic.

Offline Mayo2017

  • Contributor
  • Posts: 13
  • Country: 00
Rat's nest doesn't see ground pour? - Eagle 7.0
« on: July 22, 2014, 08:21:39 pm »
Well, here's one I've never encountered before. Working on the board for a little TSSOP breakout of mine, got a nice ground pour going, should be great, right?

Guess not. 2 Vss pins and some of the SMD caps are pretending that the ground pour isn't even a thing. It connects to the pads just fine, but then it's like the rat's nest can't find the entire ground plane.  ???

I haven't punched any vias to connect the top and bottom pours, but it shouldn't matter, since it's a solid piece of copper up top (let's forget about noisy grounds and such for now). The pads are physically touching the copper, but it acts like no connection is being made.

Anyone else hit this issue?

Ground airwires highlighted in (garish) green.
 

Offline liquibyte

  • Frequent Contributor
  • **
  • Posts: 475
  • Country: us
Re: Rat's nest doesn't see ground pour? - Eagle 7.0
« Reply #1 on: July 23, 2014, 12:36:13 am »
Right click > properties > check airwires hidden on the yellow ratsnest connected to the signal maybe?
 

Offline Monkeh

  • Super Contributor
  • ***
  • Posts: 5665
  • Country: gb
Re: Rat's nest doesn't see ground pour? - Eagle 7.0
« Reply #2 on: July 23, 2014, 12:56:01 am »
It has to pour to the centre of the pads to 'connect'. It's possible your polygon size and clearance settings are preventing this.

You can simply draw a trace out from the pad to connect if you wish.
 

Offline gxti

  • Frequent Contributor
  • **
  • Posts: 507
  • Country: us
Re: Rat's nest doesn't see ground pour? - Eagle 7.0
« Reply #3 on: July 23, 2014, 02:51:57 am »
Looks like your polygon connections are thicker than the pads are wide. Try reducing the spoke width to 8 mils. I don't use Eagle so I couldn't tell you specifically how.
 

Offline Mayo2017

  • Contributor
  • Posts: 13
  • Country: 00
Re: Rat's nest doesn't see ground pour? - Eagle 7.0
« Reply #4 on: July 23, 2014, 05:18:48 am »
It has to pour to the centre of the pads to 'connect'. It's possible your polygon size and clearance settings are preventing this.

Well, messing with those actually helped. Odd, I used the same package and design rules previously and it worked just fine. Still leaves some confusion on what's going on with the caps on the right side, never had that happen either.

Oh well. Bit of a bodge, but I just hid the airwires that were affected, since the physical connections are more than adequate for this job. Thanks, all! :-+
 

Offline Vasi

  • Regular Contributor
  • *
  • Posts: 60
  • Country: ro
    • Visual Pin Configurator for Nucleo L152RE - produces SPL code.
Re: Rat's nest doesn't see ground pour? - Eagle 7.0
« Reply #5 on: December 01, 2014, 03:49:33 pm »
The rats always pour on ground, no matter how high is the nest.  :)
 

Offline nitro2k01

  • Frequent Contributor
  • **
  • Posts: 844
  • Country: 00
Re: Rat's nest doesn't see ground pour? - Eagle 7.0
« Reply #6 on: December 01, 2014, 03:59:58 pm »
In my opinion it's still good practice to fill in the ground connections with a trace, so you're not thinking that the ground plane will fill it up, but then accidentally leave an island unconnected.
Whoa! How the hell did Dave know that Bob is my uncle? Amazing!
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf