Author Topic: [KiCAD]-libraries not found  (Read 3587 times)

0 Members and 1 Guest are viewing this topic.

Offline Bucki

  • Newbie
  • Posts: 3
  • Country: de
[KiCAD]-libraries not found
« on: October 31, 2017, 10:35:23 pm »
Hello guys,

I've got a little problem with adding the KiCAD master library from github https://github.com/KiCad/kicad-library . I'm using the newest stable release of KiCAD (4.0.7 if I'm right  ;D ) on Linux Mint.
At first I downloaded the whole package with all items in it and then created my own KiCAD workspace folder for all projects and so on. After that I started KiCAD and modified the environment paths for the templates, libraries, modules and 3D packages. But when I open the schematic window, it shows a warning window which says, that there weren't any libraries found. And if I want to add any part/component there is really an empty window. Can anyone help me with this? Or do you guys know any step by step instruction of how to add the master library? 



Thanks for your help!  :)

Cheers,
Bucki
 

Offline ElektroQuark

  • Supporter
  • ****
  • Posts: 1206
  • Country: es
    • ElektroQuark
Re: [KiCAD]-libraries not found
« Reply #1 on: October 31, 2017, 10:41:38 pm »
Can you post the environment paths values within KiCad?

You have to "load" the libraries in Eeschema. Take a look at Eeschema->Preferences->Component Libraries
There you have to add the libraries you want to use.
« Last Edit: October 31, 2017, 10:47:58 pm by ElektroQuark »
 

Offline donotdespisethesnake

  • Frequent Contributor
  • **
  • Posts: 830
  • Country: gb
  • Embedded stuff
Re: [KiCAD]-libraries not found
« Reply #2 on: October 31, 2017, 11:57:52 pm »
KiCad libraries have recenly been extensively renamed, so I would advise caution when updating from github/master. Also, are you using release 4.0.7 or a nightly build? It looks like you are using a nightly build, which has new features for symbol library tables.
Bob
"All you said is just a bunch of opinions."
 

Offline hermit

  • Frequent Contributor
  • **
  • Posts: 469
  • Country: us
Re: [KiCAD]-libraries not found
« Reply #3 on: November 01, 2017, 02:13:27 am »
Kicad is currently rethinking the entire library structure to make it more intuitive and consistent. Library questions are easily the single most discussed topic on the Kicad forum at the moment for a variety of reasons.  The forum is pretty active and a good place to get help or pick up pointers.
 

Offline Bucki

  • Newbie
  • Posts: 3
  • Country: de
Re: [KiCAD]-libraries not found
« Reply #4 on: November 01, 2017, 06:05:40 pm »
At first thanks for your answers! :)

At the moment I really just configured the environment paths as shown:


from the folder located here:



And yes I'm using the recent stable version of KiCAD, because I've got the same problems with the nigthly build. So I decided to use the stable version, but..ehh.. same probs here.  :-DD

So you think after configuring the environment paths, I also have to add those libraries via the eeschema? Same procedure for footprints and 3D packages?

Cheers,
Bucki
 

Offline donotdespisethesnake

  • Frequent Contributor
  • **
  • Posts: 830
  • Country: gb
  • Embedded stuff
Re: [KiCAD]-libraries not found
« Reply #5 on: November 02, 2017, 09:18:51 pm »
KiCad stable (4.0.7) does not support environment paths for symbols. KiCad stable can only use the installed directory for symbols, if you want to upgrade the symbols you need to find that directory and copy files into it.
Bob
"All you said is just a bunch of opinions."
 

Offline ElektroQuark

  • Supporter
  • ****
  • Posts: 1206
  • Country: es
    • ElektroQuark
Re: [KiCAD]-libraries not found
« Reply #6 on: November 02, 2017, 10:58:40 pm »
Please, post an image of this:

Eeschema->Preferences->Component Libraries

Offline Bucki

  • Newbie
  • Posts: 3
  • Country: de
Re: [KiCAD]-libraries not found
« Reply #7 on: November 11, 2017, 09:48:51 pm »
Sorry for not answering a while. I now solved my problem with the answer of donotdespisethesnake and therefore copied all the needed things to the directories. All works now, but eh...real pain in the a**  :-- I hope they fix it as soon as possible.

Cheers
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf