Author Topic: KiCad 5 Assigning foot freezes?  (Read 553 times)

0 Members and 1 Guest are viewing this topic.

Offline Floopy

  • Regular Contributor
  • *
  • Posts: 105
  • Country: us
KiCad 5 Assigning foot freezes?
« on: October 16, 2018, 04:33:01 am »
I recently upgraded to KiCad version 5. So far it's been okay but every time I try to assign a footprint to a component, it just freezes up and about 30 seconds later it just pulls up a blank list. I've tried uninstalling it and reinstalling it with not luck. I can't find anybody else mentioning this problem. What's happening? I have a project that I need to finish soon.
 :scared:
-Floopy
 

Offline awallin

  • Frequent Contributor
  • **
  • Posts: 450
Re: KiCad 5 Assigning foot freezes?
« Reply #1 on: October 16, 2018, 04:54:49 am »
do you have (good) internet connectivity with ports and IPs/firewalls allowing git-access to github?
it may try to update from github every time you start the assigning-tool from schematic-editor.

the workaround may be to download libraries to local files and point your library table there instead of github.
 
The following users thanked this post: Floopy

Offline Floopy

  • Regular Contributor
  • *
  • Posts: 105
  • Country: us
Re: KiCad 5 Assigning foot freezes?
« Reply #2 on: October 16, 2018, 07:06:58 am »
I downloaded the libraries and deleted the github.xxx ones. It seems to be working now? I have a very fast internet connection, I have about 40mbps.
Well it works, that's the essential. Thanks!  :-+
-Floopy
 

Offline MarkR42

  • Contributor
  • Posts: 5
  • Country: gb
Re: KiCad 5 Assigning foot freezes?
« Reply #3 on: November 13, 2018, 04:05:56 am »
I am pretty sure I've seen that bug and it has already been reported; the footprint "filter by number of pins" seems broken and hangs the app for several seconds. Fortunately it's usually possible to use the filter-by-name feature (which still works).

https://bugs.launchpad.net/kicad/+bug/1801622

They are claiming it's fixed in the nightly build (see link)
 

Offline SiliconWizard

  • Super Contributor
  • ***
  • Posts: 1086
  • Country: fr
Re: KiCad 5 Assigning foot freezes?
« Reply #4 on: November 13, 2018, 04:48:35 am »
Probably similar to that: http://www.eevblog.com/forum/kicad/footprint-association-tool/

Removing the 'fp-lib-table' file usually does the trick. It's in the user's config. directory (on Windows, it's 'C:\Users\XXX\AppData\Roaming\kicad').
 
The following users thanked this post: MarkR42

Offline MarkR42

  • Contributor
  • Posts: 5
  • Country: gb
Re: KiCad 5 Assigning foot freezes?
« Reply #5 on: November 16, 2018, 03:19:08 am »
That was an amazingly good tip, it's fixed!

Bravo.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf