Author Topic: KiCAD 5 workflow broken (Library files  (Read 1725 times)

0 Members and 1 Guest are viewing this topic.

Offline CM800

  • Frequent Contributor
  • **
  • Posts: 875
  • Country: 00
KiCAD 5 workflow broken (Library files
« on: August 30, 2018, 01:01:51 am »
Hi All,

I have had a second file in my dropbox which contains all my custom libraries, this is linked through so that I can access my custom parts from work, home & laptop.

The new system doesn't seem to allow me to add this file in.

What's going on here? this is really not good.
 

Offline Bassman59

  • Super Contributor
  • ***
  • Posts: 1092
  • Country: us
  • Yes, I do this for a living
Re: KiCAD 5 workflow broken (Library files
« Reply #1 on: August 30, 2018, 04:09:23 am »
Hi All,

I have had a second file in my dropbox which contains all my custom libraries, this is linked through so that I can access my custom parts from work, home & laptop.

The new system doesn't seem to allow me to add this file in.

What's going on here? this is really not good.

Need more info. What OS?
 

Offline CM800

  • Frequent Contributor
  • **
  • Posts: 875
  • Country: 00
Re: KiCAD 5 workflow broken (Library files
« Reply #2 on: August 30, 2018, 06:41:08 pm »
Hi All,

I have had a second file in my dropbox which contains all my custom libraries, this is linked through so that I can access my custom parts from work, home & laptop.

The new system doesn't seem to allow me to add this file in.

What's going on here? this is really not good.

Need more info. What OS?

Running Winblows 10 with 'Oogle Drive
 

Offline donotdespisethesnake

  • Frequent Contributor
  • **
  • Posts: 794
  • Country: gb
  • Embedded stuff
Re: KiCAD 5 workflow broken (Library files
« Reply #3 on: August 31, 2018, 05:54:47 am »
Quote
I have had a second file in my dropbox which contains all my custom libraries

Do you mean a folder containing libraries?

Jus a wild guess but you probably need to add the symbol libraries to the symbol table.
Bob
"All you said is just a bunch of opinions."
 

Offline CM800

  • Frequent Contributor
  • **
  • Posts: 875
  • Country: 00
Re: KiCAD 5 workflow broken (Library files
« Reply #4 on: August 31, 2018, 09:23:55 pm »
Dang,

i just wanted to include the whole folder of libraries like you used to be able to. :(
 

Offline donotdespisethesnake

  • Frequent Contributor
  • **
  • Posts: 794
  • Country: gb
  • Embedded stuff
Re: KiCAD 5 workflow broken (Library files
« Reply #5 on: September 01, 2018, 02:06:26 am »
In the symbol library manager, click "open"
select the libs you want
press OK

Not hard.

Tip: in your file explorer, search for "*.lib" then select all the search results.
Bob
"All you said is just a bunch of opinions."
 

Offline G0MJW

  • Contributor
  • Posts: 39
  • Country: gb
  • Mike
    • G0MJW
Re: KiCAD 5 workflow broken (Library files
« Reply #6 on: September 08, 2018, 01:44:44 am »
5.0.0 is completely broken for me under Windows 10. On a fresh install, the libraries are all completely empty, though the actual files are there. I assume this is some conflict with the removed previous version 4 but I have no idea what. It really ought to work with a fresh install!

EDIT - DAMN Microsoft and their idiot programmers. There was a kicad file in users/.../Appdata/roaming/kicad that prevented V5 from doing it's first run setup.

How I hate Microsoft for doing this. Making such a useless system that purposefully puts stuff in the wrong place. If I had a $100Bn I would buy them out and sack all of them. Every single one.
« Last Edit: September 08, 2018, 02:09:00 am by G0MJW »
Mike
 

Offline hermit

  • Frequent Contributor
  • **
  • Posts: 468
  • Country: us
Re: KiCAD 5 workflow broken (Library files
« Reply #7 on: September 08, 2018, 02:15:36 am »
I don't do windows. ;)  But.  When I installed 5 I moved my config directory out of the way as a backup and did the reinstall.  I think it is an fp-lib-tables thing.  Don't quote me but on Windows there is something like a C:\users\whoever\roaming? that has the configuration files.
 

Offline SiliconWizard

  • Super Contributor
  • ***
  • Posts: 1482
  • Country: fr
Re: KiCAD 5 workflow broken (Library files
« Reply #8 on: September 08, 2018, 02:37:15 am »
I think this is what I mentioned here: http://www.eevblog.com/forum/kicad/footprint-association-tool/msg1659884/#msg1659884
(and that nobody seems to know about or is willing to tell you although it happens to a lot of KiCad users that are upgrading).

This is not a Windows problem whatsoever IMO. The same issue arises on Linux. This is the fact that KiCad's installer doesn't do squat to help migrating your user options and that KiCad stores libraries paths and info in the user options.

 

Offline SiliconWizard

  • Super Contributor
  • ***
  • Posts: 1482
  • Country: fr
Re: KiCAD 5 workflow broken (Library files
« Reply #9 on: September 08, 2018, 03:18:45 am »
I think it is an fp-lib-tables thing.  Don't quote me but on Windows there is something like a C:\users\whoever\roaming? that has the configuration files.

Yes, as I mentioned in the post I linked to above, this is in  'C:\Users\XXX\AppData\Roaming\kicad'. On Linux, it's in your home directory, usually under '.config/kicad'.

Remove the 'fp-lib-table' and 'sym-lib-table' files. You may also delete the whole directory but then you'll lose all your previous settings. Don't know if it really matters or not as they tend to change from major version to major version in sometimes unexpected ways, so starting from fresh user options might be a safer bet. ;)


 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf