Author Topic: Traces and copper pour going through pads  (Read 1373 times)

0 Members and 1 Guest are viewing this topic.

Offline sentry7

  • Regular Contributor
  • *
  • Posts: 138
  • Country: us
Traces and copper pour going through pads
« on: March 08, 2017, 06:45:49 AM »
Hey guys,

First-time KiCad user, and I am nothing short of impressed so far.

Question about the copper layer. So I have a simple dummy design here, and I've included a grounding plane on the top layer. When I hide the top pads, it shows copper pour and traces going through places where drilled holes would be. It even shows up on the 3D view. What's going on here?



 

Offline MarkS

  • Frequent Contributor
  • **
  • Posts: 520
  • Country: us
Re: Traces and copper pour going through pads
« Reply #1 on: March 08, 2017, 07:44:00 AM »
It is the way that KiCAD draws the polygons internally, although the 3D view is clearly a bug and needs to be fixed. This will not impact a finished board.
 

Offline Caio Negri

  • Contributor
  • Posts: 21
  • Country: br
Re: Traces and copper pour going through pads
« Reply #2 on: March 09, 2017, 12:42:39 AM »
Shouldn't make a difference in the manufacturing process since pads and traces get merged in the same gerber file anyway. 3D view should definitely not display that but I guess that is a low priority bug.
"Start where you are, use what you have, do what you can." - Arthur Ashe
 

Offline Deridex

  • Regular Contributor
  • *
  • Posts: 68
  • Country: de
Re: Traces and copper pour going through pads
« Reply #3 on: March 09, 2017, 03:51:31 PM »
I gotta agree on what the other 2 guys said:
While it seems to be a bug in the 3D view, i doubt it has any impact on the manufacturing process.
 

Offline richardlawson1489

  • Regular Contributor
  • *
  • Posts: 125
  • Country: us
    • PCB Assembly
Re: Traces and copper pour going through pads
« Reply #4 on: March 09, 2017, 03:57:42 PM »
What is the solution to solve this bug in 3D view?
 

Offline QuantumLogic

  • Contributor
  • Posts: 44
  • Country: us
Re: Traces and copper pour going through pads
« Reply #5 on: March 10, 2017, 08:08:30 AM »
In the 3D Viewer, go to Preferences-->Render Options and make sure "Show holes in zones" has a check mark to the left of it.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf