Author Topic: Debugging Atmel QTouch designs  (Read 644 times)

0 Members and 1 Guest are viewing this topic.

Offline v8dave

  • Regular Contributor
  • *
  • Posts: 85
  • Country: id
Debugging Atmel QTouch designs
« on: December 23, 2015, 12:06:31 am »
I am working on SAMD20 design with a number of touch inputs configured via QTouch in  Atmel Studio 7 and when I run the programme with the JTAG ICE3, I don't get any scanning of the touch inputs.

If I run the programme without the debugger and put a coin on the touch surface of one of the buttons, I can pickup the signal from the touch driver but if I run under the debugger, there is nothing.

Running without the debugger I can detect touch on the touch panel but again, under the debugger there is nothing running.

Is there anyone here used this micro with touch and had the same issue? (I will likely post this on one of the Atmel forums but though it might catch someones attention here)
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf