Author Topic: Forum Database Upgrade  (Read 11110 times)

0 Members and 2 Guests are viewing this topic.

Offline EEVblog

  • Administrator
  • *****
  • Posts: 27193
  • Country: au
    • EEVblog
Re: Forum Database Upgrade
« Reply #25 on: March 24, 2017, 06:45:18 pm »
I just got this error when going directly into the Test gear section. It only happened once.
I think we have seen this recently.

 

Offline gnif

  • Administrator
  • *****
  • Posts: 1043
  • Country: au
Re: Forum Database Upgrade
« Reply #26 on: March 24, 2017, 06:46:19 pm »
I just got this error when going directly into the Test gear section. It only happened once.
I think we have seen this recently.



It was me hacking in a order fix, a bug in the query, missing a conditional :), ordering is correct now.
« Last Edit: March 24, 2017, 06:49:45 pm by gnif »
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission

I volunteer my time to manage this server, if you would like to support this work I have a patreon here:
https://www.patreon.com/gnif
 

Offline EEVblog

  • Administrator
  • *****
  • Posts: 27193
  • Country: au
    • EEVblog
Re: Forum Database Upgrade
« Reply #27 on: March 24, 2017, 06:52:57 pm »
It was me hacking in a order fix, a bug in the query, missing a conditional :), ordering is correct now.

I've always been amazed how well SMF just handled this stuff, like it's bullet proof.
 

Offline EEVblog

  • Administrator
  • *****
  • Posts: 27193
  • Country: au
    • EEVblog
Re: Forum Database Upgrade
« Reply #28 on: March 24, 2017, 10:02:16 pm »
Some major sever changes have been done which at the moment can be selectively turned on for individual users.
If you'd like to help out testing this new upgrade please message or email gnif your IP address and it can be enabled.
This will affect the main website and the forum.
It's important to test it before it's enabled for everyone.
Thanks.
 

Offline Future soldier

  • Contributor
  • Posts: 6
  • Country: in
Re: Forum Database Upgrade
« Reply #29 on: March 25, 2017, 02:18:42 am »
fitst post of this thread if quoted gives bad gateway error

http://www.eevblog.com/forum/contests/keysight-scope-month-feedback/

idk the warning said not to report it but the problem seems to be of a specific post
 

Offline Future soldier

  • Contributor
  • Posts: 6
  • Country: in
Re: Forum Database Upgrade
« Reply #30 on: March 25, 2017, 02:20:46 am »
Some major sever changes have been done which at the moment can be selectively turned on for individual users.
If you'd like to help out testing this new upgrade please message or email gnif your IP address and it can be enabled.
This will affect the main website and the forum.
It's important to test it before it's enabled for everyone.
Thanks.
i am willing to participate
 

Online Richard Crowley

  • Super Contributor
  • ***
  • Posts: 4003
  • Country: us
  • KE7GKP
Re: Forum Database Upgrade
« Reply #31 on: March 25, 2017, 02:25:07 am »
fitst post of this thread if quoted gives bad gateway error

http://www.eevblog.com/forum/contests/keysight-scope-month-feedback/

idk the warning said not to report it but the problem seems to be of a specific post
It works fine for me (quoting it, etc.).
"Bad Gateway" doesn't sound like any kind of database-related problem to me.
 

Offline Future soldier

  • Contributor
  • Posts: 6
  • Country: in
Re: Forum Database Upgrade
« Reply #32 on: March 25, 2017, 02:27:15 am »
fitst post of this thread if quoted gives bad gateway error

http://www.eevblog.com/forum/contests/keysight-scope-month-feedback/

idk the warning said not to report it but the problem seems to be of a specific post
It works fine for me (quoting it, etc.).
"Bad Gateway" doesn't sound like any kind of database-related problem to me.
so its a loclised issue i gues, i know bad gateway doesnt seem to forum issue
 

Offline MatthewEveritt

  • Supporter
  • ****
  • Posts: 136
  • Country: gb
Re: Forum Database Upgrade
« Reply #33 on: March 25, 2017, 02:58:57 am »
The gateway error you see isn't specifically database related, but the root cause of the issue is. It's a universal law that error messages can't be too helpful  :P.

I'm more than happy to test things. The IP I'm posting from covers 99% of my forum use.
 

Online PA0PBZ

  • Super Contributor
  • ***
  • Posts: 3769
  • Country: nl
Re: Forum Database Upgrade
« Reply #34 on: March 25, 2017, 06:37:56 am »
I noticed that the unread replies link takes lots of time to load, by lots I mean up to 30 seconds  :-\

http://www.eevblog.com/forum/unreadreplies/
Keyboard error: Press F1 to continue.
 

Online T3sl4co1l

  • Super Contributor
  • ***
  • Posts: 11825
  • Country: us
  • Expert, Analog Electronics, PCB Layout, EMC
    • Seven Transistor Labs
Re: Forum Database Upgrade
« Reply #35 on: March 25, 2017, 07:37:47 am »
Hmm, a bump in the road, just a moment ago (524 timeout), but it's fine now.  Also had a couple 502s and outages the other day, but obviously, you Aussie bastards were doing the maintenance at local downtime, which is primetime for us... so inconsiderate  :horse:  :-DD

Doesn't seem faster or anything, but my experience might be limited by network speed, and anyway, do whatever it is you need to do with the database to make it less resource intensive / more stable / easier to maintain. :)

Tim
Seven Transistor Labs, LLC
Electronic Design, from Concept to Layout.
Need engineering assistance? Drop me a message!
 

Offline ProBang2

  • Frequent Contributor
  • **
  • Posts: 293
  • Country: de
Re: Forum Database Upgrade
« Reply #36 on: March 25, 2017, 07:48:25 am »
I had only yesterday, for a few hours, the "Bad Gateway 502" error.

Today was something strange, but with the EEVBlog main-site:
Tried to load the main-site. Browser freezes for approx. 90 sec. with a blanc screen, only showing a (translated from german) "transmit data with apis.google.com". After that the site loaded as usual.
What the hell is "apis.google.com"?
Had anyone else this problem, too?

Windows7 64Bit
Mozilla Firefox 52.0.1 (32Bit)
Adblocker deactivated on www.wwvblog.com
 

Online blueskull

  • Supporter
  • ****
  • Posts: 10248
  • Country: cn
  • Power Electronics Guy
Re: Forum Database Upgrade
« Reply #37 on: March 25, 2017, 12:26:50 pm »
I noticed that the unread replies link takes lots of time to load, by lots I mean up to 30 seconds  :-\

http://www.eevblog.com/forum/unreadreplies/

+1. I also noticed other pages are also getting slower, at some degree.
 

Online Richard Crowley

  • Super Contributor
  • ***
  • Posts: 4003
  • Country: us
  • KE7GKP
Re: Forum Database Upgrade
« Reply #38 on: March 25, 2017, 02:09:23 pm »
Yes, the overall performance seems noticably slower. But that is the difference between 500ms and 1500~2000ms
 

Offline JPortici

  • Super Contributor
  • ***
  • Posts: 2311
  • Country: it
Re: Forum Database Upgrade
« Reply #39 on: March 25, 2017, 06:07:02 pm »
i noticed that tapatalk is very slow to load too
also, the sections are in alphabetical order!
 

Online Nusa

  • Super Contributor
  • ***
  • Posts: 1144
  • Country: us
Re: Forum Database Upgrade
« Reply #40 on: March 25, 2017, 06:09:37 pm »
Forum is feeling very sluggish at the moment.
My IP is on the testing list if it matters.
 

Offline andrewfernie

  • Contributor
  • Posts: 8
Re: Forum Database Upgrade
« Reply #41 on: March 28, 2017, 12:46:57 pm »
i noticed that tapatalk is very slow to load too
also, the sections are in alphabetical order!

Tapatalk has been unusable for me the last few days for EEvblog. Best case is that it is very slow to load, but most of the time I give up and go to a web browser. Same situation with iOS and Android.

Andrew
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1043
  • Country: au
Re: Forum Database Upgrade
« Reply #42 on: March 28, 2017, 04:08:24 pm »
Reports are no longer required of poor performance, we can clearly see the issue in the server's monitoring metrics. The root cause is that switching the remaining tables to InnoDB has blown out their size and they are unable to be cached in ram, as Dave stated we are getting a RAM upgrade after which there will be some tuning in order to take advantage of the additional RAM which should alleviate the issue.
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission

I volunteer my time to manage this server, if you would like to support this work I have a patreon here:
https://www.patreon.com/gnif
 

Offline JPortici

  • Super Contributor
  • ***
  • Posts: 2311
  • Country: it
Re: Forum Database Upgrade
« Reply #43 on: March 28, 2017, 04:31:42 pm »
i noticed that tapatalk is very slow to load too
also, the sections are in alphabetical order!

Tapatalk has been unusable for me the last few days for EEvblog. Best case is that it is very slow to load, but most of the time I give up and go to a web browser. Same situation with iOS and Android.

Andrew
yesterday my new phone (sigh) arrived, it was a lot faster than the old one to load tapatalk pages.. fast enough to point the finger at the crappy wifi for slowness
 

Offline andrewfernie

  • Contributor
  • Posts: 8
Re: Forum Database Upgrade
« Reply #44 on: March 28, 2017, 09:51:57 pm »


i noticed that tapatalk is very slow to load too
also, the sections are in alphabetical order!

Tapatalk has been unusable for me the last few days for EEvblog. Best case is that it is very slow to load, but most of the time I give up and go to a web browser. Same situation with iOS and Android.

Andrew

That RAM upgrade last night seems to have resolved any problems I was having. All good now.
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1043
  • Country: au
Re: Forum Database Upgrade
« Reply #45 on: April 03, 2017, 08:00:04 pm »
We are aware there seems to be an issue with a database query, I am investigating and will update shortly.
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission

I volunteer my time to manage this server, if you would like to support this work I have a patreon here:
https://www.patreon.com/gnif
 

Offline gnif

  • Administrator
  • *****
  • Posts: 1043
  • Country: au
Re: Forum Database Upgrade
« Reply #46 on: April 03, 2017, 08:09:53 pm »
We are aware there seems to be an issue with a database query, I am investigating and will update shortly.

Problem resolved, there was an bug in the database sort conditionals I hacked in last week.
HostFission - Full Server Monitoring and Management Solutions.
https://hostfission.com/
https://twitter.com/HostFission

I volunteer my time to manage this server, if you would like to support this work I have a patreon here:
https://www.patreon.com/gnif
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf