Author Topic: Fluke 187 failure  (Read 3738 times)

0 Members and 1 Guest are viewing this topic.

Offline alext

  • Regular Contributor
  • *
  • Posts: 61
  • Country: hu
Fluke 187 failure
« on: February 18, 2017, 11:39:29 pm »
my fluke 187(yes it is 187,not 189) after i replaced the lcd started to act weird |O can you suggest what to check on the board?
 

Offline alext

  • Regular Contributor
  • *
  • Posts: 61
  • Country: hu
Re: Fluke 187 failure
« Reply #1 on: February 18, 2017, 11:41:58 pm »
i checked the resistors,they seems fine but what are those blue and red ones? the bues are the mov-s(varistor) right? but what is the red one? and how to measure them?do i have to desolder them to measure?
« Last Edit: February 18, 2017, 11:56:06 pm by alext »
 

Offline WackyGerman

  • Regular Contributor
  • *
  • Posts: 194
  • Country: de
Re: Fluke 187 failure
« Reply #2 on: February 18, 2017, 11:46:40 pm »
Did you clean the zebra strips while replacing the lcd ? Are they fitted in the correct position again ?
 

Offline alext

  • Regular Contributor
  • *
  • Posts: 61
  • Country: hu
Re: Fluke 187 failure
« Reply #3 on: February 18, 2017, 11:54:18 pm »
i replaced the whole complete display assembly with a new one (thats why theres a 189 label on the front) so the zebra strips are new too
 

Offline WackyGerman

  • Regular Contributor
  • *
  • Posts: 194
  • Country: de
Re: Fluke 187 failure
« Reply #4 on: February 18, 2017, 11:57:57 pm »
ok but it seems that there are bad contacts to the display so I would reassemble the display and clean the zebra strips and the contacts on the board with alcohol
 

Offline alext

  • Regular Contributor
  • *
  • Posts: 61
  • Country: hu
Re: Fluke 187 failure
« Reply #5 on: February 19, 2017, 12:03:10 am »
why do you think theres bad connection to the display?the greyed out part on the second screen is the bar which is changing faster than the camera can catch up.the screen is fine as far as i can tell.but i cannot measure coltage with it,and it stays on at the off position,so there must be a problem with the dial terminals?(seems fine,not corroded or bent) or theres a blown component on the track somewhere but visibly theres no damaged part
 

Offline WackyGerman

  • Regular Contributor
  • *
  • Posts: 194
  • Country: de
Re: Fluke 187 failure
« Reply #6 on: February 19, 2017, 12:09:54 am »
ok then I was on the wrong way , sorry .
 

Offline WackyGerman

  • Regular Contributor
  • *
  • Posts: 194
  • Country: de
Re: Fluke 187 failure
« Reply #7 on: February 19, 2017, 12:41:58 am »
Can you anyway measure anything or is the multimeter completely locked up ?
 

Offline alext

  • Regular Contributor
  • *
  • Posts: 61
  • Country: hu
Re: Fluke 187 failure
« Reply #8 on: February 19, 2017, 12:46:39 am »
it seems it wont measure anything.the lead sockets seems fine too so i suspecting the movs or somehing around there but i dont know how to measure them or my another idea is the terminals in the knob.i disassembled it and i dont know if i put it back together correctly(maybe thats cause the off positions still on symptome)
 

Offline WackyGerman

  • Regular Contributor
  • *
  • Posts: 194
  • Country: de
Re: Fluke 187 failure
« Reply #9 on: February 19, 2017, 01:05:37 am »
Ok that could be . Here in the forum there are teardown pictures of the 187 . Just look and compare it with yours . So you could perhaps find the fault  ;)
 

Offline alext

  • Regular Contributor
  • *
  • Posts: 61
  • Country: hu
Re: Fluke 187 failure
« Reply #10 on: February 19, 2017, 01:09:54 am »
i saw that pictures but they were too poor quality / the pics from the 87iv is different(the movs ect)
 

Offline WackyGerman

  • Regular Contributor
  • *
  • Posts: 194
  • Country: de
Re: Fluke 187 failure
« Reply #11 on: February 19, 2017, 01:15:20 am »
Yes it s a quite different meter . Can you take some pictures of your multimeter and put it here in the forum ?
 

Offline alext

  • Regular Contributor
  • *
  • Posts: 61
  • Country: hu
Re: Fluke 187 failure
« Reply #12 on: February 19, 2017, 01:30:25 am »
not that different.99% the same.first i need some suggestions where to start.someone here must be saw that error before
 

Offline WackyGerman

  • Regular Contributor
  • *
  • Posts: 194
  • Country: de
Re: Fluke 187 failure
« Reply #13 on: February 19, 2017, 01:37:31 am »
Well I unfortunately don t . So it seems that the processor locks up your multimeter . Did you put the old led back in to exclude the possibility that the new lcd is faulty and lock the multimeter ?
 

Offline alext

  • Regular Contributor
  • *
  • Posts: 61
  • Country: hu
Re: Fluke 187 failure
« Reply #14 on: February 19, 2017, 01:47:35 am »
the processor?what leads you to that conclusion?how can be the new lcd be faulty?it is clearly functioning / putting back the old one is pointless since it is broken
 

Offline WackyGerman

  • Regular Contributor
  • *
  • Posts: 194
  • Country: de
Re: Fluke 187 failure
« Reply #15 on: February 19, 2017, 02:06:22 am »
well it could be possible that the new lcd locks up the processor so it doesn t measure anything and you cannot switch it off . I am not an expert in fluke multimeters . But in this case something let the multimeter not to work properly . If the movs or the ptc would be broken , you could measure it and you could switch off the multimeter properly . Another fault could be the contacts of the dial switch . Are they correctly fitted in ? Are the wipers in the correct position and not twisted 180 degrees ?
 

Offline alext

  • Regular Contributor
  • *
  • Posts: 61
  • Country: hu
Re: Fluke 187 failure
« Reply #16 on: February 19, 2017, 02:10:18 am »
how can be the new lcd block the processor? / the wipers can be misaligned since i tought that the pins are centered but as i look it closely it may be not so yes it can be twisted.do you have the correct pattern?or do you have a picture?the one i found here from it is too blurry
 

Offline WackyGerman

  • Regular Contributor
  • *
  • Posts: 194
  • Country: de
Re: Fluke 187 failure
« Reply #17 on: February 19, 2017, 02:15:34 am »
ok here is one
 

Offline alext

  • Regular Contributor
  • *
  • Posts: 61
  • Country: hu
Re: Fluke 187 failure
« Reply #18 on: February 19, 2017, 02:18:00 am »
i saw this one.i cant see the orientation on it / how about the screen and the processor?
 

Offline WackyGerman

  • Regular Contributor
  • *
  • Posts: 194
  • Country: de
Re: Fluke 187 failure
« Reply #19 on: February 19, 2017, 02:25:02 am »
Just click on the picture to enlarge it . Then you can see the orientation
 

Offline alext

  • Regular Contributor
  • *
  • Posts: 61
  • Country: hu
Re: Fluke 187 failure
« Reply #20 on: February 19, 2017, 02:26:33 am »
i did and still cant see
 

Offline WackyGerman

  • Regular Contributor
  • *
  • Posts: 194
  • Country: de
Re: Fluke 187 failure
« Reply #21 on: February 19, 2017, 02:36:50 am »
look at the arrows
 

Offline alext

  • Regular Contributor
  • *
  • Posts: 61
  • Country: hu
Re: Fluke 187 failure
« Reply #22 on: February 19, 2017, 02:41:29 am »
lol,eagle eyes :) the middle ones is twisted  :palm: i did tried to swith all 180 degree before but never tought to try all possibilities.ill let you know the  results  :)
 

Offline WackyGerman

  • Regular Contributor
  • *
  • Posts: 194
  • Country: de
Re: Fluke 187 failure
« Reply #23 on: February 19, 2017, 02:45:13 am »
they have to be in parallel line . if not then one is scratching on the pcb and not on the contact
 

Offline WackyGerman

  • Regular Contributor
  • *
  • Posts: 194
  • Country: de
Re: Fluke 187 failure
« Reply #24 on: February 19, 2017, 02:47:24 am »
look
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf