Author Topic: [Fixed] Looking for documentation and advice on fixing an old radio shack radio  (Read 386 times)

0 Members and 1 Guest are viewing this topic.

Offline Tristram

  • Contributor
  • Posts: 12
  • Country: us
  • Electronics Hobbyist
Hello all,
I have an old, probably cheap, radio shack radio I found on my balcony that I want to attempt to repair. The problem is that while taking it apart to check caps and such I mistakenly unscrewed screws holding the corded tuning system down while trying to remove the circuit board. Now I have no idea how the tuning system originally was hooked up and It is all a mess. I am hoping someone here may have some advice or maybe even recognize the model of the radio. It has no model or serial number identifiers that I can find so finding anything on it has been a exercise in futility. I couldn't even find a single image of one that looks like it. Some documentation on this thing would be greatly appreciated!

Edit: In the second picture I have screwed back on the two white wheels and have no idea if they are even facing in the right direction. Also, this is my first time working on a radio and I am fairly new to electronics repair.

Update: The radio has been identified. It is on page 48 of the 1996 Radio Shack Catalog. Catalog Number 12-686
« Last Edit: June 26, 2018, 09:57:25 pm by Tristram »
 

Offline tooki

  • Super Contributor
  • ***
  • Posts: 2334
  • Country: ch
In radio shack parlance, the model number and the cat (catalog) number are one and the same. And that’s clearly visible on the back.

But just fiddle around with it till it makes sense. This kind of “it’s no loss if I break it” gadget is a great opportunity to practice your problem solving skills.
 
The following users thanked this post: Tristram

Offline Tristram

  • Contributor
  • Posts: 12
  • Country: us
  • Electronics Hobbyist
In radio shack parlance, the model number and the cat (catalog) number are one and the same. And that’s clearly visible on the back.

But just fiddle around with it till it makes sense. This kind of “it’s no loss if I break it” gadget is a great opportunity to practice your problem solving skills.

How in the world did I manage to miss that there was a catalog number there... Maybe I should get my glasses checked ^-^. Thank you!
 

Offline FlyingHacker

  • Frequent Contributor
  • **
  • Posts: 776
  • Country: us
  • You're Doing it Wrong
I like to take cellphone pics as I take things apart. This makes for good reference as to how to put them back together.

Over course sometimes parts pop out before you can see where the were |O.

If nothing else you have a decent speaker you can use for future experiments or repairs.
--73
 
The following users thanked this post: Tristram

Offline alsetalokin4017

  • Super Contributor
  • ***
  • Posts: 1674
  • Country: us
Looks like the band selector switch (AM-FM) is completely gone and there might be some damage to the PCB where it connected.

And in the catalog image, note that the Tuning knob is larger. It looks to me like the knob from the Band selector switch has been moved up to the Tuning position and the original Tuning knob is gone.

And you've learned your first lesson about repairing stuff with complicated routings: Take photos _before_ you take it apart!



The catalog can be found here:  http://pdf.textfiles.com/catalogs/RADIOSHACK/

The easiest person to fool is yourself. -- Richard Feynman
 
The following users thanked this post: Tristram

Offline amyk

  • Super Contributor
  • ***
  • Posts: 5577
My best guess. Note that the dial cord may be wrapped around the tuning cap wheel several times.
 
The following users thanked this post: Tristram

Offline LateLesley

  • Regular Contributor
  • *
  • Posts: 78
  • Country: scotland
My best guess. Note that the dial cord may be wrapped around the tuning cap wheel several times.

While that's a good guess,, my take on it is it would include the metal "pegs" up top, and the dial would run across between them.

Something like this, if you forgive the crap shaky mouse drawing. (I was never good at art, less so on computers.)

 
The following users thanked this post: Tristram

Offline Tristram

  • Contributor
  • Posts: 12
  • Country: us
  • Electronics Hobbyist
Looks like the band selector switch (AM-FM) is completely gone and there might be some damage to the PCB where it connected.

And in the catalog image, note that the Tuning knob is larger. It looks to me like the knob from the Band selector switch has been moved up to the Tuning position and the original Tuning knob is gone.

And you've learned your first lesson about repairing stuff with complicated routings: Take photos _before_ you take it apart!



The catalog can be found here:  http://pdf.textfiles.com/catalogs/RADIOSHACK/

Yea, the original tuning knob was missing when I started. Also, I agree about the pictures... major oversight on my part |O
The band selector is fine, there is a piece of plastic that connects to the bottom of the selector nob and it reaches through a hole in the board to flip a physical switch on the back side.
It is just currently removed as I was trying to use its knob as a temporary tuning knob.

Thank you for the link to the catalog files!

My best guess. Note that the dial cord may be wrapped around the tuning cap wheel several times.

While that's a good guess,, my take on it is it would include the metal "pegs" up top, and the dial would run across between them.

Something like this, if you forgive the crap shaky mouse drawing. (I was never good at art, less so on computers.)



Yea It most definitely goes around those top pegs at some point. The tuning needle is a plastic tab physically connected to the tuning cord and it moves between the pegs. When I wire it up I get a lot of slack and I am not sure which wheel should get the cord wrapped around it more than once. Also those little white plastic wheels had the wire wrapped around the big part of the wheel and the small part as well though how many times and in what way I am not sure. From fiddling with It I think that it is done that way to increase the travel distance of the tuning needle.
« Last Edit: June 25, 2018, 11:05:30 am by Tristram »
 

Offline amyk

  • Super Contributor
  • ***
  • Posts: 5577
Quote
I am not sure which wheel should get the cord wrapped around it more than once.
The big black one on the tuning cap, the one with the tensioning spring.
 
The following users thanked this post: Tristram

Offline Tristram

  • Contributor
  • Posts: 12
  • Country: us
  • Electronics Hobbyist
Alright, I have officially given up on getting the tuning needle working and have just connected the tuning capacitors wheel directly to the tuning knob. I have also found a number of issues on the board. The speakers negative wire and the battery wells negative wire have both become disconnected from the board (luckily where they went is very obvious). Also, a section of the FM antenna wire's insulation appears to have melted and the copper strands are exposed so the cause of that needs to be tracked down.

On another note, is it just me or is this board kind of ... shoddily laid out. I am not really experienced enough to know. I am including a picture of an overview of the main section of board. Also, I found a ceramic capacitor soldered upside down directly to the side of the variable tuning capacitor. Don't know why but that tickled my funny bone so I included it in the pictures as well.

Here are the Pictures
1. The tuning fix
2. The melted wire
3. An overview of most of the board
4. The upside down capacitor
 

Offline Tristram

  • Contributor
  • Posts: 12
  • Country: us
  • Electronics Hobbyist
Okay, I re-attached the wires that had become disconnected and tested the temperatures of various components in the vicinity of the melted wire after a while of operation. Nothing showed more than 1 or 2 degrees above room temperature so how that wire became that way is still a mystery... There doesn't seem to be anything anywhere near it that could have made a melting pattern like that so maybe it happened in the factory? The only thing left to do is create a new tuning knob some how. I am currently using the AM/FM knob for that. Thank you all for responding to my post and helping me out! ^-^
« Last Edit: June 27, 2018, 11:47:38 am by Tristram »
 

Offline amyk

  • Super Contributor
  • ***
  • Posts: 5577
Someone has been inside it before.
 

Offline Tristram

  • Contributor
  • Posts: 12
  • Country: us
  • Electronics Hobbyist
Someone has been inside it before.
hmm that is a possibility. The things been kicking around for probably 20 years and has been inoperable for quite a long time.
« Last Edit: June 27, 2018, 11:49:04 am by Tristram »
 

Offline LateLesley

  • Regular Contributor
  • *
  • Posts: 78
  • Country: scotland
Someone has been inside it before.
hmm that is a possibility. The things been kicking around for probably 20 years and has been inoperable for quite a long time.
Are you sure it was actually melted? I've seen damage like that before inside old stuff, but it was because the cable was pinched at a screw hole. It's just I seen the hole next to it, and wondered if it's pinch damage?
 

Offline Tristram

  • Contributor
  • Posts: 12
  • Country: us
  • Electronics Hobbyist
Someone has been inside it before.
hmm that is a possibility. The things been kicking around for probably 20 years and has been inoperable for quite a long time.
Are you sure it was actually melted? I've seen damage like that before inside old stuff, but it was because the cable was pinched at a screw hole. It's just I seen the hole next to it, and wondered if it's pinch damage?

I think you are right.... Unscrewed it again to be sure and sure enough a circular plastic recessed screw well meets the board at the hole right next to the wire and the damage was probably from being squished and screwed through.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf