Author Topic: Hantek DSO1152S - Wont boot after firmware update  (Read 18381 times)

0 Members and 1 Guest are viewing this topic.

Online tautech

  • Super Contributor
  • ***
  • Posts: 11961
  • Country: nz
    • Taupaki Technologies Ltd.
Re: Hantek DSO1152S - Wont boot after firmware update
« Reply #75 on: July 16, 2014, 03:11:58 pm »
Quote
Very glad to hear this good news.

Our engineer have found the problem and will make up a firmware without this bug.
Many thanks for your below helpful datas.
Your new title: WanaGo, Hantek Software Support Technician.  :-DD  :-+
But you had us wondering for a good while.  :phew:
Avid Rabid Hobbyist & NZ Siglent Distributor
 

Offline WanaGo

  • Regular Contributor
  • *
  • Posts: 86
  • Country: nz
Re: Hantek DSO1152S - Wont boot after firmware update
« Reply #76 on: July 16, 2014, 03:15:48 pm »
Haha - glad we got to the bottom of it.
Big thanks to everyone involved.

I hope this has helped or will help someone with a Hantek scope. Hopefully no one else will fall into this trap now that Hantek is going to fix the updates.

Now, back to what I was trying to measure...
 

Offline rob77

  • Super Contributor
  • ***
  • Posts: 1848
  • Country: sk
Re: Hantek DSO1152S - Wont boot after firmware update
« Reply #77 on: July 16, 2014, 05:45:47 pm »
i've upgraded my DSO1102B with the last FW from Hantek - and no issues. probably that bug was only for the S series you have.
i was hoping i will have a excuse to play with the uart on my scope ... but no "luck" - the upgrade went smoothly ;)
 

Offline tinhead

  • Super Contributor
  • ***
  • Posts: 1801
  • Country: 00
    • If you like my hacks, send me a donation
Re: Hantek DSO1152S - Wont boot after firmware update
« Reply #78 on: July 16, 2014, 06:51:34 pm »
i've upgraded my DSO1102B with the last FW from Hantek - and no issues. probably that bug was only for the S series you have.

it was combination of missing files in the update files and newer dsod, with mumore functionality than the one on other models. Actually on latest benchtop "B" models Hantek implemented exact the same large dsod with more functionality, so it seems they will move all models to that. For us it is good, one can use that dsod to restore/recover and maybe even backup functionality.

i was hoping i will have a excuse to play with the uart on my scope ... but no "luck" - the upgrade went smoothly ;)

this is what fuses are for, shot them and you have to open the enclosure :P As i was younger, i always tried like that, hehe.
Now i'm old and wise, so i can open everything and play with everything, to get eventually even wiser.
I don't want to be human! I want to see gamma rays, I want to hear X-rays, and I want to smell dark matter ...
I want to reach out with something other than these prehensile paws and feel the solar wind of a supernova flowing over me.
 

Offline tinhead

  • Super Contributor
  • ***
  • Posts: 1801
  • Country: 00
    • If you like my hacks, send me a donation
Re: Hantek DSO1152S - Wont boot after firmware update
« Reply #79 on: July 16, 2014, 06:53:09 pm »
Big thanks to everyone involved.

and i have to thanks for the pics!

I don't want to be human! I want to see gamma rays, I want to hear X-rays, and I want to smell dark matter ...
I want to reach out with something other than these prehensile paws and feel the solar wind of a supernova flowing over me.
 

Offline rob77

  • Super Contributor
  • ***
  • Posts: 1848
  • Country: sk
Re: Hantek DSO1152S - Wont boot after firmware update
« Reply #80 on: July 16, 2014, 07:02:43 pm »
i was hoping i will have a excuse to play with the uart on my scope ... but no "luck" - the upgrade went smoothly ;)

this is what fuses are for, shot them and you have to open the enclosure :P As i was younger, i always tried like that, hehe.
Now i'm old and wise, so i can open everything and play with everything, to get eventually even wiser.

actually i'm a linux guy since '95 - '96 and did a lot of embeded stuff in the past... but now i'm too lazy to play with anything what is in working condition.. once something doesn't work - then i have to play with it ;)
 

Offline WanaGo

  • Regular Contributor
  • *
  • Posts: 86
  • Country: nz
Re: Hantek DSO1152S - Wont boot after firmware update
« Reply #81 on: July 16, 2014, 07:32:40 pm »
This new update has quite a few new things... Would hope so too, coming from a factory 2012 update...

Save waveform, you now seem to be able to save an animation, other than just an image or CSV etc... thats kinda cool... need to try that.
The DMM readouts in the top right actually seem to work....
The help looks much more comprehensive too. I think.
No doubt more..

Are there any update change logs, to say what has been updated?

Now I am more comfortable with this scope physically.... Tinhead.... what upgrades can I do to it? Is this one capable of the 200Mhz upgrade, or does it not fall in the right range of serial numbers or whatever?
Has mention of Video in the utility menu, which is greyed out. whats that?
SD card - unsupported. whats that for? I saw the blank footprint for the uSD card socket.
Video - unsupported.
Net Card - supported - have used that before.
Store depth - 1M

Cheers
WanaGo
 

Offline WanaGo

  • Regular Contributor
  • *
  • Posts: 86
  • Country: nz
Re: Hantek DSO1152S - Wont boot after firmware update
« Reply #82 on: July 16, 2014, 07:40:04 pm »
Oh and now I can measure some signals on CH1 in MEAS as well as CH2 signals, at the same time.
Before I suppose I couldnt select CH2 so knew no better! hah. this is going to be handy. Like a real scope or something, rather than a toy.  :-DD
 

Offline rob77

  • Super Contributor
  • ***
  • Posts: 1848
  • Country: sk
Re: Hantek DSO1152S - Wont boot after firmware update
« Reply #83 on: July 16, 2014, 07:51:26 pm »
it's strange - my DSO1102B is apparently an older model tha your DSO1152S , but both DDM & frequency in the top right corner were working just fine before and after upgrade. and same for the CH1 & CH2 at the same time in the measurements it worked before the update and still works after the update .
 

Offline commongrounder

  • Frequent Contributor
  • **
  • Posts: 254
  • Country: us
Re: Hantek DSO1152S - Wont boot after firmware update
« Reply #84 on: July 24, 2014, 12:40:15 am »
I noticed that Hantek has a firmware file (dso1kb_2.01.1_DSO1152S(140408.0).up) that is dated 7-14-2014.  Can someone confirm that this is the fixed version of the firmware that WanaGo was having trouble with?  I don't want to try it on my S series handheld until I'm sure it won't cause the same problems.  I don't have the equipment to access the ports on the inside, nor the linux experience to do what WanaGo has done (Thanks for catching the problem, by the way!). 
When something like this happens, is there any way to force a firmware downgrade through the USB port?
Thanks!
 

Offline tinhead

  • Super Contributor
  • ***
  • Posts: 1801
  • Country: 00
    • If you like my hacks, send me a donation
Re: Hantek DSO1152S - Wont boot after firmware update
« Reply #85 on: July 24, 2014, 02:04:37 am »
I noticed that Hantek has a firmware file (dso1kb_2.01.1_DSO1152S(140408.0).up) that is dated 7-14-2014.  Can someone confirm that this is the fixed version of the firmware that WanaGo was having trouble with? 
you mean on their onedrive? this is the same version, only extracted on 7-14-2014, but the same content. They deleted all
versions from web and onedrive, but seems that they forgot that extraced version.

So no, don't use that.

I will compile later today working version and post on my onedrive (it will be dated named custom_dso1kb_2.01.1_DSO1000S(140408.2).zip and only the up file dso1kb_2.01.1_DSO1000S(140408.2).up )

When something like this happens, is there any way to force a firmware downgrade through the USB port?

as long the dso.exe (dso_bin) is running - yes - because one can connect over lan or usb with that tool from Peter Dreisiebner

http://peter.dreisiebner.at/dso-usb-tool/

then go to shell tab and copy manually older files from flash drive to DSO. Then after reboot the DSO will use them.

However, when the dso.exe (or dso_bin) is not working, then there was no other way than the physical uart.

Now with the new dsod (watchdog) for benchtops and handhelds one will have a way to restore/downgrade DSO even
when dso.exe (or dso_bin) is crashing. It is somehow funny that the first firmware with the new dsod alread created
problems, because of the dsod. But yeah, something like that can happens when one forgot to copy files into update
or run test twice (where the system does have already files which are missing in update ...).
« Last Edit: July 24, 2014, 07:09:07 pm by tinhead »
I don't want to be human! I want to see gamma rays, I want to hear X-rays, and I want to smell dark matter ...
I want to reach out with something other than these prehensile paws and feel the solar wind of a supernova flowing over me.
 

Offline commongrounder

  • Frequent Contributor
  • **
  • Posts: 254
  • Country: us
Re: Hantek DSO1152S - Wont boot after firmware update
« Reply #86 on: July 24, 2014, 03:29:36 am »
Thank you, tinhead.  I will keep watch for it.  This is an interesting problem.  I'm so glad I saw this thread, as I check Hantek's onedrive regularly for firmware updates and would have blithely installed this defective one and ended up in the same boat as WanaGo, but without an easy way to fix it.
 

Offline rob77

  • Super Contributor
  • ***
  • Posts: 1848
  • Country: sk
Re: Hantek DSO1152S - Wont boot after firmware update
« Reply #87 on: July 24, 2014, 04:13:50 am »
it's strange - my DSO1102B is apparently an older model tha your DSO1152S , but both DDM & frequency in the top right corner were working just fine before and after upgrade. and same for the CH1 & CH2 at the same time in the measurements it worked before the update and still works after the update .

ups... early judgment.... the DMM & frequency in the top right corner are working... but only after pressing the measure button - but they keep working since then - even after menu off button pressed.. so not a big deal ;)
 

Offline tinhead

  • Super Contributor
  • ***
  • Posts: 1801
  • Country: 00
    • If you like my hacks, send me a donation
Re: Hantek DSO1152S - Wont boot after firmware update
« Reply #88 on: July 24, 2014, 08:29:00 pm »
here we go, on my onedrive http://1drv.ms/1hf4SgO in firmware->hw1.00.4 there is the custom_dso1kb_2.01.1_DSO1000S(140408.2).zip file. Inside that file you will find dso1kb_2.01.1_DSO1122S(140408.2).up and extra.zip. Copy that dso1kb_2.01.1_DSO1122S(140408.2).up to empty flash drive. Then unzip that extra.zip to that flash drive, you will see then "packet" directory. This is necessary due the lack of NAND space, the update procedure need always twice the size of decrypted update. So my custom update is copying part of reqiered files directly from flash drive, so that it can work even on low space models (like my test unit from 2011). Remove that flash drive from PC and insert into handheld, run now the firmware update from utility->f2->f4. Due amount of files it can take some extra time, my script is doind 10sec. loop to ensure that all files has been written. So wait until the led stopped to lit and the "plaese reboot" pops up on display. Some models, and this depends on what fw version already installed, will anyway do an automaticaly reboot, so that's fine as well.

After the reboot or power cycle you should see then 140408.0 as fw version.
I don't want to be human! I want to see gamma rays, I want to hear X-rays, and I want to smell dark matter ...
I want to reach out with something other than these prehensile paws and feel the solar wind of a supernova flowing over me.
 

Offline commongrounder

  • Frequent Contributor
  • **
  • Posts: 254
  • Country: us
Re: Hantek DSO1152S - Wont boot after firmware update
« Reply #89 on: July 24, 2014, 11:26:43 pm »
Thank you so much tinhead!  Later on, after I finish work, I will give this a try on my DSO1122S unit and report the results.  Once this is done, should the new DSOD functions work as Hantek had intended?  It would be nice to think there is some way, other than cracking open the case, to recover a scope with issues. :)
 

Offline tinhead

  • Super Contributor
  • ***
  • Posts: 1801
  • Country: 00
    • If you like my hacks, send me a donation
Re: Hantek DSO1152S - Wont boot after firmware update
« Reply #90 on: July 24, 2014, 11:39:25 pm »
Once this is done, should the new DSOD functions work as Hantek had intended? 

yes, i did tested this already, meaning when i kill dso.exe (tested with broken one and with none) then the dso display stays black and after some time it does reboot. When i then insert flash drive with e.g. system_restore.up a message popups "firmware update", where of course one have to have an system*.up file encrypted with special password (in this case "dsoduse"). There is as well the emergency way, where one have to copy "emerg.do" file to flash drive. That file is nothing else than encrypted update shell script, which can then do restore or backups or what so ever. This script need to be then encrypted with special password (in this case "949307"). There seems to be small "model check" implemented, i think to prevent people from installing wrong firmware on wrong model, haven't tested yet how this works in detail, all i saw is that the systemxxx.up or hantek.up need to contain "model" file in which the model name is stored (and that name have to be the same as on the DSO already). In case o the isolated handhelds this model name is "dso1000s", so it is universal for all models in own model category. Sometimes i think they have too much time at Hantek  >:D
I don't want to be human! I want to see gamma rays, I want to hear X-rays, and I want to smell dark matter ...
I want to reach out with something other than these prehensile paws and feel the solar wind of a supernova flowing over me.
 

Offline commongrounder

  • Frequent Contributor
  • **
  • Posts: 254
  • Country: us
Re: Hantek DSO1152S - Wont boot after firmware update
« Reply #91 on: July 26, 2014, 12:06:51 am »
Okay.  I downloaded and extracted tinheads  "custom_dso1kb_2.01.1_DSO1000S(140408.2).zip" file and followed the instructions earlier in this thread very carefully.  Something unexpected happened, though.  After starting the upgrade process through the menu (untility,>f2,>f4), things went as expected and the USB flash drive was blinking.  This was going on for a few moments.  I turned away to answer the phone and when I looked back, the screen was blank, but power was on.  The USB drive was no longer flashing.  To be certain it was hung, I left it go for 15 minutes, with no change.  I had the unit fully charged and plugged in to the AC adapter.  So, after nothing changed, I forced the unit off with the power button and restarted.  Now I get a looping first screen, second screen, blank and restart.  It seems similar to what WanaGo had happen.  I can't think what I could have done wrong.  I followed the procedure to a tee.  :-//

I'm not panicking about this.  I tried this with the full awareness that it is experimental.   I use this scope for measuring bridged output audio power amplifiers, and I have my Fluke 199C that works for the purpose, so I can still do my testing.  Screen and data captures are so much easier with the Hantek, which is why I got one (plus the screen is so much better).  I know that there is a solution in this thread, but I am scratching my head as to what happened.  I wish I hadn't turned away! As I said before, I'm not too well versed in the software aspects of this, but am willing to try, if I can get the proper hardware interface.  Thanks for any suggestions! :-BROKE
 

Offline tinhead

  • Super Contributor
  • ***
  • Posts: 1801
  • Country: 00
    • If you like my hacks, send me a donation
Re: Hantek DSO1152S - Wont boot after firmware update
« Reply #92 on: July 26, 2014, 01:00:57 am »
how crap is that, i did the installation on total 3 boards with 3 different images - and that with fw level from 2011, 2012,2013 and even the latest 2014 to ensure that an ANY stage of better said with any version of hw/fw the update is running. Any then the first DSO in field is crashing :\

Ok, i will help you with that. Copy dso1kb_2.01.1_DSO1122S(140408.2).up to empty fash drive and rename it to system1.up
Then insert it into and tell me if you see something on screen and/or if then led is blinking. I need to know at what stage your DSO is now ...
I don't want to be human! I want to see gamma rays, I want to hear X-rays, and I want to smell dark matter ...
I want to reach out with something other than these prehensile paws and feel the solar wind of a supernova flowing over me.
 

Offline commongrounder

  • Frequent Contributor
  • **
  • Posts: 254
  • Country: us
Re: Hantek DSO1152S - Wont boot after firmware update
« Reply #93 on: July 26, 2014, 01:43:59 am »
It was the FLASH DRIVE  |O  When I attempted to load the renamed firmware file onto the flash drive I've been using for this procedure, I got read/write errors.  First time that has ever happened to me, but lesson learned.  Don't use a $3.99 flash drive for firmware updates.  The files looked fine when I had copied them on yesterday, so the failure could have occurred anytime.
I loaded the renamed system1.up file to a fresh, name brand, flash drive and started the scope.  I still get the first "picture" screen, then a firmware version screen for a moment, then blank for about 10 seconds before a recycle.  The activity light on the flash drive flickers through all of the first cycle and part of the second and then goes out.  Nothing but recycling of the scope after that.  Does that mean some of the loading programs (like the DSOD) are corrupted?
 

Offline tinhead

  • Super Contributor
  • ***
  • Posts: 1801
  • Country: 00
    • If you like my hacks, send me a donation
Re: Hantek DSO1152S - Wont boot after firmware update
« Reply #94 on: July 26, 2014, 04:27:22 am »
What a crap. Did you remember what version was installed before the update? I will try then to find solution for you.
I did removed that custom fw from my onedrive, i will have to implement crc check inside, without it is too risky.
I don't want to be human! I want to see gamma rays, I want to hear X-rays, and I want to smell dark matter ...
I want to reach out with something other than these prehensile paws and feel the solar wind of a supernova flowing over me.
 

Offline commongrounder

  • Frequent Contributor
  • **
  • Posts: 254
  • Country: us
Re: Hantek DSO1152S - Wont boot after firmware update
« Reply #95 on: July 26, 2014, 04:46:46 am »
I was running the ver 2.01.1(140212.0) firmware previously.  Thank you for your efforts, tinhead.  I strongly suspect that the problem was hardware related at this end, rather than with any of your work.  Your analysis and discussions of Hantek hardware and firmware have been totally outstanding!
Should I start shopping around for one of those little USB to TTL interfaces?  I only have a USB to RS-232 variety right now, which I know is not electrically compatible. Thanks!
 

Offline tinhead

  • Super Contributor
  • ***
  • Posts: 1801
  • Country: 00
    • If you like my hacks, send me a donation
Re: Hantek DSO1152S - Wont boot after firmware update
« Reply #96 on: July 28, 2014, 09:16:46 am »
i did tested everything i could test, but without success. The only way is now to work over UART. I will of course guide you as soon you bought/build such adapter. Sorry for that.
I don't want to be human! I want to see gamma rays, I want to hear X-rays, and I want to smell dark matter ...
I want to reach out with something other than these prehensile paws and feel the solar wind of a supernova flowing over me.
 

Offline commongrounder

  • Frequent Contributor
  • **
  • Posts: 254
  • Country: us
Re: Hantek DSO1152S - Wont boot after firmware update
« Reply #97 on: July 28, 2014, 09:36:28 am »
I have a USB to TTL-serial interface on order. When I have the hardware set up, I'll drop back into this thread.  Thanks so much!
 

Offline commongrounder

  • Frequent Contributor
  • **
  • Posts: 254
  • Country: us
Re: Hantek DSO1152S - Wont boot after firmware update
« Reply #98 on: August 09, 2014, 06:07:07 am »
Greetings!
The USB to TTL uart interface arrived today and I got it hooked up.  When I started the scope, I received a string of messages exactly like the first one that Wanago received after his firmware update problem.  I've read this thread through several times, and some of the Linux commands started making sense to me.  The first thing I did actually accomplished two things:  It fixed the problem, and proved that my defective USB flash drive caused my scope trouble, not tinheads fixed (dso1kb_2.01.1_DSO1122S(140408.2).up) firmware. 
Okay, so I monitored the scope as it ran through the initialization loop to the pausing point, just before the auto restart. I then hit enter to enable the console.  After that, I typed "killall dsod". That stopped the restarts. I then simply entered "/dso.exe".  I think I was lucky, and the main program file was not corrupted/lost, because the scope came to life.  I wasted no time and inserted a good flash drive with tinheads modified firmware and files (as above, dso1kb_2.01.1_DSO1122S(140408.2).up) which I had kept.  I ran the updater right from the scope Utility menu as you would normally do a firmware upgrade.  It ran (a bit longer, as tinhead said it would with the extra files on the flash drive), and then restarted.  Voila!  The scope started normally and has been working ever since. 
To tinhead:  Thank you so very much for your dedicated interest in the Hantek/Tekway gear.  It saved me tons of grief.  I believe you should repost the dso1kb_2.01.1_DSO1122S(140408.2).up fixed firmware on your onedrive site for others to use.  It ultimately worked for me, and I have the benefits of the new firmware version, as Wanago has described.  I do wish Hantek would take that last copy of the bad firmware off of their onedrive site.  It sits like a land mine for unsuspecting "S" series scope owners (I wonder how many there are of us?).
Wanted to add: My DSO1122S has a hardware version of 1.02 dated 9-2012
« Last Edit: August 12, 2014, 12:02:08 am by commongrounder »
 

Offline tinhead

  • Super Contributor
  • ***
  • Posts: 1801
  • Country: 00
    • If you like my hacks, send me a donation
Re: Hantek DSO1152S - Wont boot after firmware update
« Reply #99 on: August 13, 2014, 05:17:58 pm »
you welcome! and of course good to hear that your handheld is back working.
I don't want to be human! I want to see gamma rays, I want to hear X-rays, and I want to smell dark matter ...
I want to reach out with something other than these prehensile paws and feel the solar wind of a supernova flowing over me.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf