Author Topic: Rigol DS1000Z series buglist continued (from: 00.04.04.03.02)  (Read 16666 times)

0 Members and 1 Guest are viewing this topic.

Online frozenfrogz

  • Frequent Contributor
  • **
  • Posts: 278
  • Country: de
  • Having fun with Arduino and Raspberry Pi
Disclaimer

This is the straightly bug related thread. If you find something that needs to be reported or double checked feel free to post here.
For all other general discussion please stick to THIS THREAD.

Disclaimer

Because the original posting from kwass can no longer be maintained by Katie, the original poster atm, we were talking about how to keep things going.

New bug reports from software version 00.04.04.03.02 onward will be bundled here. Please drop a comment, or PM in case you run into an issue with the latest firmware.
Please supply a description of how to reproduce the bug, together with detailed device information. Please provide: Software Version, Board Version, Boot Version, Firmware Version
Pressing MENU, MENU, FORCE, MENU, Utility, (soft button) System, (soft button) System Info quickly one after the other will get you there.

Direct download link to latest release: V.00.04.04.03.02
Direct download link to last release that also contained boot version update file: V.00.04.00.00.00

I took the list formerly maintained by Katie and re-checked what I could on Board Version: 0.1.4, Boot Version: 0.0.1.4, Firmware Version: 0.2.3.11


The following bugs seem to be fixed in the latest firmware:
  • Font size selection is now kept on power cycle just as other settings
  • Select item menu works on all font sizes
  • FFT works on all channels, select channel via soft menu "Source"
  • Large fonts push items up instead of covering, or other items are overlayed (intensity)
  • MATH functions shows generic unit U instead of channel unit
  • Waveform shift resolved (old buglist item 9)
  • RAW mode of data acquisition over USB now returns sane data

Recommended update procedure
Forgot to mention, before doing the upgrade, I did the memory "sanitation"* 1st as Rigol document stated, just want to make sure its like fresh from factory, which are :
  • Clear the internal volatile memory: Buttons pressed = STORAGE > DISK MANAGE > FLASH ERASE
  • Restore Power of Setup to "Default": Buttons pressed = UTILITY > SYSTEM > POWER SET = Default
  • Power off the unit.
  • Power on, insert the "blank" USB flash drive, to check whether it recognizes the USB first.
      (PS: "blank" means a freshly formatted 8GB FAT32 with 4K allocation and without any file on it as it is freshly formatted.)
  • Unplug the flash drive, copy "only" the single .GEL file from your computer to the root directory.
  • Plug the flash drive into the unit, new firmware should instantly be recognized, proceeded with update.
  • After successful update, hard-cycle reboot unit.
  • Perform self calibration routine.
*see also pdf file provided by ted572 appended below


Bugs remaining or not tested by me, please review when you were affected and could reproduce it on previous releases:
  • ATTENTION There are reports on locking up after updating. However, it does not seem irrevocable and there are no reports of permanently bricked devices to date (2017-07-08). This might be due to board version 0.1.1 and older, but might also affect newer board versions. So far everyone running into a calibration fail was able to clear it by rebooting and running self cal. again – eventually it would work on second, or third try. However, the WHY is still unresolved.

    • Behavior is as follows: Update works fine, but after reboot additional soft buttons turn up next to »Self Calibration«. Self cal. routine quits with error and locks up the device. Power cycle resolves to a regular screen, additional soft buttons disappearing and being able to successfully run self calibration routine on board version 0.1.1, boot version 0.0.1.3, firmware 0.2.3.11, CPLD 1.1 and 2.2.

  • Some users have reported that the zero line of the trace is not perfectly centered after doing a calibration.  This is not an issue on all units, however, so might be more of a hardware variability item.  Users expect that all traces along with their channel number indicator should perfectly centered on the display (on top of each other) after a calibration.


  • Writing full memory to a CSV file takes an extremely long time.  Write speeds seem to be about 0.15 MB/sec instead of the expected 10MB/sec or so.

    • Saving is still painfully slow. I don't think something changed here.

  • The 20M Bandwidth Limit setting for each channel is not saved, it resets of OFF each power cycle.

    • Not resolved as of today.

  • Some users have reported scope lock ups when setting memory depth to AUTO, timebase to 1us, zooming in and changing the persistence from MIN something else. Apparently not all users experience this problem but those that do can reproduce it every time.  See this thread for much more detail: http://www.eevblog.com/forum/testgear/rigol-ds1054z-freeze-up-bug/

    • Pass: Board Version: 0.1.4, Boot Version: 0.0.1.4, Firmware Version: 0.2.3.11, CPLD Version: 1.1
    • Pass: Board Version: 0.1.1, Boot Version: 0.0.1.3, Firmware Version: 0.2.3.11, CPLD Version: 1.1
    • Pass: Board Version: 0.1.1, Boot Version: 0.0.1.2, Firmware Version: 0.2.3.11, CPLD Version: 1.1
    • Fail:  Board Version: 0.1.1, Boot Version: 0.0.1.2, Firmware Version: 0.2.3.11, CPLD Version: 1.1
    • Fail:  Board Version: 0.1.1, Boot Version: 0.0.1.2, Firmware Version: 0.2.3.11, CPLD Version: 2.2
    • Pass: Board Version: 0.1.1, Boot Version: 0.0.1.1, Firmware Version: 0.2.3.11, CPLD Version: 1.1

  • Remote I/O menu will not allow selection of LAN if USB is ON.  You need to unplug the USB device first.

    • Needs to be tested.

  • Inside the CSV file, the scope stores the "increment", in the memory dumps that increment is 25X longer than it should be to correctly represent the expected sampling period.  For example: if the increment is 10us, one has to set the time increment to 400ns (2.5MSPS) in order to get the correct plot of data.

    • Needs to be tested.

  • USB bug causes problems depending on PC / laptop hardware & driver, because of illegal packet size of 64 bytes instead of standard conform 512 bytes. DS1000Z registers as "high speed USB". This leads to detecting the device on the bus, but not being able to communicate. Possible workaround (?) get the device registered as "full speed USB" instead? USB reference material

  • "Pluses" spelling remains as Rigols ongoing joke :)

  • (needs evaluation) Some combinations of USB thumb drive, FAT16/32 file system and board version (?) lead to unbearable long times saving screenshots

  • Remote control via LAN / telnet commands misbehaves
    Querying :FUNC:WREP:FMAX? returns the value of :FUNC:WREP:FEND, not the number of frames recorded in memory (set with :FUNC:WREC:FEND). More detailed post here.
Release notes supplied by Rigol
Code: [Select]
[Supported Model]    All the MSO/DS1000Z Series Digital Oscilloscopes
[Latest Revision Date]  2017/03/24

[Updated Contents]
--------------------
v00.04.04.03.02  2017/02/06
     - Improved the LXI module
     - Fixed the freeze problem when upgrading based on the boot version of
       0.0.0.13
     - Improved the menu in the language of Traditional Chinese and Korean
     - Modified the failure when downloading waveform to the source module
     - Fixed bugs about reading the memory data through SCPI commands
     - Fixed bugs about Measure
     - Fixed bugs about Filter

[History]
-------------
v00.04.04.01.01  2016/09/14
     - Supported the multi-interface of LXI
     - Fixed bugs about Measure

v00.04.04.00.07  2016/07/19
     - Added the full-screen display in the XY mode
     - Modified the Trace data of average sample mode
     - Fixed the bug of system halted for wave persistence in the Zoom mode
     - Fixed bugs about Measure

Please feel free to confirm, or mark as solved from the above list. All new issues and bugs belong in this thread and will be maintained in the opening post by me.

Regards and happy testing,
Frederik


Latest changes
Small follow up on calibration fail after update
Disclaimer regarding general discussion thread
Added remote command frame size bug
Added more information on USB packet bug
Appended PDF file with memory wipe instructions
Added recommended update procedure
Updated info on calibration fail
Appended device to freeze bug (#5) table
Added link and info on boot version
Typos and formatting
Added download link to latest software file
Added saving to USB takes incredibly long bug
Added possible bricking bug
Reformated buglist as ordered list (as proposed by metrologist)
« Last Edit: July 08, 2017, 09:22:20 PM by frozenfrogz »
He’s like a trained ape. Without the training.
 
The following users thanked this post: Fennec, evb149, willigo3, evzone

Online frozenfrogz

  • Frequent Contributor
  • **
  • Posts: 278
  • Country: de
  • Having fun with Arduino and Raspberry Pi
Re: Rigol DS1000Z series buglist continued (from: FW 00.04.04.03.02)
« Reply #1 on: April 12, 2017, 06:56:47 PM »
Here's my attempt to catalog the bugs and wish list items for the Rigol DS1000Z oscilloscopes.   This should apply to the regular and -s versions, but may not apply to the MSO versions)  I'll try to modify this top post as people add their found bugs and wish list items.  Hopefully Rigol will see this thread and respond to it.

This list is for software version: 00.04.02 and 00.04.03  only, with the current hardware (possibly only board 0.1.1).


Rigol fixed the following bugs (according to their documentation between 4.02 and 4.03):

  • Modified the method of key board test and screen test and optimized processing speed.
  • The display of keyboard lights and the show of menu was wrong while switch the timebase mode between YT and ROLL in the Normal trigger mode.
  • The saved data of REF waveform was wrong while STOP the system then open the channel.
  • The output of AUX was wrong while the function of Pass/Fail was closed.
  • The display of LA signal was wrong while adjust the delay calibration of LA signal.
  • The position of LA wave and label of LA channel was wrong while load the file of LA waveform then RUN the system.
  • The wave of channel1 can not be displayed while open the scan mode then switch the channel2 over and over again.
  • The position of LA wave was wrong while load the file of LA waveform before change the position of the LA channel.
  • The memory data of LA channel was wrong when use the remote command to read.
  • Save the CSV file failed while the system stopped.
  • Fixed the bug of unlocked the key board failure when save the file.



Bugs:

1) The new Large and Extra Large measurement fonts are nice, but they are reset to Normal on each power cycle.  This should be retained like all the measurement settings are.

2) The Select Item sub-menu on the Measurement menu has 5 check boxes implying that it should be useable for Normal font too, but it's grayed out.  The only way to remove a measurement from the screen using Normal font is a power off/on cycle.

One member has already suggested that the left side menu as a series of on/off toggles as the means for including/removing the measurement.  This in conjunction with the Select Item sub-menu (which could turn on/off the display position of an item) might give maximum flexibility and ease of use.

3) The FFT function only works for channel 1.  However it will work for the other channels as long as channel 1 is turned on.  It's actually more complicated than that for more details see this thread: http://www.eevblog.com/forum/testgear/another-rigol-1000z-bug/msg568478/#msg568478

Also, the FFT cdisplay shows bad aliasing under most circumstances.  See this thread for more details: http://www.eevblog.com/forum/testgear/rigol-ds1054z-fft-bug%28s%29/

4) The Large and Extra Large fonts cover up items that display at the bottom of the screen.  For example the brightness indicator and the math equation. 

5) Some users have reported that the zero line of the trace is not perfectly centered after doing a calibration.  This is not an issue on all units, however, so might be more of a hardware variability item.  Users expect that all traces along with their channel number indicator should perfectly centered on the display (on top of each other) after a calibration.

(See this post for some post-calibration screen shots:  http://www.eevblog.com/forum/testgear/rigol-ds1000z-series-%28ds1054z-ds1074z-ds1104z-and-s-models%29-bugswish-list/msg584977/#msg584977)

If it's not possible for the calibration routine to automatically do this, maybe allow the user to manually set the channel offset at the exact center and save that value until the next calibration.

6) Writing full memory to a CSV file takes an extremely long time.  Write speeds seem to be about 0.15 MB/sec instead of the expected 10MB/sec or so.

7) When show measurements from the MATH trace the units don't match to the units selected (or computed) in the MATH function.  For example:  Ch 1= Volts, Ch 2=Amps, Math= Ch1 x Ch2 will show Watts on the trace but MATH measurements will show Volts, instead of correctly showing Watts.

8 ) The 20M Bandwidth Limit setting for each channel is not saved, it resets of OFF each power cycle.

9) If the following settings are used:

  Input signal: probe compensation 1kHz square wave from the scope
  Trigger: DC / CH1 / 1.5V
  Aquisition: High Res / 120k mem. depth
  Horizontal position: 0ps
  Horizontal scale: 50us/div

  The scope will display the waveform shifted by around 75us.    See details in this picture:



10) Some users have reported scope lock ups when setting memory depth to AUTO, timebase to 1us, zooming in and changing the persistence from MIN something else. Apparently not all users experience this problem but those that do can reproduce it every time.  See this thread for much more detail: http://www.eevblog.com/forum/testgear/rigol-ds1054z-freeze-up-bug/

11) Remote I/O menu will not allow selection of LAN if USB is ON.  You need to unplug the USB device first.

12) Inside the CSV file, the scope stores the "increment", in the memory dumps that increment is 25X longer than it should be to correctly represent the expected sampling period.  For example: if the increment is 10us, one has to set the time increment to 400ns (2.5MSPS) in order to get the correct plot of data.

13) RAW mode of data acquisition over USB returns garbage, rather than the waveform.


Wish List Items:

A) Full screen X-Y mode, the current display is tiny.  Also, allow screen persistence to be set in X-Y mode.

B) Decoders should allow DATASRC to be either Trace or Memory.  This is documented in the manual but apparently only Trace is implemented, so this might be a bug.  Even the SCREEN option could be improved so that decoding starts at a start-bit not at the left edge of the screen.

C) When displaying a math function allow the underlying channels to be hidden.

D) Compress and move the waveform to the bottom of the screen when Measure All is on as is done, optionally, for FFT display.  Also for measurement history.

E) Allow Measure All to be selected in the AUTO options menu.

F) Allow the user to hide the left and right side menus.  Also the left side menu is often irrelevant and that screen space could be used for other display items.

G) When selecting a channel, show some corresponding channel color around the settings instead of having everything in just white.  Maybe just change the color of the tiny CH1, CH2, CH3, CH4 label next to the Coupling setting.

H) Use a larger font for the popup keyboard.

I) Save the last few file names in the Storage menu for faster access.  Maybe use the left side menu for this?  Alternatively, just remember the last file name entered and allow the user to increment any trailing digits.  So TEST0001 would go to TEST0002 automatically (or will a key press).

J) Allow the trace Display Persistence Time to be turned off -- instead of just MIN.  The scope would then just show each waveform as it's captured and blank the display before showing the next.  Even the MIN persistence level can hide some detail.

K) Allow larger fonts for certain items.  For example:  timebase, trigger level and channel gain (volts/div).  Also use a larger icon showing the coupling (DC/AC/GND) next to the channel gain.

L) Use a different color for the math trace, something that stands out better, maybe red?

M) Allow the user to select a color for the A and B cursors, individually.  Currently they are distinguished by a solid and dotted line both in white.

N) Allow for selectable FFT size (number of points: 128, 256, 512, 1024) calculation -- ie, trade off speed for accuracy.

O) Show the trigger type and coupling method (DC/AC/LFR/HFR) next to the trigger type icon in the upper right corner.

P) Consider moving the selection of the trigger coupling method to the top-level trigger menu instead of the Setting sub-menu.  Same for the Holdoff.

Q) Allow for variable high and low pass filtering for each channel, as was done in the earlier 1000 series scopes.

R) Add boxes for Math and Ref to the bottom bar alongside the channel info.  Color coding them and added relevant info such as gain or offset offset voltage.

S) Allow for a simple screen title.  Maybe allow more text to be added via a PC connection, perhaps a query that could be responded to with a key press on the scope.

T) Hardware frequency counter shows "<15Hz" when the STOP button is pressed even though it had been showing a valid value.  It would be best to freeze this value like other measurements are.

U) Ability to save a Recorded data to USB drive.

V) Consider checking the way the menu system works, as follows:

Push a soft menu button to open a menu, push the same button again to close the menu.
When a menu is open you can use the light blue up/down arrows to select an item in the menu, or use the multifunction knob if you prefer that.  When you have the correct item highlighted in the menu, push the soft menu button again to select the item and close the menu (or push the multifunction knob if you prefer).

W) Change file file numbering scheme so that instead of using the first available file number simply use a sequential number (stored in persistent memory) until reset by the user.

X) Use a meaningful amount of decimals in the horizontal position display (e.g. '0.00000000 ps' should be something like 0.0 ns since the smallest step size is 0.1ns)

Y) Have the FFT function compute an average if the channel it's set to is set to "average" in Acquire menu.  Other single-argument math functions seem to do this.

Z) Allow a push of the trigger level control to set the trigger level at the 50% level or at the 0% level - as it currently does.

AA) Improve the response of the vertical and horizontal position movements, they have quite a bit of lag.

AB) It would be helpful to be able to see the on-screen ASCII table when setting up an RS-232 trigger.

AC) Add (wired/wireless) USB keyboard support for navigating menus and character input.

AD) Add a menu option to allow the user to set the offset voltage (or whatever the current units are).  This is in addition to the normal offset control knob.

AE) Allow MATH to be used in the X-Y mode.  This means that instead of 6 options of what to display there would be 20 options (so that MATH can be either X or Y).
He’s like a trained ape. Without the training.
 

Online frozenfrogz

  • Frequent Contributor
  • **
  • Posts: 278
  • Country: de
  • Having fun with Arduino and Raspberry Pi
Re: Rigol DS1000Z series buglist continued (from: 00.04.04.03.02)
« Reply #2 on: April 12, 2017, 07:27:22 PM »
I could not reproduce the waveform shifting bug in the latest firmware.
Please confirm.
He’s like a trained ape. Without the training.
 

Online BravoV

  • Super Contributor
  • ***
  • Posts: 4203
  • Country: id
  • An EEE (Eternal Electronics Enthusiast)
Re: Rigol DS1000Z series buglist continued (from: 00.04.04.03.02)
« Reply #3 on: April 12, 2017, 08:07:19 PM »
Subbed

Offline Gabri74

  • Contributor
  • Posts: 48
  • Country: it
Re: Rigol DS1000Z series buglist continued (from: 00.04.04.03.02)
« Reply #4 on: April 12, 2017, 08:35:00 PM »
I could not reproduce the waveform shifting bug in the latest firmware.
Please confirm.

Confirmed, bug seems gone  :-+

Software Version: 00.04.04.03.02
Board Version: 0.1.1
Boot Version: 0.0.1.2
Firmware Version: 0.2.3.11
CPLD Version: 1.1
 

Offline Karel

  • Frequent Contributor
  • **
  • Posts: 938
  • Country: 00
The difference between theory and practice is less in theory than
the difference between theory and practice in practice.
Expensive tools cannot compensate for lack of experience.
 

Offline Karel

  • Frequent Contributor
  • **
  • Posts: 938
  • Country: 00
Re: Rigol DS1000Z series buglist continued (from: 00.04.04.03.02)
« Reply #6 on: April 12, 2017, 08:41:35 PM »
7) RAW mode of data acquisition over USB returns garbage, rather than the waveform.

(Not tested)

I tested it and it works fine. Please remove it from the list of bugs.
The difference between theory and practice is less in theory than
the difference between theory and practice in practice.
Expensive tools cannot compensate for lack of experience.
 

Online frozenfrogz

  • Frequent Contributor
  • **
  • Posts: 278
  • Country: de
  • Having fun with Arduino and Raspberry Pi
Re: Rigol DS1000Z series buglist continued (from: 00.04.04.03.02)
« Reply #7 on: April 12, 2017, 09:25:55 PM »
Done.

And finally figured out how to escape BBcode to get 8) instead of 8)

*yay*

Also: I found the language menu to hold a lot of languages now. As far as I remember it was only chinese and english before. Or am I mistaken?
« Last Edit: April 12, 2017, 09:32:41 PM by frozenfrogz »
He’s like a trained ape. Without the training.
 

Online Fungus

  • Super Contributor
  • ***
  • Posts: 6354
Re: Rigol DS1000Z series buglist continued (from: 00.04.04.03.02)
« Reply #8 on: April 12, 2017, 09:51:30 PM »
Also: I found the language menu to hold a lot of languages now. As far as I remember it was only chinese and english before. Or am I mistaken?

Yes.  :popcorn:

I don't know if there are any new ones in this release but there were definitely more than that.

Release notes say French was added in 2015.

Quote
v00.04.03.01.05   2015/06/16
     - Added French in system language
 

Online frozenfrogz

  • Frequent Contributor
  • **
  • Posts: 278
  • Country: de
  • Having fun with Arduino and Raspberry Pi
Re: Rigol DS1000Z series buglist continued (from: 00.04.04.03.02)
« Reply #9 on: April 12, 2017, 10:09:30 PM »
Strange. I could have sworn that when I first got my scope (00.04.03.xx software) it only showed two options. But then again I could easily confuse it with something totally different.  :-//
He’s like a trained ape. Without the training.
 

Offline kcbrown

  • Frequent Contributor
  • **
  • Posts: 357
  • Country: us
Re: Rigol DS1000Z series buglist continued (from: 00.04.04.03.02)
« Reply #10 on: April 13, 2017, 01:21:08 AM »
4) Some users have reported scope lock ups when setting memory depth to AUTO, timebase to 1us, zooming in and changing the persistence from MIN something else. Apparently not all users experience this problem but those that do can reproduce it every time.  See this thread for much more detail: http://www.eevblog.com/forum/testgear/rigol-ds1054z-freeze-up-bug/

(Could not be reproduced by me, please check if your unit was affected)

I'm able to consistently reproduce this with my unit with the current firmware.

Software version: 00.04.04.03.02
Board version: 0.1.1
Boot version: 0.0.1.2
Firmware Version: 0.2.3.11
CPLD Version: 1.1

 

Online frozenfrogz

  • Frequent Contributor
  • **
  • Posts: 278
  • Country: de
  • Having fun with Arduino and Raspberry Pi
Re: Rigol DS1000Z series buglist continued (from: 00.04.04.03.02)
« Reply #11 on: April 13, 2017, 01:27:20 AM »
That is unfortunate  :(
Thanks for testing and sharing.

Added Pass/Fail info on bug list.
« Last Edit: April 13, 2017, 01:33:29 AM by frozenfrogz »
He’s like a trained ape. Without the training.
 

Offline Fennec

  • Regular Contributor
  • *
  • Posts: 110
  • Country: 00
Re: Rigol DS1000Z series buglist continued (from: FW 00.04.04.03.02)
« Reply #12 on: April 13, 2017, 01:46:45 AM »
9) If the following settings are used:

  Input signal: probe compensation 1kHz square wave from the scope
  Trigger: DC / CH1 / 1.5V
  Aquisition: High Res / 120k mem. depth
  Horizontal position: 0ps
  Horizontal scale: 50us/div

  The scope will display the waveform shifted by around 75us.    See details in this picture:



Works. But:

PNG screenshot with thumb-drive and printer button takes 2 1/2 MINUTES !

Cannel Mark out of Range. So the scope measures 2.8Vpp but the signal is 3Vpp. (checked with 2 other scopes too.) Fluke 8842A => 1,492Vp

With this settings I can change the persist time to anything I want, the scope still freeze. So I have to turn it off (Power cycle and soft-button-reset) to make it usable again. ALL settings gone. Calibration too.

Since the last 3 updates the scope is still very very slow.   
« Last Edit: April 13, 2017, 02:24:40 AM by Fennec »
 

Offline kcbrown

  • Frequent Contributor
  • **
  • Posts: 357
  • Country: us
Re: Rigol DS1000Z series buglist continued (from: FW 00.04.04.03.02)
« Reply #13 on: April 13, 2017, 01:53:15 AM »
With this settings I change the persist time to anything the scope still freeze. So I have to turn it off (Power cycle and soft-button-reset) to make it usable again. ALL settings gone. Calibration too.

What I've found is that power cycling the scope is sufficient to restore functionality, because the scope restores every setting except the one that caused it to lock up, which suggests to me that (at least in my case) the scope is locking up before it gets a chance to save the last setting change.

Did you try a plain power cycle before doing a soft button reset?

Also, what are the versions of the various things (CPLD, firmware, board, boot) on your scope?   Note that to get that detailed information, you need to first quickly hit, in the trigger area, MENU MENU FORCE MENU, and then you can go to Utility -> System -> System Info to get the details.
« Last Edit: April 13, 2017, 01:56:51 AM by kcbrown »
 

Offline Fennec

  • Regular Contributor
  • *
  • Posts: 110
  • Country: 00
Re: Rigol DS1000Z series buglist continued (from: FW 00.04.04.03.02)
« Reply #14 on: April 13, 2017, 01:56:43 AM »
Did you try a plain power cycle before doing a soft button reset?
Yepp, but most times it wouldn't work. I have to do a full reset, with the soft button. Maybe 8 of 10 times.
 

Offline 2N3055

  • Frequent Contributor
  • **
  • Posts: 659
  • Country: hr
Re: Rigol DS1000Z series buglist continued (from: 00.04.04.03.02)
« Reply #15 on: April 13, 2017, 01:57:18 AM »
4) Some users have reported scope lock ups when setting memory depth to AUTO, timebase to 1us, zooming in and changing the persistence from MIN something else. Apparently not all users experience this problem but those that do can reproduce it every time.  See this thread for much more detail: http://www.eevblog.com/forum/testgear/rigol-ds1054z-freeze-up-bug/

(Could not be reproduced by me, please check if your unit was affected)


Cannot reproduce. Tried several times, different zoom, different persistence...
Scope detail info attached:
 

Offline kcbrown

  • Frequent Contributor
  • **
  • Posts: 357
  • Country: us
Re: Rigol DS1000Z series buglist continued (from: FW 00.04.04.03.02)
« Reply #16 on: April 13, 2017, 01:58:14 AM »
Did you try a plain power cycle before doing a soft button reset?
Yepp, but most times it wouldn't work. I have to do a full reset, with the soft button. Maybe 8 of 10 times.

Hmm...interesting.  I didn't reproduce the issue quite that many times, perhaps four.  But in each case, a power cycle was sufficient to restore functionality.

What are the versions of the various things (CPLD, firmware, board, boot) on your scope?   Note that to get that detailed information, you need to first quickly hit, in the trigger area, MENU MENU FORCE MENU, and then you can go to Utility -> System -> System Info to get the details.
 

Offline 2N3055

  • Frequent Contributor
  • **
  • Posts: 659
  • Country: hr
Re: Rigol DS1000Z series buglist continued (from: FW 00.04.04.03.02)
« Reply #17 on: April 13, 2017, 02:07:53 AM »
9) If the following settings are used:

  Input signal: probe compensation 1kHz square wave from the scope
  Trigger: DC / CH1 / 1.5V
  Aquisition: High Res / 120k mem. depth
  Horizontal position: 0ps
  Horizontal scale: 50us/div

  The scope will display the waveform shifted by around 75us.    See details in this picture:



Works. But:

PNG screenshot with thumb-drive and printer button takes 2 1/2 MINUTES !

Cannel Mark out of Range

With this settings I can change the persist time to anything I want, the scope still freeze. So I have to turn it off (Power cycle and soft-button-reset) to make it usable again. ALL settings gone. Calibration too.

Since the last 3 updates the scope is still very very slow.

Just tried that too. Doesn't happen either.  No shift, saves normally, maybe 6-8 seconds.. It does, however, save a bit faster (4-5 sec) if you stop acquisition.
It seems to me that it does behave differently on different batches. Maybe board rev, bootloader.. I don't know.

 

Offline bitseeker

  • Super Contributor
  • ***
  • Posts: 3276
  • Country: us
  • Lots of engineer-tweakable parts inside!
Re: Rigol DS1000Z series buglist continued (from: 00.04.04.03.02)
« Reply #18 on: April 13, 2017, 04:23:09 AM »
Thanks for creating the new thread, frozenfrogz. Following.
Got GAS? Get TEA.
 

Offline metrologist

  • Frequent Contributor
  • **
  • Posts: 718
  • Country: us
Re: Rigol DS1000Z series buglist continued (from: 00.04.04.03.02)
« Reply #19 on: April 13, 2017, 05:20:52 AM »
Mee two. I was wondering if you would use an ordered list for the bug list? It's just marginally easier to parse, but a heck of a lot harder to maintain and edit.
 
The following users thanked this post: garnix

Online frozenfrogz

  • Frequent Contributor
  • **
  • Posts: 278
  • Country: de
  • Having fun with Arduino and Raspberry Pi
Re: Rigol DS1000Z series buglist continued (from: 00.04.04.03.02)
« Reply #20 on: April 13, 2017, 06:12:09 AM »
I was wondering if you would use an ordered list for the bug list? It's just marginally easier to parse, but a heck of a lot harder to maintain and edit.

Tried to do some proper formatting, could not find a BBcode option to do an indent / tab stop that seems to work here, so for the moment it’s lists within lists :-/O

@Fennec:

Please provide your long system info, thanks :)

Also, it seems that some of the wish list items have been implemented in the recent software release. However, I do not really know how to synchronize with the wish list. I could dedicate my second post (with the quoted original post from the old thread) to be the place for wish list items in the future, but am not shure about that right now. A second thread just for the wish list seems a little misplaced IMO.
What do you think?

Regards,
Frederik
« Last Edit: April 13, 2017, 06:17:48 AM by frozenfrogz »
He’s like a trained ape. Without the training.
 

Offline Fennec

  • Regular Contributor
  • *
  • Posts: 110
  • Country: 00
Re: Rigol DS1000Z series buglist continued (from: 00.04.04.03.02)
« Reply #21 on: April 13, 2017, 06:41:48 AM »
Please provide your long system info, thanks :)

I post nothing. Since my last RESET my scope is complete ded. It boots up with this screen.



« Last Edit: April 13, 2017, 06:43:19 AM by Fennec »
 

Offline ankerwolf

  • Contributor
  • Posts: 47
  • Country: at
Re: Rigol DS1000Z series buglist continued (from: 00.04.04.03.02)
« Reply #22 on: April 13, 2017, 06:42:06 AM »
Hello,
I made update now on my DS1054Z (with Options now DS1104Z):
SW: 00.04.04.03.02 = 00.04.04.SP3
Board: 0.1.1
Boot: 0.0.1.3
FW: 0.2.3.11
CPLD: 1.1

Warm up >30'
Update ok > Power off > Power on
1. SelfCal (I seem to recall there were two more SoftButtons: [... LF ...] and [... Output ...]  ) >>> FAILED !!!
Same screen as Fennec !!!
> Power off > Power on
2. SelfCal (now only two SoftButtons) > ok.

LG Wolf
« Last Edit: April 13, 2017, 06:51:19 AM by ankerwolf »
 

Online frozenfrogz

  • Frequent Contributor
  • **
  • Posts: 278
  • Country: de
  • Having fun with Arduino and Raspberry Pi
Re: Rigol DS1000Z series buglist continued (from: 00.04.04.03.02)
« Reply #23 on: April 13, 2017, 06:48:07 AM »
I post nothing. Since my last RESET my scope is complete ded. It boots up with this screen.

Damn.

Did you try deep cycle / alternative reset?
PDF from Rigol on alternate reset

Also there is a memory clearing procedure:
PDF from Rigol on sanitizing memory

Good luck!
He’s like a trained ape. Without the training.
 

Offline Fennec

  • Regular Contributor
  • *
  • Posts: 110
  • Country: 00
Re: Rigol DS1000Z series buglist continued (from: 00.04.04.03.02)
« Reply #24 on: April 13, 2017, 07:04:35 AM »
Telnet still work. I check it tomorrow.
All knobs around the screen are ded. So Start or Exit wouldn't work. The screenshot takes a li'll less than 30 MIN. !

Never never again I buy those cheap crap from Rigol !

hf
"Pluses"

Thx for the PDF btw.


« Last Edit: April 13, 2017, 07:06:33 AM by Fennec »
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf

 

http://opalkelly.com/