Author Topic: Rigol DSA815 - problem with tracking generator?  (Read 349 times)

0 Members and 1 Guest are viewing this topic.

Offline cyberfuzzy

  • Contributor
  • Posts: 21
  • Country: de
Rigol DSA815 - problem with tracking generator?
« on: March 27, 2018, 09:36:58 am »
Hi. I'm not sure if there is a problem with the tracking generator of my Rigol DSA815. When I watch the signal with the scope it looks like the graph is not sinusoidal for <1 MHz.

I recorded a sweep from 500 kHz to 1.5 MHz, sweep time is 10 seconds:


On the spectrum analyzer the graph shows -18.1 dBm at 500 kHz and -19.2 dBm at 1.5 MHz. I don't think that the cable (RG-58) is that bad:


The setup is a cable from the tracking generator to the scope and back to the input of the spectrum analyzer:


Can anybody reproduce that issue? Is there a problem with my tracking generator or does every DSA815 act like this?
« Last Edit: March 27, 2018, 09:38:34 am by cyberfuzzy »
 

Offline cyberfuzzy

  • Contributor
  • Posts: 21
  • Country: de
Re: Rigol DSA815 - problem with tracking generator?
« Reply #1 on: March 28, 2018, 09:36:49 pm »
According to this thread it seems to be normal for those cheap spectrum analyzers:
http://www.eevblog.com/forum/testgear/rigol-dsa-815-tracking-generator-distortion/

On my DSA815 the signal does not look sinusoidal for frequencies below 1 MHz. I took 3 screenshots with the scope for 10 kHz, 100 kHz and 1 MHz at zero span.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf