Author Topic: Rigol-Tektronix adapter T2R1000, problem with connecting P6247 with DS4024  (Read 314 times)

0 Members and 1 Guest are viewing this topic.

Offline krisk

  • Contributor
  • Posts: 11
  • Country: pl
Hello,
I want to connect Tektronix differential probe P6247 to my Rigol DS4024. I check the spec of Rigol-Tektronix adapter "T2R1000", and every thing was fine (both oscilloscope and probe are in the adapter datesheet).

Unfortunately when I connect all together, probe seems to be not working. I have check it before with some Tek oscilloscope and it was working fine.
For T2R1000 and DS4024 I'm the first owner so they should be also functional. Any idea how to verified scope interface / adapter functionality ?

I could also try to connect it to the brand new Rigol MSO7024, but I'm not sure if it is safe( this model is not listed as the compatible scope for adapter).

Bellow information regarding my scope Rigol DS4024:
SW version (newest) 00.02.03.00.03
HW version: 1.2

Best Regards
 

Offline krisk

  • Contributor
  • Posts: 11
  • Country: pl
I did some investigation and is seems that T2R1000 adapter have correct voltages levels on the TekProbe interface.


When I hook up it to the oscilloscope while probe tip is connected to the test signal, I can see that probe works for the short time and the output signal is slowly decreasing its amplitude to disappear eventually.

I did comparison between Rigol T2R1000 adapter and Tek 1103 power supply. I noticed that adapter can deliver up to 150mA on each power supply rail and Tek can give 300mA.

When i work with Tek TDS3024B oscyloscope (where P6247 is correctly working) probe is warm.
I'm suspecting that P6247 is consuming more then 150mA and Rigol adapter is basically not able to work with it or it is jus damaged :)

Does anybody know what is the Tek P6247 current consumption? 
« Last Edit: March 05, 2019, 04:51:30 am by krisk »
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf