Low Cost PCB's Low Cost Components

Author Topic: Rigol Ultra Sigma and Win 8.1  (Read 5996 times)

0 Members and 1 Guest are viewing this topic.

Offline ka7gzr

  • Contributor
  • Posts: 12
Rigol Ultra Sigma and Win 8.1
« on: March 31, 2014, 05:51:36 AM »
I have Win 8.1 When I start Ultra Sigma 1.05.10 it boots properly. I see my instruments listed in the "online resource" directory. If I try to run an application e.g. Ultra Spectrum I get a Windows message saying "Ultra Sigma has stopped working" and I am forced to close the program. I have tried all of the various compatibility settings and I always get the same results. I also have tried just loading Ultra Sigma alone and it still crashes. On a very rare occasion it will run with Ultra Spectrum. Once it is running it is flawless. Has anyone else experienced this? Does anyone else have the Rigol software running correctly with Win 8.1?
Jim
 

Offline Rigby

  • Super Contributor
  • ***
  • Posts: 1475
  • Country: us
  • Learning, very new at this. Righteous Asshole, too
Re: Rigol Ultra Sigma and Win 8.1
« Reply #1 on: April 01, 2014, 11:49:20 AM »
I have win 8.1 and it's all fine for me.
 

Offline ka7gzr

  • Contributor
  • Posts: 12
Re: Rigol Ultra Sigma and Win 8.1
« Reply #2 on: April 02, 2014, 07:37:46 AM »
I have win 8.1 and it's all fine for me.
OK thanks for the feedback. I was told yesterday that Ultra Sigma was not compatible with Win 8 and Rigol will have a new version by the end of the month.
Jim
 

Offline Rigby

  • Super Contributor
  • ***
  • Posts: 1475
  • Country: us
  • Learning, very new at this. Righteous Asshole, too
Re: Rigol Ultra Sigma and Win 8.1
« Reply #3 on: April 02, 2014, 08:09:29 AM »
That's interesting; it does indeed work for me.  Not sure what I'm doing or have done that you haven't (or haven't done that you have.)

Updates from Rigol are always welcome because their software sucks.
 

Offline TVman

  • Frequent Contributor
  • **
  • Posts: 260
  • Country: us
  • Life is A bunch of people staring at computers. ;)
Re: Rigol Ultra Sigma and Win 8.1
« Reply #4 on: April 02, 2014, 08:19:13 AM »
I never knew that you could put win 8.1 on A rigol. :-//
Very cool though! :-+ :-+ :-+ :clap: :D
Yeah, I play Minecraft!
But I'm on here more because I learn more. :D
 

Offline echen1024

  • Super Contributor
  • ***
  • Posts: 1666
  • Country: us
  • 15 yo Future EE
Re: Rigol Ultra Sigma and Win 8.1
« Reply #5 on: April 02, 2014, 03:09:16 PM »
8.1 and UltraSigma work here, no problems.
I'm not saying we should kill all stupid people. I'm just saying that we should remove all product safety labels and let natural selection do its work.

http://www.youtube.com/user/echen1024
 

Offline ka7gzr

  • Contributor
  • Posts: 12
Re: Rigol Ultra Sigma and Win 8.1
« Reply #6 on: April 03, 2014, 03:17:54 AM »
My computer that I'm trying to run Ultra Sigma on is a 32 bit version. I'm wondering what others have that are successfully running Ultra Sigma with Win 8.1?
 

Offline ats3788

  • Contributor
  • Posts: 8
Re: Rigol Ultra Sigma and Win 8.1
« Reply #7 on: April 20, 2014, 01:07:42 AM »
I have the same Problem
does not work for me on win 8.1
 

Offline Bryan

  • Frequent Contributor
  • **
  • Posts: 534
  • Country: ca
Re: Rigol Ultra Sigma and Win 8.1
« Reply #8 on: April 20, 2014, 08:03:50 AM »
Does it work if you right click the exe and select run as administrator?
-=Bryan=-
 

Offline ka7gzr

  • Contributor
  • Posts: 12
Re: Rigol Ultra Sigma and Win 8.1
« Reply #9 on: April 21, 2014, 03:39:22 AM »
In all cases Ultra Sigma starts. I have tried running as an administrator by right clicking and selecting "run as an administrator". In either case after it has started it will either stop within a few seconds with the windows message "Ultra Sigma has stopped working" or I select a utility and then I get the message.
 

Offline ka7gzr

  • Contributor
  • Posts: 12
Re: Rigol Ultra Sigma and Win 8.1
« Reply #10 on: May 18, 2014, 04:32:21 AM »
Rigol posted Ultra Sigma and am still having issues running it on my 32 bit win 8.1 machine. Those of you that responded running or not what was your machine 32 or 64 bit?
 

Offline saspus

  • Supporter
  • ****
  • Posts: 3
Re: Rigol Ultra Sigma and Win 8.1
« Reply #11 on: June 06, 2014, 02:03:11 AM »
I think I found a workaround.

I'm using 8.1 x64 and it also crashes  (in random places, likely due to heap corruption, ironically most of the time in what seems to be the code to render non-standard looking black window :) ) in a short time after launching and/or after most actions.

I had success setting it to run in Windows XP Service Pack 3 compatibility mode.  This seem to be working.

I don't fully understand the reason, but I think it's due to different process memory layout on these two OSes and whatever corruption occurs in the process happens to not be fatal on XP. Rigol still needs to debug and fix it though. I'll try to file a report and send them a dump, if I find a way to approach them.
 

Offline ka7gzr

  • Contributor
  • Posts: 12
Re: Rigol Ultra Sigma and Win 8.1
« Reply #12 on: June 06, 2014, 06:19:42 AM »
Thanks saspus for your response.
I have tried the various compatibility modes including Windows XP SP3 with no joy. It still crashes. When I run it in this mode, it slows the program way down but it eventually boots. Within a short amount of time it too crashes.
If you contact Rigol USA tech support they are helpful. Although with any "hard" questions they need to contact mother Rigol.
 

Offline saspus

  • Supporter
  • ****
  • Posts: 3
Re: Rigol Ultra Sigma and Win 8.1
« Reply #13 on: June 06, 2014, 06:42:57 AM »
Hello ka7gzr,

You are right, I spoke too soon. It does indeed crash, just later down the road, and with different callstacks.

I've sent the request to their NA support via http://www.rigolna.com/tech-support/ , waiting for response, but I agree, this probably shall end up with the Ultra Sigma dev team, which might not be in the U.S.

I'll update this thread when/if I hear anything definitive from them.

 

Offline ka7gzr

  • Contributor
  • Posts: 12
Re: Rigol Ultra Sigma and Win 8.1
« Reply #14 on: June 06, 2014, 03:26:32 PM »
Thanks saspus- I will also push for a solution from Rigol.
 

Offline saspus

  • Supporter
  • ****
  • Posts: 3
Re: Rigol Ultra Sigma and Win 8.1
« Reply #15 on: April 10, 2015, 05:53:04 PM »
Even though it's been quite a time thought I'd still update the thread even though I don't have any news.

I haven't received any response from Rigol, neither on my original email nor follow up in a month, and I will probably give up at this point.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf