Low Cost PCB's Low Cost Components

Author Topic: Siglent CML+ Firmware ?  (Read 9765 times)

0 Members and 1 Guest are viewing this topic.

Offline StillTrying

  • Frequent Contributor
  • **
  • Posts: 892
  • Country: gb
  • 100% Brand New and High Quality, in theory.
Re: Siglent CML+ Firmware ?
« Reply #50 on: April 04, 2017, 02:12:18 AM »
Minor oddities.

Viewing the onscreen Time measurements while in Alt/DuelTB mode messes up the Units of the time measurements, they all should be 2.25MHz.  AltUnits1.gif

The pass/fail Y mask is always 2X the set Y value.  MaskYx2.gif
 
The following users thanked this post: tautech

Offline StillTrying

  • Frequent Contributor
  • **
  • Posts: 892
  • Country: gb
  • 100% Brand New and High Quality, in theory.
Re: Siglent CML+ Firmware ?
« Reply #51 on: April 04, 2017, 05:54:07 AM »
ETS mode on >100ns/div speeds, just for a change.  >:D

When I STOP an ETS waveform, why does it STOP with the opposite trigger edge polarity under the trigger position, as shown by the left-behind persistence.
I've tried the LP and HP trigger filters just in case, - no difference.
The STOP is instant, it's not doing another ETS scan, just choosing a different trigger position to display from the STOPped waveform data.

ETSafterselfcal.gif  is now, right after a 25sec. self calibration.

ETSold.gif is an old one from long ago (.16 FW)

« Last Edit: April 04, 2017, 06:01:52 AM by StillTrying »
 

Offline StillTrying

  • Frequent Contributor
  • **
  • Posts: 892
  • Country: gb
  • 100% Brand New and High Quality, in theory.
Re: Siglent CML+ Firmware ?
« Reply #52 on: April 05, 2017, 07:51:29 AM »
Channel Skew takes ages to wind up from 0ns to 5ns, it keeps jumping up to 12 to 15ns, the trick seems to be to stop about every 1ns and wait a second or 2, still takes ages.

It doesn't always save on power off, it's 50:50 whether it'll be on 0ns or 5ns on power up.

Using EXTtrig ignores any (carefully set!) skew values.


When using EXTTrig pressing "Set to 50%" always sets the trigger level to 0V, rather than 50% of trigger's amplitude.

That's the last 'feature' I can remember - for now!
« Last Edit: April 10, 2017, 05:44:54 AM by StillTrying »
 
The following users thanked this post: tautech

Offline StillTrying

  • Frequent Contributor
  • **
  • Posts: 892
  • Country: gb
  • 100% Brand New and High Quality, in theory.
Re: Siglent CML+ Firmware ?
« Reply #53 on: April 20, 2017, 06:35:33 PM »
It must be time for the unreleased FW to be ununreleased. :)

Online tautech

  • Super Contributor
  • ***
  • Posts: 9596
  • Country: nz
    • Taupaki Technologies Ltd.
Re: Siglent CML+ Firmware ?
« Reply #54 on: April 28, 2017, 11:18:49 PM »
Avid Rabid Hobbyist & NZ Siglent Distributor
 

Offline StillTrying

  • Frequent Contributor
  • **
  • Posts: 892
  • Country: gb
  • 100% Brand New and High Quality, in theory.
Re: Siglent CML+ Firmware ?
« Reply #55 on: April 30, 2017, 08:15:49 AM »
2017/4/7
6.01.01.19
1. Repaired bug causing Math error when trace is stopped in dot display mode.
2. Fixed ‘add measurement’error in Polish language.
3. Bug repaired when measuring frequency of 500 Hz, using alternate trigger, and a time base of greater than 1 ms/div.

Update instructions
Before updating the ADS file, the ADS file need to be renamed and ensured that its name is less than 9 letters.

Hmmm... :-\
I get the impression I could list the results before installing the firmware. :-X

Online tautech

  • Super Contributor
  • ***
  • Posts: 9596
  • Country: nz
    • Taupaki Technologies Ltd.
Re: Siglent CML+ Firmware ?
« Reply #56 on: April 30, 2017, 08:28:21 AM »
Update instructions
Before updating the ADS file, the ADS file need to be renamed and ensured that its name is less than 9 letters.
This is because the file system UI will not display the full filename larger than 9 characters in SDS1*****L models.
It has always been this way and now the update instruction have been changed to try to help users not make a mistake and possibly brick a unit.
The risk is higher when a user has many upgrade files on 1 USB stick but if care is taken there is little problem and risk.

Edit
I'll have a chance to check this update today. Please put up links to posts you've made about thing that have not been fixed.
« Last Edit: April 30, 2017, 08:38:43 AM by tautech »
Avid Rabid Hobbyist & NZ Siglent Distributor
 

Offline StillTrying

  • Frequent Contributor
  • **
  • Posts: 892
  • Country: gb
  • 100% Brand New and High Quality, in theory.
Re: Siglent CML+ Firmware ?
« Reply #57 on: April 30, 2017, 08:59:10 AM »
OK. The new filename would clash with the old .18 which shows as SDS1000CML+_V on the scope.

Would there be many improvements not listed? I can't think of any reason to install it if it's just 1,2,3.

Online tautech

  • Super Contributor
  • ***
  • Posts: 9596
  • Country: nz
    • Taupaki Technologies Ltd.
Re: Siglent CML+ Firmware ?
« Reply #58 on: April 30, 2017, 09:20:14 AM »
OK. The new filename would clash with the old .18 which shows as SDS1000CML+_V on the scope.

Would there be many improvements not listed? I can't think of any reason to install it if it's just 1,2,3.
Not all improvements are always listed, but I'll make it my next task to check this update.
Just grabbed the update and un-rar'ed it so I'm ready to go.
Have to reacquaint myself with all that's been happening with these so it might take an hour or so.
If you're not still up (11am here) check for comments in the morning.
Avid Rabid Hobbyist & NZ Siglent Distributor
 

Offline StillTrying

  • Frequent Contributor
  • **
  • Posts: 892
  • Country: gb
  • 100% Brand New and High Quality, in theory.
Re: Siglent CML+ Firmware ?
« Reply #59 on: April 30, 2017, 09:35:10 AM »
"(11am here)"
00:30 Sunday here, I'll be up for 2 hours-ish yet!

Online tautech

  • Super Contributor
  • ***
  • Posts: 9596
  • Country: nz
    • Taupaki Technologies Ltd.
Re: Siglent CML+ Firmware ?
« Reply #60 on: April 30, 2017, 09:57:13 AM »
"(11am here)"
00:30 Sunday here, I'll be up for 2 hours-ish yet!
:)
Install it quick before Siglent pull it down. My SDS1102CML+ is now SDS1152CML+.  >:D

Checking other stuff.
Avid Rabid Hobbyist & NZ Siglent Distributor
 

Offline StillTrying

  • Frequent Contributor
  • **
  • Posts: 892
  • Country: gb
  • 100% Brand New and High Quality, in theory.
Re: Siglent CML+ Firmware ?
« Reply #61 on: April 30, 2017, 10:51:47 PM »
Oh dear, cut the filename down to 9 chars, FPGA_V5.2.ADS and been stuck on

Updating firmware now. Do not interrupt power to the DSO during this process, or the DSO will no longer boot.

for 8 minutes so far.
« Last Edit: April 30, 2017, 10:56:32 PM by StillTrying »
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 9596
  • Country: nz
    • Taupaki Technologies Ltd.
Re: Siglent CML+ Firmware ?
« Reply #62 on: April 30, 2017, 11:12:16 PM »
Oh dear, cut the filename down to 9 chars, FPGA_V5.2.ADS and been stuck on

Updating firmware now. Do not interrupt power to the DSO during this process, or the DSO will no longer boot.

for 8 minutes so far.
EDIT
IMPORTANT NOTE

The following few posts are to resolve an unexpected error where a firmware update freezes on install.
Advice to turn off the power when the SDS1***CML+ has frozen is against all advice by the manuals and Siglent. Proceed with extreme care.

------------------------------------------------------------------------------------

Had a customer have the same problem.  :-//
Pull the USB stick and power it off.....yes, cut the power.
Try another stick.
I had no problem doing one I had here, didn't change the filename but did take care to select the correct file.
Customer tried twice with the same stick while I waited on the phone but as it was getting late I suggested he use another stick in the morning and give me a shout about the outcome.
Have a try or wait for my local guinea pig to report back.
(apologies to John)
« Last Edit: May 01, 2017, 06:52:24 AM by tautech »
Avid Rabid Hobbyist & NZ Siglent Distributor
 

Offline StillTrying

  • Frequent Contributor
  • **
  • Posts: 892
  • Country: gb
  • 100% Brand New and High Quality, in theory.
Re: Siglent CML+ Firmware ?
« Reply #63 on: April 30, 2017, 11:19:32 PM »
"Pull the USB stick and power it off.....yes, cut the power."

Switching it off 1st rather than pulling the USB 1st would seem the safest to me, not done either yet.
No problem with the USB that I know of.
Perhaps it's just giving me enough time to get its box ready. :)

Edit:
Pulled the USB, switched it off, switched it back on, and seems to be normal and still on FW .18.
« Last Edit: April 30, 2017, 11:31:17 PM by StillTrying »
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 9596
  • Country: nz
    • Taupaki Technologies Ltd.
Re: Siglent CML+ Firmware ?
« Reply #64 on: April 30, 2017, 11:32:28 PM »
"Pull the USB stick and power it off.....yes, cut the power."

Switching it off 1st rather than pulling the USB 1st would seem the safest to me, not done either yet.
No problem with the USB that I know of.
Perhaps it's just giving me enough time to get its box ready. :)
From the stick the update just takes ~15s to load and the scope takes only a few minutes to digest it.
If the USB stick read/write LED is not on, pull it and power off. John had to do this twice and then we decided to try again in the morning.
Late here now but I'll do another one I have in the morning and report back.

BTW if you shortened the filename just be sure to leave the .ads file extension intact.  ;)
Avid Rabid Hobbyist & NZ Siglent Distributor
 

Offline StillTrying

  • Frequent Contributor
  • **
  • Posts: 892
  • Country: gb
  • 100% Brand New and High Quality, in theory.
Re: Siglent CML+ Firmware ?
« Reply #65 on: April 30, 2017, 11:42:04 PM »
"didn't change the filename but did take care to select the correct file."

That's the way I normally do it, throw everything else in a folder so that there's only the one firmware showing in the root, but that long-filename method instantly gives "Update Failed" and exits the update screen.

I'll re-download it and try again soon.

Edit: Is "John" also the one without 'Siglent' and the LongMem option.
« Last Edit: April 30, 2017, 11:48:32 PM by StillTrying »
 
The following users thanked this post: tautech

Offline StillTrying

  • Frequent Contributor
  • **
  • Posts: 892
  • Country: gb
  • 100% Brand New and High Quality, in theory.
Re: Siglent CML+ Firmware ?
« Reply #66 on: May 01, 2017, 07:29:26 AM »
Tried a few things including reinstalling FW .18 which was fine.
Gave up. But while watching the snooker, dreamt up the idea to make the filename as close as possible to the .18 filename, making it  SDS1000CML+_V100R006B01D01P19.ADS, which worked! although a bit longer than the recommended 8 chars.

No differences/changes/improvements found yet, so list follows.
« Last Edit: May 01, 2017, 10:00:57 AM by StillTrying »
 
The following users thanked this post: tautech

Offline StillTrying

  • Frequent Contributor
  • **
  • Posts: 892
  • Country: gb
  • 100% Brand New and High Quality, in theory.
Re: Siglent CML+ Firmware ?
« Reply #67 on: May 01, 2017, 07:40:31 AM »
FW  6.01.01.18  to  6.01.01.19
HW  B-64-5.1  ( seems to have changed to B-64-5.2  with P19 )
SN  SDS10BA216****


Trigger Level line going off with change of FW. #8,#13
  Off by only 0.2 Div. P18 -> P19

Missing Dots Persistance, with 1CH 100ns & 50ns/Div, with 2CHs just missing from 100ns/Div. #2,#13

Missing Dots Persistance/LongMem 25ns/Div and 2.5ns/Div. #22

Unstable ETS mode, lockups, freezes. When switching to ETS, the freeze can be so fast that it doesn't even have time to change the menu from "Real Time" to "Equ Time".

Jumping Waveforms on ETS STOP. #15

STOP works differently on Normal/Long Memory. #22,#30

LongMem corrupted displays. #24,#30,#34

LongMem Option disappeared. #35

Math sensitivity goes to 1pV/Div. #42

Making any changes to Math, including just returning to the Math menu, resets the Math sensitivity to that of the scope channels, but it doesn't seem to take into account the probes' X10 setting.

Trigger X position sometimes moving with X expansion on STOPed waveforms. #45

ETS waveform STOPs on the opposite trigger edge polarity. #51

Channel Skew adjustment jumping/not saving. #52

EXTtrig ignores Channel Skew values. #52

EXTrig "Set to 50%" sets to 0V. #52

Intermittent Saving of REF 'A' or 'B' waveforms, broke P18 -> P19. #69
 - Improved by itself, just an occasional unexplained "Function isn't useable."

Unexplained lockups/freezes when using Scan Mode on slow timebases 1 to 10 Sec/div.
10S/Div. the worst, will lock up on power up after the splash screen if I don't quickly turn the TB up to 50ms/div.

In Scan Mode touching almost any control causes the trace to restart, about the only control you can touch without losing the captured scan is RUN/STOP.


Minor oddities #50
  The messed up ALT Time Units Fixed in P19.

Pressing STOP while in Math,Dots+Persistence mode giving the whiteout. #41
  Maybe  Fixed in P19.

« Last Edit: August 14, 2017, 08:35:02 PM by StillTrying »
 
The following users thanked this post: tautech

Offline Electro Detective

  • Frequent Contributor
  • **
  • Posts: 905
  • Country: au
Re: Siglent CML+ Firmware ?
« Reply #68 on: May 07, 2017, 09:50:28 AM »
Wow, there's more electronic snafu action going down here than on the first episode of Lost In Space     :popcorn:

And I thought losing the Siglent boot time splash screen was a concern after unboxing a CFL, and applying a firmware update to resolve a weird Channel 1 gain issue (fixed btw).

I haven't run the unit through its paces yet to see if that's the only issue   :-\


EDIT /UPDATE: Siglent did contact me and after some email chat back and forth describing the snafu to their staff/engineers,
they promptly sent me a file that fixed the issue    :clap:

This is what I like to see  :-+  it encourages one to BUY new gear with Support confidence, and give it a whirl,

rather than stick to using well made older gear that keeps working (sometimes with a bit of TLC of course) 


« Last Edit: August 15, 2017, 10:07:47 AM by Electro Detective »
 

Offline StillTrying

  • Frequent Contributor
  • **
  • Posts: 892
  • Country: gb
  • 100% Brand New and High Quality, in theory.
Re: Siglent CML+ Firmware ?
« Reply #69 on: May 09, 2017, 07:50:14 AM »
P19
I can only Save a new REF waveform about 25% of the time, can't find any reason why "Function isn't useable" about 75% of the time, not seen this before.

Edit: After 5 mins off and a reboot, now worse, only saved once out of about 20 tries!
« Last Edit: May 11, 2017, 07:38:48 AM by StillTrying »
 
The following users thanked this post: tautech

Offline StillTrying

  • Frequent Contributor
  • **
  • Posts: 892
  • Country: gb
  • 100% Brand New and High Quality, in theory.
Re: Siglent CML+ Firmware ?
« Reply #70 on: August 14, 2017, 08:32:44 AM »
It must be time for new CML+ firmware.
 
The following users thanked this post: tautech

Online tautech

  • Super Contributor
  • ***
  • Posts: 9596
  • Country: nz
    • Taupaki Technologies Ltd.
Re: Siglent CML+ Firmware ?
« Reply #71 on: August 14, 2017, 08:47:41 AM »
It must be time for new CML+ firmware.
You ain't kidding.
I send Siglent reminders of this thread ~once a month. Latest was last week.  :rant:
Avid Rabid Hobbyist & NZ Siglent Distributor
 
The following users thanked this post: StillTrying, Electro Detective

Offline StillTrying

  • Frequent Contributor
  • **
  • Posts: 892
  • Country: gb
  • 100% Brand New and High Quality, in theory.
Re: Siglent CML+ Firmware ?
« Reply #72 on: August 15, 2017, 11:16:15 PM »
EDIT /UPDATE: Siglent did contact me and after some email chat back and forth describing the snafu to their staff/engineers, they promptly sent me a file that fixed the issue    :clap:

I wish they'd send me "a file", have you seen my (up to date) list just above.


Offline Electro Detective

  • Frequent Contributor
  • **
  • Posts: 905
  • Country: au
Re: Siglent CML+ Firmware ?
« Reply #73 on: August 17, 2017, 09:44:14 AM »
EDIT /UPDATE: Siglent did contact me and after some email chat back and forth describing the snafu to their staff/engineers, they promptly sent me a file that fixed the issue    :clap:

I wish they'd send me "a file", have you seen my (up to date) list just above.

Send them  a PM and you might get lucky

fwiw  I'm not a DSO power user (yet) I bought mine for basic 4 channel monitoring, simple wysiwyg controls, some quick capture stuff,
and because the popular Rigol 4/2 channel knob layout wasn't my cup of tea 
 
I probably won't find out any time soon if it has any more bugs or quirks to speak of, I still get my main work done with old school analogue storage scope/s.

Good luck    :-+     


maybe they'll consider to take it back if it's a dud and do a fair deal/swap via their local distributor on something else... to put closure on this post.   



 

Offline StillTrying

  • Frequent Contributor
  • **
  • Posts: 892
  • Country: gb
  • 100% Brand New and High Quality, in theory.
Re: Siglent CML+ Firmware ?
« Reply #74 on: August 21, 2017, 07:29:27 AM »
Electro D
The next FW is supposed to be file-able/cfg-able, but I won't be holding my breath. ;D
 
The following users thanked this post: Electro Detective


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf