Author Topic: Siglent CML+ Firmware ?  (Read 15054 times)

0 Members and 1 Guest are viewing this topic.

Offline StillTrying

  • Super Contributor
  • ***
  • Posts: 1415
  • Country: gb
  • 100% Brand New and High Quality, in theory.
Re: Siglent CML+ Firmware ?
« Reply #75 on: August 24, 2017, 08:13:22 am »
Pass/fail doesn't work(detect) when in DOTs Mode.
« Last Edit: August 24, 2017, 09:50:46 am by StillTrying »
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 12830
  • Country: nz
  • NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Siglent CML+ Firmware ?
« Reply #76 on: August 24, 2017, 08:22:28 am »
Pass/fail doesn't work(detect) when in DOTs Mode.
You have Persistence enabled which is not appropriate for Pass/Fail tests.

The solution would be to display a warning that Pass/Fail will not work is Persistence modes. (needs adding to the GUI)
Avid Rabid Hobbyist
 

Offline StillTrying

  • Super Contributor
  • ***
  • Posts: 1415
  • Country: gb
  • 100% Brand New and High Quality, in theory.
Re: Siglent CML+ Firmware ?
« Reply #77 on: August 24, 2017, 10:03:49 am »
You have Persistence enabled which is not appropriate for Pass/Fail tests.

Nope, it doesn't seem to be that, on this scope any old persistence is just ignored the scope can't see it, any auto measurements are done on just on the last full brightness scan.
« Last Edit: August 24, 2017, 10:09:42 am by StillTrying »
 

Offline StillTrying

  • Super Contributor
  • ***
  • Posts: 1415
  • Country: gb
  • 100% Brand New and High Quality, in theory.
Re: Siglent CML+ Firmware ?
« Reply #78 on: September 19, 2017, 10:42:21 am »
FW  6.01.01.18  to  6.01.01.19
HW  B-64-5.1  ( seems to have changed to B-64-5.2  with P19 )
SN  SDS10BA216****


1. LongMem Option disappeared. #35

2. LongMem corrupted displays. #24,#30,#34

3. STOP works differently on Normal/Long Memory. #22,#30
Pressing STOP while using LongMem actually puts the CML+ into single capture mode.
(I think I know why it's been done that way, but after using NormalMem, and for slow triggers/captures it's a pain.)

4. Trigger X position sometimes moves to a different part of the waveform when X-expanding a STOPed waveform. #45, #79
It's more common when the X trigger position if well off the screen center position.

5. EXTrig "Set to 50%" actually sets the trigger level to 0V, same as pressing the triglevel knob. #52

6. Using EXTtrig ignores any Channel Skew set values. #52

7. Channel Skew adjustment jumps and saves randomly(50/50) on power-off. #52


8. Unstable ETS mode, lockups, freezes. When switching to ETS, the freeze can be so fast that it doesn't even have time to change the menu item from "Real Time" to "Equ Time", turning the TB up to 50ns/div it can freeze before it's changed the on screen M100ns to M50ns.

9. ETS waveform STOPs on the opposite trigger edge polarity. #51
STOPping on a +ve edge when set to -ve edge is more common than the STOPping on a -ve edge when set to +ve edge.

10. Jumping Waveforms on ETS STOP. #15


11. Intermittent Saving of REF 'A' or 'B' waveforms, broke P18 -> P19. #69
 - Improved by itself, just an occasional unexplained "Function isn't useable."


12. Unexplained lockups/freezes when using Scan Mode on slow timebases 1sec to 10 sec/div.
10S/Div. the worst, will lock up on power up after the splash screen if I don't quickly turn the TB up to 50ms/div.

13. In Scan Mode touching almost any control causes the trace to restart, about the only control you can carefully touch without losing the captured scan is RUN/STOP.


14. DOTs Persistance missing on 100ns & 50ns/Div with 1CH in use, with 2CHs in use just missing on 100ns/Div. #2,#13

15. Dots Persistance missing on 25ns/Div and 2.5ns/Div on LongMem. #22

16. DOTs persistance missing on Zoom/DelayTB Mode. #22


17. Pass/fail doesn't work(detect) when in DOTs Mode. #75


18. Making almost any changes to Math, including just viewing the Math menu, keeps resetting the Math sensitivity to that of the scope channels, but it doesn't seem to take into account the probes' X10 setting.
Math sensitivity adjustment direction is reverse of Y channels, it's easy to find yourself on the way to 1pV/div.

19. Pressing the Trigger "Set to 50%" when a channel is "Inverted" sets the trigger level to the waveform's
old (before inverted) position, and the trigger level control now works in reverse.

20. Trigger Holdoff adjustment steps don't vary with timebase speed, they're still 10ns steps at 250ms/div. making Trigger holdoff unusable for slower timebase speeds.
« Last Edit: October 13, 2017, 11:56:39 pm by StillTrying »
 
The following users thanked this post: tautech

Offline StillTrying

  • Super Contributor
  • ***
  • Posts: 1415
  • Country: gb
  • 100% Brand New and High Quality, in theory.
Re: Siglent CML+ Firmware ?
« Reply #79 on: October 11, 2017, 11:29:02 pm »
"4. Trigger X position sometimes moves to a different part of the waveform when X-expanding a STOPped waveform. #45, #79"

I've found what causes this, and can produce many of them...


Online tautech

  • Super Contributor
  • ***
  • Posts: 12830
  • Country: nz
  • NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: Siglent CML+ Firmware ?
« Reply #80 on: October 12, 2017, 05:53:25 am »
"4. Trigger X position sometimes moves to a different part of the waveform when X-expanding a STOPped waveform. #45, #79"

I've found what causes this, and can produce many of them...
This behaviour can be related to the trigger Holdoff setting....not hard to check.  ;)
Avid Rabid Hobbyist
 

Offline StillTrying

  • Super Contributor
  • ***
  • Posts: 1415
  • Country: gb
  • 100% Brand New and High Quality, in theory.
Re: Siglent CML+ Firmware ?
« Reply #81 on: October 12, 2017, 12:05:09 pm »
This behaviour can be related to the trigger Holdoff setting....not hard to check.  ;)

It's something to do with the trigger hysteresis levels, but thanks for reminding me to add trigger holdoff to the list as well!

Offline StillTrying

  • Super Contributor
  • ***
  • Posts: 1415
  • Country: gb
  • 100% Brand New and High Quality, in theory.
Re: Siglent CML+ Firmware ?
« Reply #82 on: October 16, 2017, 09:03:31 am »
It would be good if any other CML+ or DL+ users could reproduce - or not, any of the features in the list above.


Near the bottom or top of the screen, the trigger level indication is off by about a mile, it doesn't trigger at all if the line is within the waveform's amplitude.

Offline StillTrying

  • Super Contributor
  • ***
  • Posts: 1415
  • Country: gb
  • 100% Brand New and High Quality, in theory.
Re: Siglent CML+ Firmware ?
« Reply #83 on: February 18, 2018, 12:34:21 am »
The List in Reply #78 above is current/uptodate.

« Last Edit: April 15, 2018, 01:52:55 am by StillTrying »
 

Offline StillTrying

  • Super Contributor
  • ***
  • Posts: 1415
  • Country: gb
  • 100% Brand New and High Quality, in theory.
Re: Siglent CML+ Firmware ?
« Reply #84 on: April 15, 2018, 01:52:21 am »
Vertical Scale is recorded to only 2 decimal places, so when below 10mV/div. it comes out as 0V/div.


Vertical Units,CH1:V CH2:V,,-4.09599971771,0.00552,-0.06800
Vertical Scale,CH1:0.00 CH2:0.05,,-4.09560012817,0.00552,-0.06800
Vertical Offset,CH1:-0.00472 CH2:-0.01700,,-4.09520006180,0.00536,-0.07000



Why do the first 8 csv samples have to be written up there, it's a bit of a pain!

Record Length,40000,,Source,CH1
Sample Interval,CH1:0.0000020000000,,Second,Volt
Vertical Units,CH1:V,,-0.02047999948,-1.46000,
Vertical Scale,CH1:0.50,,-0.02047800086,-1.50000,
Vertical Offset,CH1:0.00,,-0.02047600038,-1.48000,
Horizontal Units,s,,-0.02047399990,-1.48000,
Horizontal Scale,0.0010000000,,-0.02047199942,-1.50000,
Model Number,SDS110X,,-0.02047000080,-1.46000,
Serial Number,SDS10BA*******,,-0.02046800032,-1.48000,
Software Version,6.01.01.19,,-0.02046599984,-1.50000,
,,,-0.02046399936,-1.48000,
,,,-0.02046200074,-1.48000,
,,,-0.02046000026,1.54000,
,,,-0.02045799978,1.54000,

« Last Edit: April 23, 2018, 10:27:47 pm by StillTrying »
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf