Author Topic: Siglent Technical Support join in EEVblog  (Read 251111 times)

0 Members and 1 Guest are viewing this topic.

Offline echen1024

  • Super Contributor
  • ***
  • Posts: 1660
  • Country: us
  • 15 yo Future EE
Re: Siglent Technical Support join in EEVblog
« Reply #75 on: August 04, 2013, 01:07:17 pm »
However, I do have one question. Is it possible to install the LeCroy firmware on the Siglent SDS1102CNL?
I'm not saying we should kill all stupid people. I'm just saying that we should remove all product safety labels and let natural selection do its work.

http://www.youtube.com/user/echen1024
 

Offline illyesgeza

  • Contributor
  • Posts: 41
Re: Siglent Technical Support join in EEVblog
« Reply #76 on: August 04, 2013, 06:15:21 pm »
on a SDS1102CNL you can not!!!!
on a SDS1102CML I think it will work (99.99%)
but I did not tried. What I realy don't know if the buttons are at same ports.
If you try the Lecroy WaveStudio program, you will notice that all the buttons can be manipulated by remote commands, but their positions on the screen are not correct.

 

Offline Siglent

  • Regular Contributor
  • *
  • Posts: 170
  • Country: cn
  • SIGLENT
    • SIGLENT TECHNOLOGIES
Re: Siglent Technical Support join in EEVblog
« Reply #77 on: August 05, 2013, 12:33:46 pm »
Siglent fixed that "Auto" button problem. I got the new firmware and it works. However if the scope is in AC coupling mode before pressing the "Auto" button, it switches back to DC coupling therefore shifting the signal (with a DC bias) after rescaling it on the screen. May be it's just me being picky. How do other scopes behave (if they do have "Auto" type function of course)?

In the new version, made the following modifications:
AUTO perfect algorithm to enhance the speed of response, and unified the DC coupling



SIGLENT TECHNOLOGIES CO.,LTD
 

Offline Siglent

  • Regular Contributor
  • *
  • Posts: 170
  • Country: cn
  • SIGLENT
    • SIGLENT TECHNOLOGIES
Re: Siglent Technical Support join in EEVblog
« Reply #78 on: August 05, 2013, 12:38:57 pm »
More problems with SIGLENT SDS1102CML
If you get the Sampling Rate with the command SAMPLE_RATE? you'll get the right one no matter if LONGMEM is selected or not. But if you read the Sampling Rate from address 176 in the WAVDESC than in the case of LONGMEM on you'll get the half of it.
Example:TimeBase is set to 100nS and LONGMEM is on.
If you press the ACQUIRE button you can read 500.0MSa on the scope. That mean 2ns sampling time
Now if you get the trace with the command C1:WF? and read the Sampling Time in the WAVEDESC at offset 176 acordingly to the specification of SDS1000_REMOTE_CONTROL_MANUAL_1.2 you will read 4ns
There are a lot of more bugs. I am wondering why Siglent newer answer to my remarks.
But the most annoying problem is that I can't get all the 1mega data using the Command C1:WF?
I know that with easyscope program you have an option to select LONGMEM, download the data, and save it in .DAV format. unfortunately on my scope the EASYSCOPE dosen't work. I'd like to know if somebody who have a SIGLENT SDS1102CML had ever succeeded to get all the LONGMEM data.
An other problem is the STORE command.
The syntax is: STORE [<trace>, <dest>].
The <dest> parameter can be an USB stick UDSK.
As <trace> parameter you can select a channel or ALL_DISPLAYED
BUT THE MOST IMPORTANT wich is ALL that can't be!!!!!!!!!
I mean ALL as ALL THE CHANNELS.

Thanks to our attention, in order to better solve your questions, I hope you give edition models, and others  problems, thank you.
SIGLENT TECHNOLOGIES CO.,LTD
 

Offline illyesgeza

  • Contributor
  • Posts: 41
Re: Siglent Technical Support join in EEVblog
« Reply #79 on: August 06, 2013, 02:38:17 am »
If I understood, you (SIGLENT) have asked me about my DSO
This strings are inside my scope
siglent
ca_m_111000
sat7.820.6810
rz-02a
94v-0
e322892
and this is what I got in sytem utility:
Hardware version:  10-61-3.3
Software version: 5.01.02.13
Product type: SDS1102CML
You have asked me about other problems.
Yes there are a lots of.
Example:
If you use the command GCSV? DD,MAX,SAVE,ON
than the scope freeze. It must be powered off.
In case of GCSV DD,DIS,SAVE,ON everything is ok.
This problem have nothing to do with LONGMEM ON or OFF
In both cases the scope freeze.
If I use the SAVE button I can save the data acordingly to LONGMEM and DISPLAYED
ex: LONGMEM off, DataDepth Maximum -> filesize will be aprox 600Kilobytes
    LONGMEM on,  DataDepth Maximum -> filesize will be aprox 60Megabytes
    LONGMEM off, DataDepth Displayed -> filesize will be aprox 300Kilobytes
    LONGMEM on,  DataDepth Displayed -> filesize will be aprox 6.3Megabytes
So it is obvious there is a software problem wich is not related to the hardware.
I don't want to repeat me, but it would be great to solve the problem with the WaveForm realted commands
WFSU does not work
WF?   Does not work in LONGMEM ON mode.

 

Offline grego

  • Frequent Contributor
  • **
  • Posts: 330
  • Country: us
Re: Siglent Technical Support join in EEVblog
« Reply #80 on: August 07, 2013, 10:09:05 am »
Siglent support:

A question has come up about the SDG5000 series of function generators.

Is there a way to synchronize the two channels?  I can not figure out a way to have both channel 1 and 2 in phase with each other on my SDG5082.
 

Offline Zbig

  • Frequent Contributor
  • **
  • Posts: 795
  • Country: pl
Re: Siglent Technical Support join in EEVblog
« Reply #81 on: August 07, 2013, 07:10:52 pm »
Question to Siglent support:

How much longer until the 5.01.02.22 firmware for SDS1000 series shows up on the download page? Personally, I find it very frustrating knowing that the new version is out there in the wild on new units yet the download page got stuck on 5.01.02.13 for some reasons.
 

Offline Siglent

  • Regular Contributor
  • *
  • Posts: 170
  • Country: cn
  • SIGLENT
    • SIGLENT TECHNOLOGIES
Re: Siglent Technical Support join in EEVblog
« Reply #82 on: August 08, 2013, 11:40:18 am »
I
siglent
ca_m_111000
sat7.820.6810
rz-02a
94v-0
e322892
and this is what I got in sytem utility:
Hardware version:  10-61-3.3
Software version: 5.01.02.13
Product type: SDS1102CML
You have asked me about other problems.

Example:
If you use the command GCSV? DD,MAX,SAVE,ON
than the scope freeze. It must be powered off.
In case of GCSV DD,DIS,SAVE,ON everything is ok.

......

Thank you for your attention on these issues, we have to submit questions processes, and in the next version update
« Last Edit: August 08, 2013, 11:42:24 am by Siglent »
SIGLENT TECHNOLOGIES CO.,LTD
 

Offline Siglent

  • Regular Contributor
  • *
  • Posts: 170
  • Country: cn
  • SIGLENT
    • SIGLENT TECHNOLOGIES
Re: Siglent Technical Support join in EEVblog
« Reply #83 on: August 08, 2013, 11:45:46 am »
I
Example:
If you use the command GCSV? DD,MAX,SAVE,ON
than the scope freeze. It must be powered off.
In case of GCSV DD,DIS,SAVE,ON everything is ok.

......

Thank illyesgeza attention on these issues, we have to submit questions processes, and in the next version update
SIGLENT TECHNOLOGIES CO.,LTD
 

Offline David Aurora

  • Regular Contributor
  • *
  • Posts: 153
  • Country: au
Re: Siglent Technical Support join in EEVblog
« Reply #84 on: August 08, 2013, 12:54:31 pm »
Question to Siglent support:

How much longer until the 5.01.02.22 firmware for SDS1000 series shows up on the download page? Personally, I find it very frustrating knowing that the new version is out there in the wild on new units yet the download page got stuck on 5.01.02.13 for some reasons.

Yeah, I'd definitely like to know what's happening with this too
 

Offline illyesgeza

  • Contributor
  • Posts: 41
Re: Siglent Technical Support join in EEVblog
« Reply #85 on: August 08, 2013, 11:00:57 pm »
Anomalies on Siglent SDS1102CML.
Here are some screenshots
The ETS bugs don't bother me.
BUT !!! the realtime problems YES!!! (SDS0003.JPG, SDS00004.JPG)
When you get the trace with C1:WF? command you got the wrong sampling rate
because in that moment the acquisition is stoped. Just like in this example
As I said in an earlier post you get the half of the sampling rate
 

Offline illyesgeza

  • Contributor
  • Posts: 41
Re: Siglent Technical Support join in EEVblog
« Reply #86 on: August 09, 2013, 07:08:52 pm »
Can anybody help me to make a test on a SIGLENT SDS1102CML?
Select both chanels. select LONGMEM. Select Trigger EDGE,SLOPE+,NORMAL,source CH1.
When you have a stable image make a screenshot.
Then push the STOP button and make an other screenshot.
I'd like to know if both traces remain in the same position as in RUN mode.
There is not the generator's error. In LONGMEM OFF mode everything is OK.
Thanks.
 

Offline illyesgeza

  • Contributor
  • Posts: 41
Re: Siglent Technical Support join in EEVblog
« Reply #87 on: August 09, 2013, 07:20:38 pm »
There is no difference between the hardware. So the problem is in the software
 

Offline illyesgeza

  • Contributor
  • Posts: 41
Re: Siglent Technical Support join in EEVblog
« Reply #88 on: August 09, 2013, 07:25:26 pm »
I'd like to ask SIGLENT why is possible to make an one shot acquisition on 20480 samples, and why not on 1mega samples.
If it's a realtime sampling mode, there must not be related to the number of samples. So simple.
 

Offline illyesgeza

  • Contributor
  • Posts: 41
Re: Siglent Technical Support join in EEVblog
« Reply #89 on: August 09, 2013, 07:41:03 pm »
Question for SIGLENT.
If the hardware can not make a continuous acquisition on 1 mega samples after a SINGLE!!! stable trigger, in that case there is no need for LONGMEM.
I can not figure out what kind of REALTIME  acquisition metod is used to have such a limitation.
This limitation is also on ATTEN and LECROY.
 

Offline echen1024

  • Super Contributor
  • ***
  • Posts: 1660
  • Country: us
  • 15 yo Future EE
Re: Siglent Technical Support join in EEVblog
« Reply #90 on: August 10, 2013, 01:25:30 am »
Please, stop spamming this thread. Honestly, that firmware is not under the Siglent name, so I think you should talk to Atten, or whoever made your scope for support.
I'm not saying we should kill all stupid people. I'm just saying that we should remove all product safety labels and let natural selection do its work.

http://www.youtube.com/user/echen1024
 

Offline illyesgeza

  • Contributor
  • Posts: 41
Re: Siglent Technical Support join in EEVblog
« Reply #91 on: August 10, 2013, 03:07:14 am »
Sorry sire if I bother you but that firmware is signed by SIGLENT and is used on a SIGLENT made hardware.
I don't know why you consider that I am spamming. I just pointed some problems. I am sure about that those problems are on all CML models.
Apology if I made you angry.
 

Offline echen1024

  • Super Contributor
  • ***
  • Posts: 1660
  • Country: us
  • 15 yo Future EE
Re: Siglent Technical Support join in EEVblog
« Reply #92 on: August 10, 2013, 06:04:46 am »
Sorry sire if I bother you but that firmware is signed by SIGLENT and is used on a SIGLENT made hardware.
I don't know why you consider that I am spamming. I just pointed some problems. I am sure about that those problems are on all CML models.
Apology if I made you angry.

Really? Huh. I will try and recreate these issues on the CNL, since I can only get max 20k points mem, when I am promised 40k.
I'm not saying we should kill all stupid people. I'm just saying that we should remove all product safety labels and let natural selection do its work.

http://www.youtube.com/user/echen1024
 

Offline illyesgeza

  • Contributor
  • Posts: 41
Re: Siglent Technical Support join in EEVblog
« Reply #93 on: August 10, 2013, 04:53:08 pm »
you can get 40k only for one trace when the sample rate is 1G
 

Offline echen1024

  • Super Contributor
  • ***
  • Posts: 1660
  • Country: us
  • 15 yo Future EE
Re: Siglent Technical Support join in EEVblog
« Reply #94 on: August 11, 2013, 01:32:40 am »
you can get 40k only for one trace when the sample rate is 1G

I've played around with the sample rate, and only have had 1 channel turned on. The same old 20k.
I'm not saying we should kill all stupid people. I'm just saying that we should remove all product safety labels and let natural selection do its work.

http://www.youtube.com/user/echen1024
 

Offline rf-loop

  • Super Contributor
  • ***
  • Posts: 2797
  • Country: fi
  • Starting with DLL21
Re: Siglent Technical Support join in EEVblog
« Reply #95 on: August 11, 2013, 06:01:38 am »
you can get 40k only for one trace when the sample rate is 1G

I've played around with the sample rate, and only have had 1 channel turned on. The same old 20k.

Under 1GSa/s normal memory is 20k for each channels independent if 1 or 2 channels in use.
1GSa/s normal memory is 40k. (1GSa/s available only if one channel in use and normal memory and timebase is 50ns/div or faster.

(In theory of operation, there is 2 x 500MHz ADC* and after both there is 20k sample buffer what can take full 500MSa/s.  When scope use 1GSa/s these two ADC are interleaved, and so also these two 20k sample are interleaved. In end when read this sampling buffers  alternately there is 1GSa/s data and 40k data points.

*made  using several interleaved 100MHz running ADC's)


Here CSV start with 1 channel in use and 1GSa/s (50ns/div)  and second is 1 channel in use and 500MSa/s (100ns/div)

CSV really have this amount of data points what it tell record lenght.

NOTE: In save menu there need select of course "Data Depth" = "Maximum"
(other selection is "Displayed")

And if want parameters "ParaSave" = On

Also if stop capture there is same 20k or 40k in sample buffer and visible.

Here start from both stored CSV
opened just normally with OpenOffice Calc (only mod is serial number hide)
« Last Edit: August 11, 2013, 06:22:47 am by rf-loop »
If practice and theory is not equal it tells that used application of theory  is wrong or the theory itself is wrong.
It is much easier to think an apple fall to the ground than to think that the earth and the apple will begin to move toward each other and collide.
 

Offline Smoking

  • Contributor
  • Posts: 27
  • Country: nl
    • ATTEN.EU
Re: Siglent Technical Support join in EEVblog
« Reply #96 on: August 12, 2013, 08:52:11 pm »
It looks like it's from the same guy who also does atten.eu
No official Siglent factory website !
Indeed, both sites are operated by JR Special Electronics. KVK nr: 52793575 Rivierensingel 325 5704KN Helmond The Netherlands
They put alot of effort into pretending to be official manufacturer websites...  :--

Hi all,

Let make something clear  :)

Yes I do have multiple web-shops Like ATTEN.EU Siglent.eu and more.
These web-shops are run independently from the Chinese cooperation's BUT this doesn't mean we do not communicate.
The websites are made to have a better support and promotion in the EU with these products.
The assumption that we are non official is wrong. Siglent.eu is a official reseller like many other resellers.

I do not think it is very nice to make a assumption that we are pretending!
If you do not know how things are set up please do some research first.

Please feel free to contact me if you have any questions.

Greetings,
Jonas Rijnders
 

Offline illyesgeza

  • Contributor
  • Posts: 41
Re: Siglent Technical Support join in EEVblog
« Reply #97 on: August 12, 2013, 11:40:28 pm »
As you see I have many remarks and questions.
Plese be more specific. How we can contact you. Here? Or by e-mail ?
 

Offline Bored@Work

  • Super Contributor
  • ***
  • Posts: 3932
  • Country: 00
Re: Siglent Technical Support join in EEVblog
« Reply #98 on: August 13, 2013, 04:41:51 am »
I do not think it is very nice to make a assumption that we are pretending!

Actually, it is not very nice that you pretend with your websites that you are Atten/Siglent. Which you aren't. You are just a reseller.
I delete PMs unread. If you have something to say, say it in public.
For all else: Profile->[Modify Profile]Buddies/Ignore List->Edit Ignore List
 

Offline ChrisShillito

  • Newbie
  • Posts: 4
  • Country: gb
Re: Siglent Technical Support join in EEVblog
« Reply #99 on: August 16, 2013, 01:25:42 am »
I have a Siglent SDS1102CM oscilloscope but it has suddenly stopped working and now only ever displays its splash screen - anyone else ever seen this?

When I turn on the scope the buttons light up as usual and the fan runs. The splash screen appears and the buttons lights go out (except measure, run/stop, CH1 and CH2 lights on) but that's as far as it gets - the splash screen just stays there and pressing the buttons doesn't do anything. The scope first entered this mode when I pressed the horizontal time scale zoom button.

Anybody (SIGLENT?) know of a back door way to force a 'restore to factory defaults'  - perhaps powering up with certain buttons pressed etc?

Chris.

[Edit] Just noted Andor's post from earlier in this thread where he reports the same thing. Andor, if you read this could you confirm that you managed to get your scope out of this lockup? And could you explain/confirm the steps I need to take. Cheers.
« Last Edit: August 16, 2013, 01:48:25 am by ChrisShillito »
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf