Author Topic: Any resin gurus out there that can point me in the right direction. Bad prints.  (Read 1093 times)

0 Members and 1 Guest are viewing this topic.

Offline magnetchief

  • Contributor
  • Posts: 26
  • Country: us
Hi, I have a Photon Mono X printer that I just can't get to work correctly.
Attached are a couple of photos showing my issue.
The print is not detaching from the screen.

I have tried running through the set up a few times all with similar results.

Also attached a photo of identical prints on my Form 3. These work perfectly, but of course at a much higher cost.

The Mono X was purchased to make quick prototypes but it's just not working out.

Any advice greatly appreciated.

 

Offline Mechatrommer

  • Super Contributor
  • ***
  • Posts: 10805
  • Country: my
  • reassessing directives...
1) maybe uv light is not powerful enough you need to increase exposure time by a bit?
2) maybe the bed is too sticky rubbing a thin layer of grease or some oily thing on it before print may help?
Nature: Evolution and the Illusion of Randomness (Stephen L. Talbott): Its now indisputable that... organisms “expertise” contextualizes its genome, and its nonsense to say that these powers are under the control of the genome being contextualized - Barbara McClintock
 
The following users thanked this post: magnetchief

Offline magnetchief

  • Contributor
  • Posts: 26
  • Country: us
Many thanks, will look into that
 

Online eliocor

  • Supporter
  • ****
  • Posts: 477
  • Country: it
    • rhodiatoce
too low exposure...
Use UVtools and follow the hints in this video:

 
« Last Edit: June 22, 2022, 08:37:59 pm by eliocor »
 
The following users thanked this post: magnetchief

Offline magnetchief

  • Contributor
  • Posts: 26
  • Country: us
Thanks, that’s an interesting link.
I’ll play around with the UVtest as per the video and try again.
 

Online lugaw

  • Contributor
  • Posts: 25
  • Country: jp
Your FEP film is probably low grade, it shouldn't stick to the film.
 
The following users thanked this post: magnetchief

Offline magnetchief

  • Contributor
  • Posts: 26
  • Country: us
FEP film now replaced.
I agree the one that came with the printer was pretty poor quality.
 

Offline amwales

  • Regular Contributor
  • *
  • Posts: 66
  • Country: gb
I'm curious, did replacing the FEP fix it?
 

Offline magnetchief

  • Contributor
  • Posts: 26
  • Country: us
Well I experimented with UVtest and with that and the replacement FEP film I'm up and running.
Now recent issues, I can pretty much have the confidence to print as needed without issues.

 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf