Author Topic: Altium Issue: Components are flipped when imported to PCB.  (Read 2915 times)

0 Members and 1 Guest are viewing this topic.

Offline bkish

  • Contributor
  • Posts: 5
  • Country: us
Altium Issue: Components are flipped when imported to PCB.
« on: September 10, 2015, 10:46:28 pm »
I have come across an issue when importing my schematic design into the PCB design. I sometimes will flip the board inside of the PCB editor, to get a better idea of how components are laid out. If I have the board flipped in the PCB editor, (Using View > Flip Board) and forget that the board is flipped, when I go to (Design > Import Changes from Name.prjpcb) then the footprints for the components actually import Flipped.

What I mean by this is that while the silkscreen is on one side of the board, the 3D model of the part actually goes through the board, and pokes out the other side, as if the footprint was oriented "Upside down". Or another way to think of it, is instead of the part pointing away from the board, it points inward to the board. It is almost if you were to lay a part flat on the table, then completely flip it over, so now the part is going through the table/board.

This is something that is not immediately noticeable unless you are looking for it, and in 3D view as some parts have identical footprints, but the pins function will change. It has huge adverse effects with the pin layout of the board, as all of the pins will be incorrect for the part. Often times I will layout parts of the board just the way I want them, just to find out that the pad is actually flipped, then I have to re-do all of the work because the pin functions are flip-flopped.

I was wondering if anyone else experienced this problem or if there is a solution for this.
« Last Edit: September 10, 2015, 10:50:05 pm by bkish »
 

Offline DutchGert

  • Frequent Contributor
  • **
  • Posts: 257
  • Country: nl
Re: Altium Issue: Components are flipped when imported to PCB.
« Reply #1 on: October 31, 2015, 03:29:51 pm »
I noticed something similar: sometimes when I Import from schematic it places the components itself on the top layer (correct) but the silkscreen text mirrores on the bottom.... Wtf
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf