Author Topic: Altium Designer 20 crashes if I try to rout inner layer  (Read 425 times)

0 Members and 2 Guests are viewing this topic.

Offline soFPG

  • Regular Contributor
  • *
  • Posts: 132
  • Country: de
Altium Designer 20 crashes if I try to rout inner layer
« on: November 30, 2019, 08:47:25 pm »
For the first time now I am creating a 4-layer board.
So what I did: I added two more layers in the Layer Stack Manager together with a dielectric inbetween.

I am using one of the inner layers for a ground plane. So I placed my polygon, re-poured everything but I noticed, that the polygon didn't get filled!

Then I tried to route a pin of a pin-header (which of course goes through all layers) from this ground layer and Altium just crashes.

Do you have any explanation for this? Routing and pouring on top layer works fine.

Maybe I just don't know how to use the layer manager
« Last Edit: November 30, 2019, 08:49:21 pm by soFPG »
 

Offline T3sl4co1l

  • Super Contributor
  • ***
  • Posts: 14072
  • Country: us
  • Expert, Analog Electronics, PCB Layout, EMC
    • Seven Transistor Labs
Re: Altium Designer 20 crashes if I try to rout inner layer
« Reply #1 on: December 01, 2019, 12:33:08 am »
Did you check Design Rules, namely routing layers and such?

20 is new, unclear if the crash is due to what you've done, or something they botched.

Tim
Seven Transistor Labs, LLC
Electronic design, from concept to prototype.
Bringing a project to life?  Send me a message!
 

Offline thm_w

  • Super Contributor
  • ***
  • Posts: 1578
  • Country: ca
Re: Altium Designer 20 crashes if I try to rout inner layer
« Reply #2 on: December 02, 2019, 09:54:34 pm »
The red exclamation mark on the left seems to hint something is wrong?
I would open up one of their demo projects with 4+ layers, try to route the inner layer, and see if it works there.

https://www.altium.com/documentation/altium-designer/defining-the-layer-stack-ad

edit: the middle layer should be "core" but I can't see why that would matter for routing.
« Last Edit: December 02, 2019, 09:57:18 pm by thm_w »
 

Offline VK3DRB

  • Super Contributor
  • ***
  • Posts: 1554
  • Country: au
Re: Altium Designer 20 crashes if I try to rout inner layer
« Reply #3 on: December 03, 2019, 10:57:21 am »
Does it do this in Altium 19? Altium 20 is in beta phase, so use at your own risk. Even soon after it is released, there is elevated risk for a while.

You did not state how Altium crashes. If it shows a small screen with memory violation errors, it is an Altium problem. If Altium hangs, it is an Altium problem. If Altium just disappears off screen, it is an Altium problem.
 

Offline ajb

  • Super Contributor
  • ***
  • Posts: 1687
  • Country: us
Re: Altium Designer 20 crashes if I try to rout inner layer
« Reply #4 on: Yesterday at 06:02:57 pm »
I use signal layers for inner layers on 4-layer boards all the time in AD19 with no trouble.  If you try any altium examples, I expect that they will have the inner layers defined as planes which you van't route on, so those may or may not be helpful.  It looks like you have solder mask defined for the inner layers but not the outer layers, which may or may not be what's triggering the bug?
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf