EDA > Altium Designer

Altium DRC doesn't seem to catch via-to-metal spacing issues

(1/2) > >>

TheUnnamedNewbie:
So, I have a pcb with only blind microvias. The metals on different layers have different thicknesses and as a result each of my micro-vias and metals has different pitch/diameter/spacing.

I 'fixed' this by having a separate clearance rule for each layer. The rule would be something like 'Where first object matches InLayer('M1') and second object matches InLayer('M1')' . This seems to work fine for 99% of my design - but it doest seem to catch a lot of via annular ring clearance issues. Even though my DRC is clean in altium, the manufacturer says there are a lot of DRC errors still remaining. EG the via below, which is too close to the metals on the left and right, clearly violates the DRC rules, yet the DRC results are clean for that metal layer.

[attachimg=1]

[attachimg=2]

thinkfat:
Rule might not trigger because the via and the second object are on the same net? Is there a 'same net' constraint you could use or formulate a manufacturing constraint and not an electrical rule?

TheUnnamedNewbie:
The via and surrounding copper is not the same net here, so that is not the issue

voltsandjolts:
This is the age old game where the OP provides a bare minimum of information and then everyone else submits their guesses as to the problem.

How about providing a minimal PCBdoc that shows the problem?

evb149:
Check the altium designer forum there are several posts in the past year or so that deal with DRC rules and vias and clearances.

One thing comes to mind is that I wonder if:
InLayer('M1')

applies to your via pads.  Obviously a blind microvia may have a pad only on one layer but a regular pad or through via might be categorized as
something else...InLayer('MultiLayer') or whatever the syntax is?

A quick search on that forum  for instance reveals a message which is one of several that might be relevant:

[quote user=altiumforum]
John,
   Just seeing your one clearance rule and making assumptions from that.

   You're falling into the unusual pit that befalls a fair number of less experienced AD designers when writing rules for specific clearances on specific layers.
The clearance between your via and the trace on that layer is not being checked by the specified clearance rule because the via is on the Multilayer, not on the individual internal signal layers like you have defined in your clearance rule.

I haven't actually used or tested the query modification suggested by Tim Phillips in the following thread but I believe it is the solution to your clearance rule problem.

Clearance Rule Does not work with OnLayer Query - Altium Discussion Forums
https://forum.live.altium.com/#posts/236566/720255
[/quote]

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version