EEVblog Electronics Community Forum

Electronics => PCB/EDA/CAD => Altium Designer => Topic started by: ajawamnet on June 18, 2022, 11:57:11 pm

Title: Altium has got to stop mucking around with stuff
Post by: ajawamnet on June 18, 2022, 11:57:11 pm
They keep hosing stuff.   In 22.5.1, they messed up the ability to use a right click edit in the Components panel unless you were signed into their cloud (Clown) .  I bitched about it on the forum, but - cause they hate me - it took another user to post the same issue.  Now in 22.6.1 they trashed the ability to even create a new Library unless signed in. 

They gotta stop this.  At least test for us guys that need to be ITAR (which is a considerable market for them) and can't use the "Clown"

Title: Re: Altium has got to stop mucking around with stuff
Post by: ajawamnet on June 19, 2022, 12:52:44 am
From my post on the forum:

 Post ID: 797277
I was on the phone with another user and he had no problem getting the new Library Dialog to pop up.  But I was still having issue with the Fresh Install as well as the non-networked installations (the ones we really use).   So while I was on the phone, I signed in to Altium using the fresh install - but DID NOT connect to any 365 workspace.  It worked.  Then I signed back out and closed it out.  Reopened the fresh install and again it hung.  So Task killed it and reopened it.  I then signed in again - and again, not to any 365 workspace. It popped up the newfangled library dialog.  So i signed back out, closed Altium.  BUT this time when I reopened Altium AND DID NOT sign in I DID get the pop up library thing.  Tried again, closed out Altium, reopened Altium, did the the File - New - Library... and AGAIN I got the new dialog.   So now I'm wondering WTF?. 

So I uninstall that fresh install.  Totally.   I then re-install another fresh install to a totally different location. Open up this new, fresh install - No Prefs -  just my ALF file.  I close back out

Guess what?  I reopen - DON'T SIGN IN - and now this new install hangs/crashes on doing the File - New - Library...   Try again - same thing.

This is nutz...

Software totally hose the old adage that doing the same thing over and over again and expecting different results is insane.
Nope - just buggy software...