Electronics > Altium Designer

Altium questions

<< < (21/21)

Sounds like you aren’t actually making the correction you think you’re making. I’ve seen this before, read on:

1. Make sure which rule is actually being violated. You may have unused pins on a component on the schematic, and a rule disallowing this. Place a “generic no ERC” flag (the red x) onto pins which deliberately don’t connect to anything.
2. Make sure the snap settings are correct, and that you’re in the correct layer, so that it’s definitely snapping to the pad center.
3. Make sure that you’re actually looking at the right object! It is possible to end up with little “corpses” (as I like to call them) of traces (or other copper objects) that are hiding out under a pad, so you move a trace, but it’s not actually the offending piece! A few ways to spot these lil zombies:
- use the DRC report to cross-select the offending object
- select the pad
- in the selection filter, turn off everything except traces, arcs, fills, and regions, then do a blue-rectangle select (drag selection rectangle from left to right, which only selects items totally enclosed by the selection rectangle) to enclose the suspect pad area. Delete whatever gets selected.
- hide layers that are obscuring view of the pad area.
- use transparency and/or draft mode settings in View Configuration > View Options to hide or make transparent object types that are obscuring the view

There’s also a really obscure situation involving “free” copper on footprints: before Altium added bona fide custom pad shapes, the way to do them was to draw a fill, then place an ordinary pad onto it. For example, for a weird SMD pad, you’d draw the weird shape as the fill, then place a tiny little no-hole pad on the same layer, right in the middle of the weird shape. When you place and route the component, it’ll assign the weird fill shape the same net as the pad. However, it is possible to inadvertently change this, for example if you cut and paste the component (which, unless you use a Smart  Paste function, removes all net assignments) and the paste location creates net ambiguity, for example if there are more than one vias or traces there. It may ask which one you want to connect, and if you don’t, the weird shape and the actual pad get out of sync. This can lead to unrouted net errors and/or shorted net errors. There’s a menu command that fixes this:  Design>Netlist>Update Free Primitives From Component Pads

Altium won't name net to GND in schem:
Hi, Done many boards in Altium no prob...but today, for some reason, Altium wont let me name a net to GND.
It just says "net name N/A, Physical name N/A"
Do you know why not?
Even adding a bar with a net name  name and connecting it  to a net wont name the net to that name.
I think its a bug.?..never seen this before and have done loads of boards in Altium.

I am trying to name nets now with the "bar" thing..sometimes it lets me, sometimes not.

A screenshot might explain the issue many, many times more succinctly than how you've tried to describe it.

Thanks......rebooting solved it

Showing all ratsnests when moving a component in PCB
Hi, It was showing them at first, btu then suddenly stopped...anyone know how to get the ratsnests back?....they inconveniently now mostly all disappear when i drag a component....but i want to see them all, all the time....even whilst dragging.

Read this https://www.altium.com/documentation/altium-designer/understanding-connectivity-pcb

"Hiding/Displaying Connection Lines" is the section you want.


[0] Message Index

[*] Previous page

There was an error while thanking
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod