Author Topic: Improper import of schematic symbol or footprint from Ultra Librarian  (Read 2398 times)

0 Members and 1 Guest are viewing this topic.

Offline logancane

  • Regular Contributor
  • *
  • Posts: 50
  • Country: nz
Hi everyone,

I'm just wondering if anyone else comes across the same problem that I do on a very regular basis.

So what I'll do is

1. Download a symbol and footprint package from Ultra Librarian for Altium
2. Extract the contents of the zip folder into their own folder,
3. Go into Altium and run the script,
4. Select the text file and press import
5. Get a message saying something about this version does not support some kind of text standard (I get this every time whether or not it works so I don't think this is relevent)
6. Go to my schematic and add component
7. Usually the library is already open so I go to select my symbol so that I can use it in my schematic.

But over half of the time when I do this, the schematic symbol hasn't loaded. Instead there is an empty schematic symbol called compoent. Then I'll go into the components .Schlib file and it is empty. Sometimes the .Pcblib file suffers the same fate. (I always double check to make sure that both are supposed to be supplied)

The weird thing is that 9/10 times if I repeat the exact same process, it works  :-//

Because of that it is only a mild annoyance but it's happened enough times to me that I want to know why. I did some googling but nothing came up.

Has this ever happened to you?
 

Offline AJbotic

  • Newbie
  • Posts: 3
  • Country: us
Re: Improper import of schematic symbol or footprint from Ultra Librarian
« Reply #1 on: January 20, 2022, 01:32:28 am »
Yes, this happens to me on a regular basis.  Next time, instead of reimporting.  Close the empty schlib or pcblib, then simply reopen them.  This has worked for me every time.  I think the files show up in the project panel before they are finished loading, then we double click them too early too.  This is just my guess.
 

Online free_electron

  • Super Contributor
  • ***
  • Posts: 8409
  • Country: us
    • SiliconValleyGarage
Re: Improper import of schematic symbol or footprint from Ultra Librarian
« Reply #2 on: January 20, 2022, 06:53:29 pm »
Your big issue is item 1. using ultralibrarian , snapeda or samasys for anything.

Those parts are full of mistakes .
[attach=1]
seriously ? who makes opamp symbols like that ? this needs to be a 3-part split. what is this ? arduino style schematics ?

[attach=2]
They are not even trying. this should be arranged properly. inputs left, outputs right , power top , ground bottom. and logically sequenced.

[attach=3]
This is a disaster of a footprint. the corner pads are too close. all pads are too long , there is silkscreen over copper , the soldermask is too narrow and none of the pads use rounded corners. there is no via farm or windowpane design on the thermal pad.

[attach=4]
Molex drawing

[attach=5]
Their implementation. The anchoring pads orientation is wrong , the pin order is wring and pin 1 sits in the wrong corner ! The symbol is not representative of the actual part and the anchoring pads are not called out. And where is the 3D model ? Molex website has it ... why is it not in there ?

There is a very descriptive terminology for this kind of stuff: sheite.
Professional Electron Wrangler.
Any comments, or points of view expressed, are my own and not endorsed , induced or compensated by my employer(s).
 

Offline AJbotic

  • Newbie
  • Posts: 3
  • Country: us
Re: Improper import of schematic symbol or footprint from Ultra Librarian
« Reply #3 on: January 24, 2022, 11:27:29 pm »
@free_electron is accurate concerning trustworthiness for all those resources.  I've used them all and I've been burned by them all.  I don't recommend ignoring them completely though either.  Instead I've adjusted my workflow to take what's useful and leave the rest behind.  Instead of blindly adding these components to my library, I'll only add the features I want, layer by layer to ensure what I bring in matches my convention, my library layer stack, and the component datasheet.  This is (for me) a happy medium WRT time optimization between the two extremes of blind trust in ulltralib/snapeda/samacsys vs. building every component from scratch using the component mechanical drawings and other resources.
 

Online free_electron

  • Super Contributor
  • ***
  • Posts: 8409
  • Country: us
    • SiliconValleyGarage
Re: Improper import of schematic symbol or footprint from Ultra Librarian
« Reply #4 on: January 25, 2022, 12:46:38 am »
TRY THE CELESTIAL ALTIUM LIBRARY
Professional Electron Wrangler.
Any comments, or points of view expressed, are my own and not endorsed , induced or compensated by my employer(s).
 
The following users thanked this post: thm_w, AJbotic


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf