Author Topic: Altium slows down when dragging some components.  (Read 963 times)

0 Members and 1 Guest are viewing this topic.

Offline palpurul

  • Regular Contributor
  • *
  • Posts: 166
  • Country: tr
  • Hey
Altium slows down when dragging some components.
« on: July 01, 2022, 08:43:29 pm »
Hello,
I've just received a PCB layout job from one of my customers. It's a flex PCB design with about 600 components.

The problem is that when I try to move some components (99% of them) Altium behaves very sluggish.

Let me show you this in a video:
https://streamable.com/wc34b5

The component on the right (1 pin header) doesn't cause any problem when dragging, it's from the default Altium library (miscellaneous_connector.Intlib I think). The component on the left (diode) is generated by the customer it's from their library and whenever I try to pick one up and move it, Altium slows down terribly.

Thanks in advance!
What would be the cause of that, how can I fix it?
 

Offline thm_w

  • Super Contributor
  • ***
  • Posts: 4446
  • Country: ca
  • Non-expert
Re: Altium slows down when dragging some components.
« Reply #1 on: July 04, 2022, 10:25:19 pm »
D1 has a 3D body while TP7 has none. So its doing additional 3D clearance violation checks when you are moving D1. Still normally it would never be that slow.

What version is this? Do you have another version installed you can try on.
What are system specs?

If necessary you can turn off on-line DRC, but, that shouldn't be required unless its a very old system.
Profile -> Modify profile -> Look and Layout ->  Don't show users' signatures
 
The following users thanked this post: palpurul

Offline palpurul

  • Regular Contributor
  • *
  • Posts: 166
  • Country: tr
  • Hey
Re: Altium slows down when dragging some components.
« Reply #2 on: July 05, 2022, 05:45:07 am »
Actually I tried this on many PCs. There is some kind of a problem with the project I assume.

When I try the version 17 it works great, but later versions it always sluggish.
 

Offline Batang

  • Contributor
  • Posts: 49
  • Country: my
Re: Altium slows down when dragging some components.
« Reply #3 on: July 05, 2022, 06:29:05 am »
I have seen this before and it always turned out to be a library problem.
 
The following users thanked this post: palpurul

Offline palpurul

  • Regular Contributor
  • *
  • Posts: 166
  • Country: tr
  • Hey
Re: Altium slows down when dragging some components.
« Reply #4 on: July 05, 2022, 06:46:56 am »
I have seen this before and it always turned out to be a library problem.

THat's what I was thinking as well. Have you ever solved it?
 

Offline thm_w

  • Super Contributor
  • ***
  • Posts: 4446
  • Country: ca
  • Non-expert
Re: Altium slows down when dragging some components.
« Reply #5 on: July 05, 2022, 09:28:28 pm »
I have seen this before and it always turned out to be a library problem.

Library problem, as in, the entire library is corrupted? Or as in, an issue present in all footprints?

Maybe you could unlock primitives, delete the 3D body, see if that does anything.
Or copy the footprint to an empty library and load it from there.

https://www.altium.com/documentation/knowledge-base/altium-designer/slowness-in-specific-areas
Profile -> Modify profile -> Look and Layout ->  Don't show users' signatures
 

Offline Doctorandus_P

  • Super Contributor
  • ***
  • Posts: 2382
  • Country: nl
Re: Altium slows down when dragging some components.
« Reply #6 on: July 06, 2022, 06:51:04 am »
I have seen this before and it always turned out to be a library problem.

It may have something to do with a library, but if you pay Mega $$ each year for some software, then I would at least expect it to be robust enough to not get brought down on it's knees by some library issue like that. So I say it primarily is a bug in the software that manifests itself when there is some library issue.

This also means I would let their customer service handle it. Maybe make a bug report.
« Last Edit: July 06, 2022, 06:59:04 am by Doctorandus_P »
 

Offline ajawamnet

  • Regular Contributor
  • *
  • Posts: 62
  • Country: 00
    • Porfolio
Re: Altium slows down when dragging some components.
« Reply #7 on: July 08, 2022, 06:52:09 pm »
I would shut off the online DRC first.  Is it possible to share that PCBDOC?


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf

 



Advertise on the EEVblog Forum