EEVblog Electronics Community Forum

EDA => Altium Designer => Topic started by: geo_leeman on April 29, 2014, 08:54:57 pm

Title: Printing 1:1 PCB in Altium
Post by: geo_leeman on April 29, 2014, 08:54:57 pm
Hello all,

This has had me banging my head for an hour now! I see multiple internet tutorials on printing a PCB at 1:1 scale.  I follow their lead exactly and get my PCB at 1:1, but distributed over 10 pages! I've tried every printer option and page setup I can think of.  Any ideas? This is only a 4.3x3" board.  Screenshot attached.  It looks like the printable region is just a fraction of the 8.5x11"page!  I'm sure it is something stupid, but I can't seem to find it.   |O |O

Thank you,

John
Title: Re: Printing 1:1 PCB in Altium
Post by: Kean on April 30, 2014, 06:36:23 am
I had a bit of trouble working this out the first time too, as you can't seem to get useful results using the PCB Print under Documentation Outputs.  A bit of googling found the answer, but I can't remember where.

1) Create a new Fabrication Output of type Final Artwork Print in your Output Job
2) In the Print Properties, add/remove the Printout and Layer settings you want
3) In Page Setup, set Scale Mode to Scaled Print, with Scale of 1.00
Title: Re: Printing 1:1 PCB in Altium
Post by: Psi on April 30, 2014, 07:13:11 am
Make sure you setup which layer, if any, should be mirrored for printing (depending on your intended use)

ie, if making a home PCB with toner transfer the TOP layer has to be mirrored because by default you're looking at the backside of it from a toner transfer perspective.

It's easy to forget, or think that the bottom layer should be mirrored. Then you end up with a PCB you can't use.

Title: Re: Printing 1:1 PCB in Altium
Post by: Kean on April 30, 2014, 07:17:19 am
Good point Psi.  I rarely use toner transfer, as I prefer to CNC prototypes, or just get a small run made commercially.
I usually do these 1:1 prints to confirm new footprints match the parts before ordering PCBs.
Title: Re: Printing 1:1 PCB in Altium
Post by: NANDBlog on April 30, 2014, 01:06:54 pm
Good point Psi.  I rarely use toner transfer, as I prefer to CNC prototypes, or just get a small run made commercially.
I usually do these 1:1 prints to confirm new footprints match the parts before ordering PCBs.
Very wise thing to do! It is distributed because you have stuff on one or more of the layers. If you have one tiny point on some hidden mechanical layer somewhere, it will print it.
The other issue, is that probably the PCB is not placed on the bottob left corner of the workspace. I never really understood why but some people start their design in the wast emptiness. Move it to around 100mmx100mm and try it again.
Title: Re: Printing 1:1 PCB in Altium
Post by: geo_leeman on April 30, 2014, 01:44:56 pm
Hmm.. well I am closer, but still no joy. I have checked and when scrolled all the way to the bottom left of the workspace, I'm in about 25mm and up about 50 for my board origin.  I followed the advice to make a fabrication output and set the scale to 1:1.  In the preferences I unchecked everything except the top layer for simplicity.  I still get 26 pages.    :palm: The first two look like what I'm looking for.  I'm pretty new to Altium, but have done 2 small boards before without such headache.  (This board again is about 4.3"x3")

Any ideas?

Thank you!
Title: Re: Printing 1:1 PCB in Altium
Post by: NANDBlog on April 30, 2014, 01:54:11 pm
I still think you have something outside your board area. Just turn on all used layers ( L ) and then select everything there. Like press the mouse and scroll to eternity and press delete. Or jump to the PCB list ( V W P L ) and see if you find anything which is far away from origo.
Title: Re: Printing 1:1 PCB in Altium
Post by: Kean on April 30, 2014, 02:34:54 pm
Here's a couple of screen shots of how I have mine set up to get two pages (top & bottom) in colour with silkscreen & mech outline.
Origin shouldn't matter, but I do find it annoying you can't actually use an origin of 0,0 in practice.
You do have an option to select Area to Print (rather than Entire Sheet), which would possibly get around the possible issue NANDBlog refers to.
Title: Re: Printing 1:1 PCB in Altium
Post by: geo_leeman on April 30, 2014, 06:04:08 pm
Kean:

I setup my print options exactly like those you showed.  The board is still split across two pages (so 4 total since we are doing 2 print outputs for the top/bottom). 

NANDBlog:

I checked via both suggestions that you made and still couldn't find anything.  I've attached a screenshot showing me zoomed very far out with all things selected.  The PCB list window didn't have any suspects either.

Notice that I specified a board area (much smaller than the page) as well.

Thank you for your patience and help! We're close!
Title: Re: Printing 1:1 PCB in Altium
Post by: NANDBlog on April 30, 2014, 06:45:50 pm
Ha ha! Set your page siye to A4 or whatever yankee paper you have in your printer.
Title: Re: Printing 1:1 PCB in Altium
Post by: geo_leeman on April 30, 2014, 06:48:05 pm
Same result on A4 or even 12x18"
Title: Re: Printing 1:1 PCB in Altium
Post by: free_electron on April 30, 2014, 07:00:22 pm
do a zoom-all operation. Z-A
if you get a mostly empty screen with a tiny board you got a problem with an object somewhere
if you get to see your board fullscreen then that is not your problem.

an object somewhere can be a hidden designator or comment that is waaaaay off in the distance. this causes trouble printing
open the parts inspector right click on a parts comment - select similar and then set position to auto center and click them hidden.

the printing processor looks at all data , hidden or not , to determine required printing size.

if you get the board full screen then there is something wrong in your printing definition. set the otput to pdf and select 8 1/2 x 11 as format. autoscale off. and set scale to 1 make sure that the print origin is set to 0 and 0 and not some wonky coordinate. that can cause the output to print split as well.
Title: Re: Printing 1:1 PCB in Altium
Post by: geo_leeman on April 30, 2014, 07:26:15 pm
free_electron: When I turn all layers on and do a zoom all the board fills the screen.  So looks like there isn't an object problem!  :phew:

If I print to a PDF with the PDF settings getting size and orientation from the document I get a print on one page, but obviously not 1:1.  When I change to look at the page setup dialog (see screenshot) I get a PDF with very small split pages.  Also attached.  Where can I verify the print origin is set to 0,0?

Title: Re: Printing 1:1 PCB in Altium
Post by: geo_leeman on May 01, 2014, 09:56:49 pm
You'd almost think it's something with the page setup (since the paper sizes above are obviously not 8.5x11").  Any other ideas? This one is still problematic!

Thanks for the help!
-John
Title: Re: Printing 1:1 PCB in Altium
Post by: free_electron on May 02, 2014, 01:10:48 am
your pcb printout scaling is set to the page setup dialog . do a page setup (right click on the job and select page setup)

most likely your orgigina and scaling and paper size there is wrong
Title: Re: Printing 1:1 PCB in Altium
Post by: geo_leeman on May 02, 2014, 01:35:53 pm
your pcb printout scaling is set to the page setup dialog . do a page setup (right click on the job and select page setup)

most likely your orgigina and scaling and paper size there is wrong

I've attached screenshots of that and a screenshot of the print preview showing the correct paper size in the bottom corner (circled).  I've also tried PDF and a few different printers.  All of this is Altium 13.3 on Win 7 if it makes any difference.  It all looks correct, any other ideas? Thanks for  |O with me!
Title: Re: Printing 1:1 PCB in Altium
Post by: dave_k on May 03, 2014, 12:52:45 am
i had scaling issues when trying to print 1:1 to a multi-function printer/copier device .. the A4 sheet ended up being spread over 9 pages!
i changed to using a bog-standard HP laserjet printer, and the 1:1 scaled print worked perfectly, so maybe it's a printer driver issue?
Title: Re: Printing 1:1 PCB in Altium
Post by: geo_leeman on May 03, 2014, 01:16:30 am
i had scaling issues when trying to print 1:1 to a multi-function printer/copier device .. the A4 sheet ended up being spread over 9 pages!
i changed to using a bog-standard HP laserjet printer, and the 1:1 scaled print worked perfectly, so maybe it's a printer driver issue?

That sounds like this problem.  I'll try to switch printers when I'm in the office tomorrow.
Title: Re: Printing 1:1 PCB in Altium
Post by: NANDBlog on May 03, 2014, 11:15:11 am
i had scaling issues when trying to print 1:1 to a multi-function printer/copier device .. the A4 sheet ended up being spread over 9 pages!
i changed to using a bog-standard HP laserjet printer, and the 1:1 scaled print worked perfectly, so maybe it's a printer driver issue?
Well, sometimes I think printers go backwards in time. I had an old paralel port printer. I clicked print, 2 seconds later it started printing what I've asked for. Now the company has a HP heavy duty network printer, which is about 200 KG. I click print, I walk there, so far it is just clicking and rotating it's stuff. I get a paper which is resized and rotated, and an other page telling me that it was unable to print the second page.
Title: Re: Printing 1:1 PCB in Altium
Post by: Psi on May 03, 2014, 11:24:12 am
A few things to try..

-Check your printer driver options and make sure its not set to do any enlarging or page combining enabled, or has an incorrect paper size set


-Do a test, create a brand new project with PCB then confirm you still have this issue with the scale set to 1:1.
(If that prints ok it proves the problem is in your main project somewhere)


Title: Re: Printing 1:1 PCB in Altium
Post by: Psi on May 03, 2014, 11:33:55 am
You don't need to specify a specific area, set it to entire sheet.

Your pic...
(https://www.eevblog.com/forum/altium/printing-11-pcb-in-altium/?action=dlattach;attach=91972;image)
Title: Re: Printing 1:1 PCB in Altium
Post by: geo_leeman on May 03, 2014, 07:45:36 pm
A few things to try..

-Check your printer driver options and make sure its not set to do any enlarging or page combining enabled, or has an incorrect paper size set


-Do a test, create a brand new project with PCB then confirm you still have this issue with the scale set to 1:1.
(If that prints ok it proves the problem is in your main project somewhere)

Psi: I don't know what I didn't do that! I just made a dummy project with about the same size board, setup things the same and the print out was fine.  It must be something with that project.  I'm probably going to redo most of it with more care managing my libraries and such.  It must be something in that project though, since another worked fine!

Thank you all for your patience and help. 

i had scaling issues when trying to print 1:1 to a multi-function printer/copier device .. the A4 sheet ended up being spread over 9 pages!
i changed to using a bog-standard HP laserjet printer, and the 1:1 scaled print worked perfectly, so maybe it's a printer driver issue?
Well, sometimes I think printers go backwards in time. I had an old paralel port printer. I clicked print, 2 seconds later it started printing what I've asked for. Now the company has a HP heavy duty network printer, which is about 200 KG. I click print, I walk there, so far it is just clicking and rotating it's stuff. I get a paper which is resized and rotated, and an other page telling me that it was unable to print the second page.

Indeed.  Sadly we are on networked printers here and it's absolutely hopeless when you print large PDFs and such.  The last conference poster we printed on a network plotter took an hour to transfer and process a 5 MB PDF.  I think I could draw the plot faster than that!  :-DD
Title: Re: Printing 1:1 PCB in Altium
Post by: geo_leeman on May 07, 2014, 02:54:12 pm
Quick update.  Problem does not exist if I print to a virtual printer made my PDFCreator installed on the windows side.  :-+  Printing to the Mac PDF printer or a real printer didn't work, but PDFCreator (Freeware) did the job.