Author Topic: Adjusting trigger settings on an old HP 1741 Oscilliscope  (Read 2665 times)

0 Members and 1 Guest are viewing this topic.

Offline alphanumero

  • Newbie
  • Posts: 4
  • Country: us
Adjusting trigger settings on an old HP 1741 Oscilliscope
« on: February 20, 2016, 06:53:47 pm »
Full disclosure -- I'm definitely still learning. I've tried searching the web, but in all honesty, I'm not getting very far, probably because I'm not sure of the exact terminology.

video of the issue



I have an old HP oscilloscope that I'm try to get working. I've compensated the probes, finally figured out that storage mode is way too tricky and I'd rather be in conventional mode, and gotten a rough idea for how time base and volts per division work.

However, when I went to try and measure a signal (500Hz square wave from an arduino uno), I'm having a tricky time getting the trigger setting to hold the wave. Attached is a video to showcase the issue. Also, the wave seems to tend upward, although it's fairly faint. I have channel A in AC mode, which I though would remove any DC offset that would cause that upward shift.

I should also mention, it's a x10 probe, an HP 10433A.

I've played around with the various buttons on the Trigger setting -- Pos/Neg, Low Fereq and High freq Rejection, AC/DC, INT/EXT, EXT/10, but I don't see any changes.

Is there something stupidly obvious I'm missing?
« Last Edit: February 20, 2016, 07:01:40 pm by alphanumero »
 

Offline MatthewEveritt

  • Supporter
  • ****
  • Posts: 136
  • Country: gb
Re: Adjusting trigger settings on an old HP 1741 Oscilliscope
« Reply #1 on: February 20, 2016, 09:56:36 pm »
First off I'd recommend decreasing the volts/div so the wave fills more of the screen. This makes it easier to see what's going on and generally makes triggering more stable to boot.

I suspect the gradual shifting up comes from the fact that the mean of the square wave is changing due to the shifting duty cycle. Try a fixed duty cycle and see if it goes away. If the trigger level isn't just slightly above  zero this could cause issues I guess.

The trigger issue could simply be a combination of those two things, so try them first.
 

Offline rf+tech

  • Regular Contributor
  • *
  • Posts: 247
  • Country: us
  • Miracle repairs performed daily
Re: Adjusting trigger settings on an old HP 1741 Oscilliscope
« Reply #2 on: February 21, 2016, 12:00:37 am »
alphanumero,

Watching the video closely, the scope *is* triggering very consistently on the falling edge at the left. As the low period increases, the next rising edge "walks away" and is adding to your confusion. The clue is to focus on the next *falling* edge which does remain stable. If the scope were not syncing, the position of this next falling edge would appear somewhere different for each successive sweep.

DC coupling the signal should remove the upward drift. This certainly is an artifact of AC coupling a variable duty cycle square wave as MatthewEveritt correctly suggests.

On second thought, maybe I should have withheld my post to see how many additional forum members get stumped. Congratulations are in order for your very creative "stump the panel" entry.

So what did I win?

RF+ Tech
 

Offline alphanumero

  • Newbie
  • Posts: 4
  • Country: us
Re: Adjusting trigger settings on an old HP 1741 Oscilliscope
« Reply #3 on: February 21, 2016, 03:51:21 am »
No intention to stump, sorry.

DC coupling the scope seemed to have no noticable effect.

The V/Div shift did make it slightly more stable, but it's tricky to tell

As for the duty cycle, I'm doing an analogWrite(11, 127.5), on an arduino, which is as far as I can tell, supposed to be a 50% duty cycle square wave at about 490Hz. I am correct here?
 

Offline vk6zgo

  • Super Contributor
  • ***
  • Posts: 4943
  • Country: au
Re: Adjusting trigger settings on an old HP 1741 Oscilliscope
« Reply #4 on: February 21, 2016, 02:55:06 pm »
No intention to stump, sorry.

DC coupling the scope seemed to have no noticable effect.

The V/Div shift did make it slightly more stable, but it's tricky to tell

As for the duty cycle, I'm doing an analogWrite(11, 127.5), on an arduino, which is as far as I can tell, supposed to be a 50% duty cycle square wave at about 490Hz. I am correct here?

From the look of things,your signal is changing its mark/space ratio at a slow rate.
If it had a fixed mark/space ratio,& the 'scope wasn't triggered,the whole signal would drift across the screen but the timing between each positive edge ,or each negative edge would remain the same.
.
Analog 'scopes only trigger at the beginning of the sweep,so the fact that one falling edge in mid screen is stable shows that point has a fixed time relationship with the trigger point.
The Oscilloscope is operating,just as it is supposed to.
If it retriggered with every edge,its display would not show what is happening to the signal
 

Offline alsetalokin4017

  • Super Contributor
  • ***
  • Posts: 1919
  • Country: us
Re: Adjusting trigger settings on an old HP 1741 Oscilliscope
« Reply #5 on: February 21, 2016, 10:10:27 pm »
@alphanumero

At the very end of the video you seem to have the timebase and the trigger level (and other trigger controls like source, coupling and mode) set properly. The channel input coupling should be DC for proper display of the Arduino's signal.

You would benefit from having a smaller V/div setting so the trace fills more of the screen vertically, as others suggested.

The signal does look like a variable mark-space (or Duty Cycle) signal though, not what you are expecting from your Arduino code. Can you please post your entire Arduino sketch for us to look at?

Indeed, the single statement analogWrite (11, 127.5) does produce a 50 percent duty cycle pulse train at about 490 Hz.  But that's not what it looks like on your scope; you should be getting a stable square pulse train like I show below on the Rigol.  So either there is something wrong with your Arduino sketch, or there is something wrong with the scope. Let's hope it is the sketch!
« Last Edit: February 21, 2016, 10:22:55 pm by alsetalokin4017 »
The easiest person to fool is yourself. -- Richard Feynman
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf