Author Topic: Atten oscilloscope firmware????  (Read 67519 times)

0 Members and 1 Guest are viewing this topic.

Offline markus_r

  • Newbie
  • Posts: 1
  • Country: ru
Re: Atten oscilloscope firmware????
« Reply #50 on: April 19, 2016, 11:49:07 pm »
Hi,  guys!

Have anybody LeCroy 5.01.02.27 firmware? Official site shares only 5.01.02.29 now and I'm not sure of it.
Also package does not contain *.cfg file - does anybody have *.cfg file for LeCroy 1012 (if it exists at all)?

(I attach here 5.01.02.29 firmware from official site (registration takes some time), it is 2-volume archive, just cut .txt extension)




Teledyne LeCroy WaveAce 1012 firmware: 5.01.02.27

http://teledynelecroy.com/support/softwaredownload/download.aspx?did=8107

Tested and working fine with Siglent 1102CML memory mod. (Original Atten ADS-1102CAL+)

CAUTION: this firmware is for WaveAce 1012 (SDS1102CML or Memory Modded CAL+, CNL) scopes. DO NOT install it if you dont have the memory IC installed first and 3 ADCs board.

GS
« Last Edit: April 20, 2016, 01:30:57 am by markus_r »
 

Offline daro-1

  • Newbie
  • Posts: 4
  • Country: au
Re: Atten oscilloscope firmware????
« Reply #51 on: September 16, 2016, 02:39:30 am »
I've got the ATTEN ADS 1102CAL that I brought secondhand from a local ham radio fest for $275 and I was warned about some of the original firmware issues as it had vers 301.01.01.213 installed when I got it and then I decided to upgrade the firmware based on what I was reading on this forum post and a similar one on this site and upgraded mine to Siglent SDS1102CNL vers 5.01.02.29 which works a treat when you follow the instructions of flashing the firmware first then reboot and then cfg file and reboot again and then do self calibration of the unit, so mine now is basically a Siglent SDS1102CNL and I can't use the original ATTEN ADS 2202CAL USB drivers as it has also upgraded USB flash EEPROM and now identifies itself as an SDS1102CNL when it's plugged into a Windows 7 or 10 based PC, is there anyway I can use this DSO on a PC because there is no known USB drivers for the SDS1102CNL to be able to use this with EasyScope vers 3?
 

Offline Kirill S

  • Newbie
  • Posts: 4
  • Country: ua
Re: Atten oscilloscope firmware????
« Reply #52 on: October 31, 2016, 01:31:31 am »
Hi. I bricked my ATTEN ADS1102CAL by connecting 220V to the ground of a scope probe. I managed to connect to it over JTAG and appeared that firmware had been corrupted. I found full dump on the internet and flashed the scope. It returned back to the life but It seems that some configuration in this dump is not corresponding to my real hardware revision. It doesn't show me signals from both channels. Tried to update it to Siglent firmware. Didn't helped.  The board of the scope has version SAT7.820.681K
Does anybody can help me with the full dump which would correspond to my hardware (ATTEN or Siglent)?

Attaching the config file for topJTAG Flash Programmer if anyone need it.
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 28766
  • Country: nz
  • Taupaki Technologies Ltd. Siglent Distributor NZ.
    • Taupaki Technologies Ltd.
Re: Atten oscilloscope firmware????
« Reply #53 on: October 31, 2016, 04:10:38 am »
I've got the ATTEN ADS 1102CAL that I brought secondhand from a local ham radio fest for $275 and I was warned about some of the original firmware issues as it had vers 301.01.01.213 installed when I got it and then I decided to upgrade the firmware based on what I was reading on this forum post and a similar one on this site and upgraded mine to Siglent SDS1102CNL vers 5.01.02.29 which works a treat when you follow the instructions of flashing the firmware first then reboot and then cfg file and reboot again and then do self calibration of the unit, so mine now is basically a Siglent SDS1102CNL and I can't use the original ATTEN ADS 2202CAL USB drivers as it has also upgraded USB flash EEPROM and now identifies itself as an SDS1102CNL when it's plugged into a Windows 7 or 10 based PC, is there anyway I can use this DSO on a PC because there is no known USB drivers for the SDS1102CNL to be able to use this with EasyScope vers 3?
Just noticed this post.....
Use of the later version EasyscopeX over USB you need to install NIVISA, the USB drivers are contained within.
The driver is ausbtmc.inf and you'll need to point your USB port to use it.
Some guidance can be found in the attached Doc.
Avid Rabid Hobbyist.
Siglent Youtube channel: https://www.youtube.com/@SiglentVideo/videos
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 28766
  • Country: nz
  • Taupaki Technologies Ltd. Siglent Distributor NZ.
    • Taupaki Technologies Ltd.
Re: Atten oscilloscope firmware????
« Reply #54 on: October 31, 2016, 04:14:43 am »
Hi. I bricked my ATTEN ADS1102CAL by connecting 220V to the ground of a scope probe. I managed to connect to it over JTAG and appeared that firmware had been corrupted. I found full dump on the internet and flashed the scope. It returned back to the life but It seems that some configuration in this dump is not corresponding to my real hardware revision. It doesn't show me signals from both channels. Tried to update it to Siglent firmware. Didn't helped.  The board of the scope has version SAT7.820.681K
Does anybody can help me with the full dump which would correspond to my hardware (ATTEN or Siglent)?

Attaching the config file for topJTAG Flash Programmer if anyone need it.
Welcome to the forum.

By any chance is the non-working channel the one you dumped mains into the GND ?
You may have damaged that channel.

Can you post up a screenshot or a pic?
Avid Rabid Hobbyist.
Siglent Youtube channel: https://www.youtube.com/@SiglentVideo/videos
 

Offline Kirill S

  • Newbie
  • Posts: 4
  • Country: ua
Re: Atten oscilloscope firmware????
« Reply #55 on: October 31, 2016, 10:13:36 am »
Welcome to the forum.

By any chance is the non-working channel the one you dumped mains into the GND ?
You may have damaged that channel.

Can you post up a screenshot or a pic?

Thank you for your attention. Both channels are not working. It looks like some internal signal is now connected to the channels or digital information about signals is taken not from ADCs. If I press Default Setup button I can see the first picture. And the second one is after I press Auto button.
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 28766
  • Country: nz
  • Taupaki Technologies Ltd. Siglent Distributor NZ.
    • Taupaki Technologies Ltd.
Re: Atten oscilloscope firmware????
« Reply #56 on: October 31, 2016, 11:36:11 pm »
Welcome to the forum.

By any chance is the non-working channel the one you dumped mains into the GND ?
You may have damaged that channel.

Can you post up a screenshot or a pic?

Thank you for your attention. Both channels are not working. It looks like some internal signal is now connected to the channels or digital information about signals is taken not from ADCs. If I press Default Setup button I can see the first picture. And the second one is after I press Auto button.
The only check I can now suggest is to reseat all connections to the display.
To do all you will have to remove the mobo to access the connector on the rear of the display.

There are some checks you can do with another scope and a DMM in the service manual.
Service manual:
http://www.siglentamerica.com/Uploadfile/file/20140925/SDS1000CNL_ServiceManual_en.pdf

Avid Rabid Hobbyist.
Siglent Youtube channel: https://www.youtube.com/@SiglentVideo/videos
 

Offline Kirill S

  • Newbie
  • Posts: 4
  • Country: ua
Re: Atten oscilloscope firmware????
« Reply #57 on: November 01, 2016, 12:42:33 am »
The only check I can now suggest is to reseat all connections to the display.
To do all you will have to remove the mobo to access the connector on the rear of the display.

There are some checks you can do with another scope and a DMM in the service manual.
Service manual:
http://www.siglentamerica.com/Uploadfile/file/20140925/SDS1000CNL_ServiceManual_en.pdf

Thank you. Will try this.
Is there any chance that FPGA Altera Cyclone IV in my scope is not configured correctly as a result of high voltage on the ground? Is the FPGA's configuring should be done separately? Or it get's it's configuration from main firmware.
 

Offline alfishe

  • Newbie
  • Posts: 8
  • Country: us
Re: Atten oscilloscope firmware????
« Reply #58 on: May 09, 2017, 01:28:47 am »
Thank you. Will try this.
Is there any chance that FPGA Altera Cyclone IV in my scope is not configured correctly as a result of high voltage on the ground? Is the FPGA's configuring should be done separately? Or it get's it's configuration from main firmware.

Altera Cyclone IV has no internal flash memory, it's SRAM based. So configuration is loaded each time on startup from external flash chip, or from CPU (most likely in this case). FPGA chip if fried, can be replaced without risk to loose anything. But I suspect that there were more fried chips and FPGA is not first in that list.
 

Offline poland153

  • Newbie
  • Posts: 5
  • Country: us
Re: Atten oscilloscope firmware????
« Reply #59 on: June 17, 2017, 06:53:54 pm »
Hi, first time poster! 

I received a Atten ADS 1102CML from my girlfriends father who told me that he broke it and that maybe I could fix it.  He tried updating the firmware to Siglent firmware and said ever since he did that he could never get a signal to appear on the display from either of the channels.

First things first, here is what current software is on it:
Software Version 5.01.02.22
Hardware Version 3-41-0.0
Product Type SDS1102CML

When I started my research I came across some of the threads here with instructions on how to upgrade to the Siglent firmware but the issue I'm having is trying to update the *.cfg file.  Most of the threads pointed to this post on the freeforums site where you can grab the firmware file, cfg file, and instructions: http://siglent.freeforums.org/new-fw-for-sds1000cml-and-cnl-t77.html

I proceeded by downloading the FW 5.01.02.22 CML firmware.
Inside there are only two files (no instructions inside rar):
SDS1000CML_SSP_V100R005B01D02P22.ADS
Siglent_CML.cfg

I renamed them to this to keep it easier:
up.ADS
cf.cfg

I put both onto a 2GB usb drive, plugged into the front usb port on the scope, went to Update Firmware, press 'SINGLE', I then selected the up.ADS file and hit LOAD.  It shows that its updating the firmware so I let it finish and then I turn off the scope.  I go to turn the scope back on and do the same process of going to Update Firmware again.  This time I scroll down to the cf.cfg file and hit LOAD but I get an error at the bottom of the file: "The selected file format is incorrect". 

And thus I'm stuck here.  Everything I looked on this site for has said to keep it the same *.cfg extension so I'm not sure what I'm doing wrong.  Also, they say the instructions are inside the package(rar file) but they are not so I'm not sure where everyone is getting their instructions from.  Any help would be greatly appreciated! Thanks in advance!
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 28766
  • Country: nz
  • Taupaki Technologies Ltd. Siglent Distributor NZ.
    • Taupaki Technologies Ltd.
Re: Atten oscilloscope firmware????
« Reply #60 on: June 17, 2017, 09:08:16 pm »
Hi, first time poster! 

I received a Atten ADS 1102CML from my girlfriends father who told me that he broke it and that maybe I could fix it. 
Welcome to the forum.

Quote
He tried updating the firmware to Siglent firmware and said ever since he did that he could never get a signal to appear on the display from either of the channels.
Nothing at all ?  :-//


Quote
First things first, here is what current software is on it:
Software Version 5.01.02.22
Hardware Version 3-41-0.0
Product Type SDS1102CML
Can you provide all but the last four characters of the SN# ?
Just need to check FW compatability.  ;)

Quote
When I started my research I came across some of the threads here with instructions on how to upgrade to the Siglent firmware but the issue I'm having is trying to update the *.cfg file.  Most of the threads pointed to this post on the freeforums site where you can grab the firmware file, cfg file, and instructions: http://siglent.freeforums.org/new-fw-for-sds1000cml-and-cnl-t77.html

I proceeded by downloading the FW 5.01.02.22 CML firmware.
Inside there are only two files (no instructions inside rar):
SDS1000CML_SSP_V100R005B01D02P22.ADS
Siglent_CML.cfg

I renamed them to this to keep it easier:
up.ADS
cf.cfg

I put both onto a 2GB usb drive, plugged into the front usb port on the scope, went to Update Firmware, press 'SINGLE', I then selected the up.ADS file and hit LOAD.  It shows that its updating the firmware so I let it finish and then I turn off the scope.  I go to turn the scope back on and do the same process of going to Update Firmware again.  This time I scroll down to the cf.cfg file and hit LOAD but I get an error at the bottom of the file: "The selected file format is incorrect". 
What you've done so far should've given you a result if the correct FW version has been applied.
All FW is available directly from Siglent sites and the .rar packages come with instructions
http://siglentamerica.com/gjjrj.aspx?id=15
User manual: (Plus model but should be very similar)
http://www.siglentamerica.com/USA_website_2014/Documents/UserManual/SDS1000DLplus&CMLplus_UserManual_UM0101A-E01A.pdf

Quote
And thus I'm stuck here.  Everything I looked on this site for has said to keep it the same *.cfg extension so I'm not sure what I'm doing wrong.  Also, they say the instructions are inside the package(rar file) but they are not so I'm not sure where everyone is getting their instructions from.  Any help would be greatly appreciated! Thanks in advance!

There are older FW versions and revisions, the only way to match them is with the SN#.

Think about it.....what is reported on the display is applicable to the FW currently installed and maybe not the HW.
Because the .cfg was rejected could mean it was too recent for the HW you have.


Avid Rabid Hobbyist.
Siglent Youtube channel: https://www.youtube.com/@SiglentVideo/videos
 

Offline poland153

  • Newbie
  • Posts: 5
  • Country: us
Re: Atten oscilloscope firmware????
« Reply #61 on: June 17, 2017, 10:37:55 pm »
Thank you for the quick repy!

Quote
Nothing at all ?  :-//
I played around some more with the controls and if I 'zoom' out on Ch1 to 10V and 25us then I see what looks like a lot of junk. And this is without any probes attached to it.  I have tried the 'Do Self Cal' multiple times but that didn't seem to help anything.

Quote
Can you provide all but the last four characters of the SN# ?
Just need to check FW compatability.  ;)
Of course, 01020100300195

Quote
What you've done so far should've given you a result if the correct FW version has been applied.
All FW is available directly from Siglent sites and the .rar packages come with instructions
http://siglentamerica.com/gjjrj.aspx?id=15
User manual: (Plus model but should be very similar)
http://www.siglentamerica.com/USA_website_2014/Documents/UserManual/SDS1000DLplus&CMLplus_UserManual_UM0101A-E01A.pdf
I went ahead and found the newest FW (I believe) from the link you provided:
SDS1000CML_Update
ReleaseDate
7/9/2015 4:37:55 AM
Version: 5.01.02.32
Imprint
For SDS1072CML/SDS1102CML/SDS1152CML

I see the .ADS file and also the instructions but I notice that there is no .cfg file and the instructions do not mention of one? Is a .cfg file only needed when initially going from Atten to Siglent FW?

Quote
There are older FW versions and revisions, the only way to match them is with the SN#.

Think about it.....what is reported on the display is applicable to the FW currently installed and maybe not the HW.
Because the .cfg was rejected could mean it was too recent for the HW you have.

Ahh yeah that makes sense. So are there situations where the FW won't allow to be loaded if the HW is very different? Because here it seems that it was half; the FW was allowd to load but the .cfg wasn't.  Or maybe I'm not understanding completely what the .cfg is supposed to do  |O.
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 28766
  • Country: nz
  • Taupaki Technologies Ltd. Siglent Distributor NZ.
    • Taupaki Technologies Ltd.
Re: Atten oscilloscope firmware????
« Reply #62 on: June 18, 2017, 01:06:08 am »
Thank you for the quick reply!

Quote
Nothing at all ?  :-//
I played around some more with the controls and if I 'zoom' out on Ch1 to 10V and 25us then I see what looks like a lot of junk. And this is without any probes attached to it.  I have tried the 'Do Self Cal' multiple times but that didn't seem to help anything.
Does the display look like those in images above ?

Quote
Can you provide all but the last four characters of the SN# ?
Just need to check FW compatability.  ;)
Of course, 01020100300195[/quote]
OK, I think you need older version 3 FW that is not on the Siglent site.
I only have it for 5" display models.

But I have this Atten FW: ads1K40K_func_ads1102cal+20140724.up
And AFAIK it will suit your scope if it has 7" display.
You will need to PM me with your email if you want it.
I think it will help but I'm not entirely sure, use at your own risk as I don't see you mention that the unit is a Plus model.


For now you need to forget about .cfg files and get this scope working again and worry about getting Siglent FW that might suit the HW onto it later.

Quote
So are there situations where the FW won't allow to be loaded if the HW is very different?
No.
Older FW is not on websites now so to minimise user error.

Quote
Because here it seems that it was half; the FW was allowed to load but the .cfg wasn't.
.cfg files are only included when there are substantial changes to the way a unit works and/or if there are major changes to the UI. Normally we don't see .cfg files very often included in FW releases.
Avid Rabid Hobbyist.
Siglent Youtube channel: https://www.youtube.com/@SiglentVideo/videos
 

Offline poland153

  • Newbie
  • Posts: 5
  • Country: us
Re: Atten oscilloscope firmware????
« Reply #63 on: June 18, 2017, 01:58:50 am »
Quote
Does the display look like those in images above ?
In fact, it does look similar to those two pictures where it looks all over the place. 

Quote
OK, I think you need older version 3 FW that is not on the Siglent site.
I only have it for 5" display models.

But I have this Atten FW: ads1K40K_func_ads1102cal+20140724.up
And AFAIK it will suit your scope if it has 7" display.
You will need to PM me with your email if you want it.
I think it will help but I'm not entirely sure, use at your own risk as I don't see you mention that the unit is a Plus model.
I see, I went ahead and sent you a pm with that.  And yes, I do not have the Plus model; all it says is ADS 1102CML 100MHz 1GSa/s.

Quote
For now you need to forget about .cfg files and get this scope working again and worry about getting Siglent FW that might suit the HW onto it later.
No.
Older FW is not on websites now so to minimise user error.
Okay, and if I get it working on the Atten FW, I take it I'll have to start scouring the net for older Siglent FW? Or at least the older 3.x stuff.

Quote
.cfg files are only included when there are substantial changes to the way a unit works and/or if there are major changes to the UI. Normally we don't see .cfg files very often included in FW releases.
Aha okay that makes sense. Thanks for explaining that to me!
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 28766
  • Country: nz
  • Taupaki Technologies Ltd. Siglent Distributor NZ.
    • Taupaki Technologies Ltd.
Re: Atten oscilloscope firmware????
« Reply #64 on: June 18, 2017, 04:18:48 am »
Quote
Does the display look like those in images above ?
In fact, it does look similar to those two pictures where it looks all over the place. 
Hmmm, that worries me as the only other times I've seen this it meant a mobo replacement.

Quote
OK, I think you need older version 3 FW that is not on the Siglent site.
I only have it for 5" display models.

But I have this Atten FW: ads1K40K_func_ads1102cal+20140724.up
And AFAIK it will suit your scope if it has 7" display.
You will need to PM me with your email if you want it.
I think it will help but I'm not entirely sure, use at your own risk as I don't see you mention that the unit is a Plus model.
I see, I went ahead and sent you a pm with that.  And yes, I do not have the Plus model; all it says is ADS 1102CML 100MHz 1GSa/s. [/quote]
Got it, will send you some stuff soon........but when I have a look at reply #51 it seems you can put series 5 FW on these units.  :-//
Which leads me back to suspecting something's wrong with your unit.

Quote
.cfg files are only included when there are substantial changes to the way a unit works and/or if there are major changes to the UI. Normally we don't see .cfg files very often included in FW releases.
Aha okay that makes sense. Thanks for explaining that to me![/quote]
I've got two different sized .cfg files in my archives but there's no .cfg file in the package with 2.29 FW mentioned in reply #51.
I'll send what I have and you can try them with 2.29 but I don't like what you tell me about the display.

If you have success do comeback here and describe your journey for others to maybe benefit from.
Avid Rabid Hobbyist.
Siglent Youtube channel: https://www.youtube.com/@SiglentVideo/videos
 

Offline poland153

  • Newbie
  • Posts: 5
  • Country: us
Re: Atten oscilloscope firmware????
« Reply #65 on: June 18, 2017, 04:59:15 am »
Quote
Hmmm, that worries me as the only other times I've seen this it meant a mobo replacement.
OK, I think you need older version 3 FW that is not on the Siglent site.
I only have it for 5" display models.

But I have this Atten FW: ads1K40K_func_ads1102cal+20140724.up
And AFAIK it will suit your scope if it has 7" display.
You will need to PM me with your email if you want it.
I think it will help but I'm not entirely sure, use at your own risk as I don't see you mention that the unit is a Plus model.
I see, I went ahead and sent you a pm with that.  And yes, I do not have the Plus model; all it says is ADS 1102CML 100MHz 1GSa/s.
Got it, will send you some stuff soon........but when I have a look at reply #51 it seems you can put series 5 FW on these units.  :-//
Which leads me back to suspecting something's wrong with your unit.
So I got your email and put both of those files onto the root of my USB drive but when I go to LOAD the .up file, it says it's in the incorrect file.  I changed the extension type to .ADS to see if that helps but then it gave me the 'Product type does not match' error. Any ideas?

Quote
I've got two different sized .cfg files in my archives but there's no .cfg file in the package with 2.29 FW mentioned in reply #51.
I'll send what I have and you can try them with 2.29 but I don't like what you tell me about the display.

If you have success do comeback here and describe your journey for others to maybe benefit from.
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 28766
  • Country: nz
  • Taupaki Technologies Ltd. Siglent Distributor NZ.
    • Taupaki Technologies Ltd.
Re: Atten oscilloscope firmware????
« Reply #66 on: June 18, 2017, 05:49:23 am »
Quote
Hmmm, that worries me as the only other times I've seen this it meant a mobo replacement.
OK, I think you need older version 3 FW that is not on the Siglent site.
I only have it for 5" display models.

But I have this Atten FW: ads1K40K_func_ads1102cal+20140724.up
And AFAIK it will suit your scope if it has 7" display.
You will need to PM me with your email if you want it.
I think it will help but I'm not entirely sure, use at your own risk as I don't see you mention that the unit is a Plus model.
I see, I went ahead and sent you a pm with that.  And yes, I do not have the Plus model; all it says is ADS 1102CML 100MHz 1GSa/s.
Got it, will send you some stuff soon........but when I have a look at reply #51 it seems you can put series 5 FW on these units.  :-//
Which leads me back to suspecting something's wrong with your unit.
So I got your email and put both of those files onto the root of my USB drive but when I go to LOAD the .up file, it says it's in the incorrect file.  I changed the extension type to .ADS to see if that helps but then it gave me the 'Product type does not match' error. Any ideas?
I guess the .up file is Atten's own format and won't be compatible with the Siglent OS.

So let's go back and ask why/ how it got broken ?
Quote
I received a Atten ADS 1102CML from my girlfriends father who told me that he broke it and that maybe I could fix it.
Broke because the display was corrupted and then installed FW trying to fix it ?
If this is the case then IMO a new mobo will be needed.

Avid Rabid Hobbyist.
Siglent Youtube channel: https://www.youtube.com/@SiglentVideo/videos
 

Offline poland153

  • Newbie
  • Posts: 5
  • Country: us
Re: Atten oscilloscope firmware????
« Reply #67 on: June 18, 2017, 06:23:46 am »
Quote
Hmmm, that worries me as the only other times I've seen this it meant a mobo replacement.
OK, I think you need older version 3 FW that is not on the Siglent site.
I only have it for 5" display models.

But I have this Atten FW: ads1K40K_func_ads1102cal+20140724.up
And AFAIK it will suit your scope if it has 7" display.
You will need to PM me with your email if you want it.
I think it will help but I'm not entirely sure, use at your own risk as I don't see you mention that the unit is a Plus model.
I see, I went ahead and sent you a pm with that.  And yes, I do not have the Plus model; all it says is ADS 1102CML 100MHz 1GSa/s.
Got it, will send you some stuff soon........but when I have a look at reply #51 it seems you can put series 5 FW on these units.  :-//
Which leads me back to suspecting something's wrong with your unit.
So I got your email and put both of those files onto the root of my USB drive but when I go to LOAD the .up file, it says it's in the incorrect file.  I changed the extension type to .ADS to see if that helps but then it gave me the 'Product type does not match' error. Any ideas?
I guess the .up file is Atten's own format and won't be compatible with the Siglent OS.

So let's go back and ask why/ how it got broken ?
Quote
I received a Atten ADS 1102CML from my girlfriends father who told me that he broke it and that maybe I could fix it.
Broke because the display was corrupted and then installed FW trying to fix it ?
If this is the case then IMO a new mobo will be needed.
Basically from what I understood was that it was in working order and he read on some of his Polish forums that people were changing their FW to Siglent to get more features. So he followed some of their instructions and ever since it was reading wrong.  What FW he used and what instructions he followed I have no idea.  He gave it to me saying that he 'bricked' it and if I can fix it then I can have it; he seemed like he tried fixing it but gave up.

I tried looking on eBay for a mobo to it but nothing came up; maybe I was searching for it incorrectly. 
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 28766
  • Country: nz
  • Taupaki Technologies Ltd. Siglent Distributor NZ.
    • Taupaki Technologies Ltd.
Re: Atten oscilloscope firmware????
« Reply #68 on: June 18, 2017, 07:53:34 am »
Quote
Hmmm, that worries me as the only other times I've seen this it meant a mobo replacement.
OK, I think you need older version 3 FW that is not on the Siglent site.
I only have it for 5" display models.

But I have this Atten FW: ads1K40K_func_ads1102cal+20140724.up
And AFAIK it will suit your scope if it has 7" display.
You will need to PM me with your email if you want it.
I think it will help but I'm not entirely sure, use at your own risk as I don't see you mention that the unit is a Plus model.
I see, I went ahead and sent you a pm with that.  And yes, I do not have the Plus model; all it says is ADS 1102CML 100MHz 1GSa/s.
Got it, will send you some stuff soon........but when I have a look at reply #51 it seems you can put series 5 FW on these units.  :-//
Which leads me back to suspecting something's wrong with your unit.
So I got your email and put both of those files onto the root of my USB drive but when I go to LOAD the .up file, it says it's in the incorrect file.  I changed the extension type to .ADS to see if that helps but then it gave me the 'Product type does not match' error. Any ideas?
I guess the .up file is Atten's own format and won't be compatible with the Siglent OS.

So let's go back and ask why/ how it got broken ?
Quote
I received a Atten ADS 1102CML from my girlfriends father who told me that he broke it and that maybe I could fix it.
Broke because the display was corrupted and then installed FW trying to fix it ?
If this is the case then IMO a new mobo will be needed.
Basically from what I understood was that it was in working order and he read on some of his Polish forums that people were changing their FW to Siglent to get more features. So he followed some of their instructions and ever since it was reading wrong.  What FW he used and what instructions he followed I have no idea.  He gave it to me saying that he 'bricked' it and if I can fix it then I can have it; he seemed like he tried fixing it but gave up.
OK, so it sounds if you get the right FW it might go again.
I have seen corrupted displays arising from internal connection problems and you might have seen my comments a few posts back to reseat all internal connections. Grab the Service manual that's linked for guidance.
Beware the locks on the ribbon cable connectors  ;) and you'll have to pretty much totally dismantle it to get to a hidden ribbon cable connector on the back of the display. It's well hidden and can be a bitch to get at.
If the GF's dad has any experience with modular and mechanical construction he will have a few tools and the patience to guide you. Don't plan on it taking only an hour, they do for me now after having done a couple and knowing exactly which tools I need.
When they're all apart you can connect the parts/boards and power them up for quick checks. Just be careful where you put your fingers....stay safe.

Quote
I tried looking on eBay for a mobo to it but nothing came up; maybe I was searching for it incorrectly.
You'll be very lucky to find one unless you stumble on a unit that doesn't power up, maybe with a dead PSU only.
Avid Rabid Hobbyist.
Siglent Youtube channel: https://www.youtube.com/@SiglentVideo/videos
 

Offline tv84

  • Super Contributor
  • ***
  • Posts: 3251
  • Country: pt
Re: Atten oscilloscope firmware????
« Reply #69 on: August 12, 2017, 12:26:59 pm »
Look at https://www.eevblog.com/forum/testgear/firmware-update-for-atten-ads1102cal-oscilloscope/


ADS files are totally different from this UP (which is PGP encrypted like Hantek fw).

An .UP firmware won't work in a .ADS scope and vice-versa!
« Last Edit: December 11, 2017, 09:50:17 pm by tv84 »
 

Offline cfwotzka

  • Newbie
  • Posts: 1
  • Country: de
Re: Atten oscilloscope firmware????
« Reply #70 on: November 12, 2017, 05:41:18 am »
hi all,

I've got an Siglent SDS1102CN with the small 5.7" screen and accidently updated with firmware made for more recent versions.
now I can only see around 75% of the screen.
is there somebody who could PM me the original firmware?

many thanks in advance

christian
 

Offline phillman5

  • Newbie
  • Posts: 4
  • Country: us
Re: Atten oscilloscope firmware????
« Reply #71 on: February 02, 2018, 05:56:32 pm »
I know most here are discussing a different ATTEN model, but hopefully someone can help.
I have a Atten ADS1062CAL and updated the FW with SDS1000CML_SSP_V100R005B01D02P32.ADS.  There was no .cfg file in the SDS1000CNL_SSP_V100R005B01D02P32 (3).rar download.

I then had a pro solderer put the IS61LPS51236A-200TQLI memory chip on the board (I gave him a large Apple pie from Costco afterwards).  I don't see any difference in the screens, saved data has the same length.

Do I need to reflash the FW?  Do I need a different FW?  Do I need a .cfg file? There are is another blank chip site on the board unpopulated, do I also need that chip?  Any jumpers need to be set?

Also another question.  I notice a Record function (Utitity, third screen), but that is in the manual so not new.  Manual say you can record up to 2500 frames, then play them back.  But can you save that recording to the thumb drive?  I also see a Recorder function (Utility, forth screen) this is not in the manual.  Scope says can only be used in the Scan mode. That is for slow scans > 100ms, so kind of doubt the memory chip has anything to do with it.

Thanks for any help!
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf