Electronics > Beginners

Function Generator Amplitude vs. Scope Amplitude

(1/2) > >>

pheller:
Greetings,

  I am a beginner, with a a Rigol DS1102D and a Rigol DG1022A.

Anyways, I'm just learning the two pieces of gear, and I'm stumped by something.

I set channel 1 of the Function Generator to output a 1khz Sine Wave at 1Vpp, no offset.  I connect directly to channel one of the scope with straight bnc-bnc coax.  Channel 1 is set for 1x.  I successfully get a stable waveform on the screen, but the scope measures 2Vpp.

Am I missing something here?

Regards,

  Phil

Simon:
are you sure that the probe attenuation is set up right, you need to select the attenuation on the probe itself and then tell the scope what attenuation the probe has, it sounds like a case where you have 10X on the probe and the scope set to 20X (the scope has settings for 1X 5X 10X 20X 50X 100X 1000X)

jimmc:
I'm not familiar with the Rigol kit but it sounds as if the generator is calibrated for pd.

ie It has an emf of 2v p-p and an output resistance of 50 ohm, thus it will deliver 1vp-p into a 50 ohm load and 2vp-p into an open circuit (or the 1 Megohm of the 'scope).
Connect a 50 ohm resistor across the input of the 'scope and the voltage will drop to 1v p-p.

There is probably a option to select emf rather than pd somewhere in the generators menu.

Jim

Bored@Work:
Yes, you are missing something. The generator displays the voltage as if put into a certain load. Typically a generator assumes 50 Ohm load and has an own source impedance of 50 Ohm. It compensates for that assumed load. If you connect a load with another impedance than 50 Ohm the generator gets its compensation wrong.

To deliver 1 Vpp into an assumed 50 Ohm load the generator has to put out 2 Vpp, because the generator's 50 Ohm impedance and the 50 Ohm load form a voltage divider 1:2. That 1:2 divider than divides the generator's 2 Vpp down to 1 Vpp, so the 50 Ohm load gets 1 Vpp. And everything is fine.

You are putting the signal into 1 MOhm. With the 1 MOhm oscilloscope impedance you have a voltage divider 1:1.00005, which is as good as 1:1 for practical purposes. But the generator still puts 2 Vpp into it, thinking it is driving a 50 Ohm load, and you get 2 Vpp.

Search in the generator menu for an option to change its output impedance. That option doesn't really change the output impedance, it remains 50 Ohm. But it changes what load impedance the generator assumes. If it knows it puts the signal into a 1 MOhm load it will assume a 1:1 divider, and just output 1 Vpp.

pheller:

--- Quote from: BoredAtWork on October 30, 2010, 06:44:24 pm ---Search in the generator menu for an option to change its output impedance. That option doesn't really change the output impedance, it remains 50 Ohm. But it changes what load impedance the generator assumes. If it knows it puts the signal into a 1 MOhm load it will assume a 1:1 divider, and just output 1 Vpp.

--- End quote ---

D'oh.  I'm sure this is exactly right, and I should have thought about it before even posting.

There is an option for output impedance, and I'll give it a shot tomorrow sometime.

Thanks for the hint!

--phil

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version