Author Topic: What can cause Topward 6603A power supply transfomer heavy vibration & noise ?  (Read 2934 times)

0 Members and 1 Guest are viewing this topic.

Offline hunter

  • Contributor
  • Posts: 13
Hi all,
I have a Topward 6306D power supply and recently it started on making violent transformer noise (yes, it did it itself while I was away  :palm:, there was no load connected to the outputs..). So I opened up the cover and took a look, everything looked fine. All functions worked well (voltage, current...) except that the transformer which buzzed like a grinder.


Here are some pics for the 6603A which have very identical boards
http://www.kerrywong.com/2012/12/01/topward-6603a-linear-power-supply-teardown/

There were 2 packs of wire from the transformer which went to each channels. Each pack had 5 thick wires which were soldered directly to the heavy traces (top in pictured). The rest 6 thin wires were to connector on board (top right corner).

 I measured the 5 thick wires continuity and they seemed to be shorted together. The same is true for the other channel. I wonder if this way is the way it is ...?
I disconnected as many connectors from transformer to PCB as I could, powered up, still buzzed..
So I am planning to desolder those 5 thick wires off the PCB to see what happens . But before I do that, can you please offer your opinions on troubleshooting this PS ?
Thanks.
 

Offline Tube_Dude

  • Regular Contributor
  • *
  • Posts: 115
  • Country: pt
I measured the 5 thick wires continuity and they seemed to be shorted together. The same is true for the other channel. I wonder if this way is the way it is ...?

Hi

I have a Topward 6303A and the transformer make some hum noise too. It's a mechanical noise, so you need to play with the bolts that fix the transformer to the chassis, and the transformer bolts themselves. Sometimes tighten, others untighten, help.

About the wires coming from transformer to the boards looking shorted, that's because they come from the secondary of the transformer and as the wire from the secondary is very thick, it looks like a short at DC, but not at AC because of the inductance.

I love my Topward, 6303 A...  8)
« Last Edit: January 03, 2013, 01:02:32 pm by Tube_Dude »
Jorge
 

Offline saturation

  • Super Contributor
  • ***
  • Posts: 4788
  • Country: us
  • Doveryai, no proveryai
    • NIST
Transformer noises come from the vibrations of the laminated plates caused by magnetorestriction, it can also happen suddenly when adjacent components flex with temperature and now resonate with this noise or with line frequency.  If its not the resonance, transformer noise is inherent in its construction.  Its not a defect, but modern transformers made well do not make such a noise as badly as those from before ~ 1990s.

http://www.crosslinktech.com/articles/how-to-reduce-transformer-noise-using-epoxy-or-polyurethane-compounds.html

Best Wishes,

 Saturation
 

Offline hunter

  • Contributor
  • Posts: 13
Hi guys,
I took out the 2 big caps to make some measurement and put back in. And the noise is gone ! It is unclear why I had the noise before (which is unusual noise, indicating there was a problem) but I am glad it is back to normal now.
Cheers !
 

Offline hunter

  • Contributor
  • Posts: 13
my Topward 6603A is making violent vibration once in a while. And it keeps doing that. When it happens I stop using it and next time I turn on its back to normal. It is annoying.
 

Offline alsetalokin4017

  • Super Contributor
  • ***
  • Posts: 1879
  • Country: us
Check the fans.
The easiest person to fool is yourself. -- Richard Feynman
 

Offline BrianHG

  • Super Contributor
  • ***
  • Posts: 2959
  • Country: ca
Though it's not a Topward 6306D, I have a few 500va and 1kva toroid transformers which once in awhile powerup with a huge hum and vibrate.  Nothing seems to be wrong, the application is working fine, they are not heating up or anything, it's just like the transformer started off on a bad point of the AC cycle and decided to generate this hum until I turn it off, then turn it on again.  This weird lemon powerup only happens around 1 in 200 power cycles & all I do is cycle the power to fix it.  I have no clue why.  All these toroid are commercial grade premium transformers spanning different years and manufacturers and they are not operating under duress.
__________
BrianHG.
 

Offline Kleinstein

  • Super Contributor
  • ***
  • Posts: 6222
  • Country: de
Especially large ring core transformers might get upset with to much DC voltage one the grid. This can increase the audible noise as it brings the core closer to saturation on one side. So it could be neighbor using something like hair dryer on low power setting or a kind or poor dimmer for the lights.
 

Offline DarkAvenger183

  • Newbie
  • Posts: 1
  • Country: ro
Hello, have you found what was causing this problem? Did you fix this issue?
My Topward PSU has a similar problem. I would like to fix it
 

Offline IanMacdonald

  • Frequent Contributor
  • **
  • Posts: 944
  • Country: gb
    • IWR Consultancy
First check the four through-bolts in the transformer for looseness. There might also be another loose piece of metal in the vicinity, flapping in the magnetic breeze from the transformer. If no joy, varnishing the laminations with a good quality thin varnish that will run into any gaps between them, may help.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf