Electronics > Beginners

Low noise voltage opamp oscillating

(1/3) > >>

pwnell:
Birds eye overview of my project: I am building a low noise voltage amplifier to amplify small signal noise, specifically I want to quantify Johnson noise in resistors.  The amp is not my design -  merely built it (I know it is working - but I might have botched something, I therefore cannot post it, but suffice to say it is dual channel, two cascaded low noise opamps each with negative feedback, and non-inverting, all using SMD components in a shielded box, powered by 4 D-cell 1.5V cells).  The power supply is partly of my own design as I never had the schematics.  See schematic attached.



I tested this amp by connecting a signal generator to the input and measuring the output - I get a clean gain of approx 2100 between 100Hz and 2000Hz with an input of 0.865mV RMS (Sine wave).  The supply rails look fine - after my addition of the TLE2426 and caps it does not drift. 

Here is the problem - I connect various carbon resistors to the input (via a shielded copper tube and BNC cable), then measure the output.  Here is what I get - random noise (as expected) for resistors of values:

Short
10MΩ 1% Carbon
330kΩ 1% Carbon
10kΩ, 5%, Carbon
1kΩ, 5% Carbon
100Ω, 5%, Carbon
10Ω, 1%, Carbon

But for these resistors:
1MΩ 5% Carbon
100kΩ, 5%, Carbon

I get a clipped square wave output.  Frequencies are ~1.178kHz and ~8kHz, respectively (1MΩ and 100kΩ).  Measuring at the input to the opamp I get a 60mV or so spike at that frequency, but what is oscillating in my circuit that can cause this?  There are no caps between the input and the non-inverting input, only between the output of each opamp and the inverting input.

David Hess:
Check figure 17 on page 17 of the datasheet.  The 0.22 microfarad output capacitor shown will be unstable for some loads.

I would replace that capacitor with a 1 microfarad solid tantalum or 10 microfarad aluminum electrolytic.  The higher ESR of these capacitors aids stability.

pwnell:
Still unstable :(

magic:
Why are you posting a schematic of the PSU rather than the amplifier itself? Did you verify that it's the output of TL2426 which goes bonkers and not the opamps?

You can get a 100% stable ground by tapping into the middle of the battery chain. Problems will begin when some of the batteries get depleted before others, but it's good enough for testing at least (or you can even choose to ignore the problems and just build it that way).

And your schematic is wrong; you are supposed to connect COMMON to VEE and BAT- and OUT to GND and the capacitors. C2 makes no sense as drawn because it's shorted. Make sure the schematic corresponds to what you have actually built and vice-versa.

pwnell:

--- Quote from: magic on December 06, 2021, 07:58:16 am ---Why are you posting a schematic of the PSU rather than the amplifier itself? Did you verify that it's the output of TL2426 which goes bonkers and not the opamps?
--- End quote ---

The output of the supply rails look stable to me - no oscillations or anything strange I can see.  I posted it as I designed it, whereas the low voltage amp I did not design and have no permission to repost.


--- Quote from: magic on December 06, 2021, 07:58:16 am ---And your schematic is wrong; you are supposed to connect COMMON to VEE and BAT- and OUT to GND and the capacitors. C2 makes no sense as drawn because it's shorted. Make sure the schematic corresponds to what you have actually built and vice-versa.

--- End quote ---
You are right - the schematic is wrong, the power supply circuit is correct (since it works) - see attached, I redrew it and removed the 0.22µF caps as I tested with and without them and it made no difference..

Any insights where in the amp I can look at?  Like I said - feeding it an input voltage over 100Hz - 2kHz it seems stable - properly amplifying the signal.  Only when I apply a single resistor and no voltage source to the input, and only for some values, does it oscillate.

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version