Electronics > Beginners

QFN Chip stuck won't come off Help!

(1/2) > >>

kifu88:
Hello!
SO decided to fix my broken GPU (sapphire rx 480 nitro) , changing the IR qfn Chip (rectifier power stages.)

i bought a hot air station (KD 858).  My problem is that the solder will not melt. The chipset is stuck. i tried with hot air station 300c-400c medium air with flux for 20sec-2 min multiple times and nothing. chip is not budging! I tried adding new Solder (Sn60Pb40 2.5flux) still nothing.

Is the chip welded itself to the ground PCB?

What should i do?



Siwastaja:
The multilayer board is just not heating up.

You can try to heat the whole board at slightly lower temperature setting (like 200 degC) for a LONG time (like 15 minutes!) and then increase the temperature and start working around the chip. Don't go beyond about 370-380.

But better yet, use preheating. Even a simple frying pan on a stove does. You don't need high temperatures. A cheap IR thermometer helps here. If you can keep the frying pan at, say, 200 degC, so that the board finally heats up somewhere around 150 degC, this will already make a huge difference; now let the hot air do the rest of the job: keep the board on the pan, and start working with hot air around the chip.

kifu88:
IT WORKED! i DID exactly as you said! your the best!

Btw the back of the card (PCB) was sweating a bit, is that normal?

Siwastaja:
What do you mean by sweating? If it creates blister-like structure or emits smoke, you have applied too much heat to it, the FR4 board material itself can't take much beyond 200 degC for a long time, or much beyond 300 degC even for a shorter time. (Because of limited thermal transfer capabilities of air, the air itself can and must be hotter than this.)

The key with preheating is to get whole board to as equal temperature as possible, using modest heat and long enough time. If you have any dummy boards, practice.

kifu88:
No somke no blister-like structure. Just like spots of water/liquid and then they evaporated.

I replaced the QFN chip, there was a extremely small SMD ceramic capacitor missing next to it desoldered when i was trying to remove the chip.

the card worked, but as soon as i installed the driver bum! the second QFN blew and burning circuit smell.

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version