Author Topic: Range Finder - TTL Comunication  (Read 330 times)

0 Members and 1 Guest are viewing this topic.

Offline Dryadwoods

  • Newbie
  • Posts: 1
  • Country: at
Range Finder - TTL Comunication
« on: February 17, 2018, 04:24:29 pm »
I am trying to make connection to a range finder, however I am facing some problems.

I am using:

    Geekcreit┬« FT232RL FTDI USB To TTL Serial Converter Adapter Module For Arduino
    Suaoki 600M

This is a "closed range finder", but after opening it I found it very similar (but NOT the same) to other chinese products available on ebay offers TTL comunication.

The ebay version has the following description:

    Port Type: TTL
    Baud Rate: 115200bps

I have tried to connect it (please see the printscreen and photos on how I am plugin things up)

And I try to send the following commands (described on the ebay article)

    0d0a4f4e0d0a ON
    0d0a4f46460d0a OFF
    0d0a4d4f44453d310d0a MODE=1
    0d0a4d4f44453d300d0a MODE=0
    0d0a4f3d310d0a O=1

But I receive nothing....

The layout of my board is different from the ebay product, so I am really not sure if I am plugging the cable correctly, but with trial and error I think I was able to make a correct connection, because the optic changes the "layout" to continuous range with automatic update of distance (we can see that on the webcam attached to the range finder)... Meanwhile I have tried all combinations of baud rate, etc.. and nothing changed... I never receive anything and also the commands I sent seem to have no impact on the device.

Is there anything that I am doing wrong? or I simply cannot expect that similar boards will work the same way?
« Last Edit: February 17, 2018, 04:26:28 pm by Dryadwoods »

Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo