Electronics > Beginners

Resistance between two unconnected tracks on PCB [in Mega Ohms]

(1/3) > >>

I have a PCB that I was about to assemble. In fact, I've already soldered one part onto it (the AT Mega 128L). I was just curious and decided to check what the resistance was between my 1.8V rail and ground and I found an interesting result.

My meter gives me a reading in the mega ohms range. It varies between 0.5M to 40M and it doesn't really stabilize. These tracks are unconnected at this stage. The MCU is only connected to 3.3V and GND and the 1.8V rail does not come near it. I would have expected the 3.3V to Gnd resistance to be in kOhms range and the resistance between 1.8V to GND to be pretty much infinite. The 3.3V to Gnd resistance is as expected in kOhms but the other result is bewildering.

Some (but not all. Most give 0L as the meter isn't able to measure it) other tracks also give me this reading. I'm not sure what to think. I don't have another PCB on which I could test this on but from my limited knowledge, I feel that isn't this entirely normal and could cause my circuit to fail.

Any advice regarding this would be appreciated. Here's a link to my PCB:
--- End quote ---

Apologies for the not-so-good layout. It was really only my 3rd or 4th one and the most complicated that I've done. I measured the resistance between 1.8V rail and GND at P1 and the pads at C103 and C102 - all unconnected as I mentioned. The PCB is unassembled with the exception of U3 (Mega 128L).

All will be good what voltage did you test the resistance at.

Do you have an empty board to test, or was this home built?

Try cleaning off any flux residue and measuring again.

0.5M = 500000 ohms

Yeah, I actually realized that flux could be the issue as soon as I hit "Submit" on my original post. I'm using a Flux Pen and that somehow got to the center of the board where the 1.8V rail goes to.

I then did a experiment - I had some AT Mega 128 breakout boards and measured the resistance between any two pins without any flux or anything. This was a clean, brand new board and as expected the resistance was 0L. I then applied some flux on two pads and measured it. The resistance shot up to mega ohms. I then used some thinner and applied that and that got rid of the conductivity.

I then did the same on my PCB and it worked. Unfortunately, it sorta smudged my silk screen but that's not a big issue as this is just a prototype. So I feel I've fixed the problem but I have some concerns:

1) What's the best way to clean the board after soldering? Unfortunately, I can't get specialized chemicals as I'm in Pakistan and it's very difficult to import such things. But if a Flux Thinner comes in "pen form", that would be quite convenient.

2) I actually had an identical board that I assembled a week ago. It stopped working out of the blue a couple of days ago. Unfortunately I haven't been able to track down the problem - is it possible that this residual flux could be the issue? I didn't realize that the resistance could be measurable with flux and worked on the board without removing some of it. A hard lesson to learn, but this is something I probably won't forget anytime soon.


[0] Message Index

[#] Next page

There was an error while thanking
Go to full version