Author Topic: How on earth do I get the PSU out of this old scope??? (retitled)  (Read 10994 times)

0 Members and 1 Guest are viewing this topic.

Offline Atheus

  • Contributor
  • Posts: 47
  • Country: gb
Hi all,

Thank you all for all your help so far on my venture into electronics. So I just acquired a bit of kit from Ebay - a "Flue and Phillips" PM3055 60Mhz analog oscilloscope for next to nothing. It was sold as for parts, but one pic showed a trace on the screen, and it didn't look too bad apart from one crack in the plastic and one non-working button (the auto set). I spoke to the guy and he said he didn't really know if it worked, he didn't know how to test it, and it was old so he was just getting rid of it.

I lucked out. The crack in the plastic was purely cosmetic damage - no components directly under it - and it was just a bit of old plastic from the crack preventing the auto set button working. Clear the switch and a bit of duck tape later I have an (I think?) fully functional 60Mhz scope. It even came with probes. Herein lies the problem...

The probes have no ground clip attached! I don't really understand much about the operation of a scope yet, but I know it needs two points per probe, the trace for that probe being the difference between those points over time. They look like the attached photo.



Why would someone remove the clip? Are these of any use without it? Can I just wire-wrap one in or is there some kind of standard connector for that end which I am missing?

Confused,  :-// ~Atheus

/edit: Okay it doesn't like dropbox shared images. I'll give it a real URL...
« Last Edit: April 01, 2017, 04:33:36 pm by Atheus »
 

Offline Brumby

  • Supporter
  • ****
  • Posts: 8954
  • Country: au
Re: Scope probes have no ground connector!
« Reply #1 on: March 26, 2017, 05:17:19 pm »
Google search "oscilloscope probe" and look at some images.

The ground clip is usually a short alligator clip with an end that screws into or clips onto a point along the probe.  There's nothing exceptionally special about them - other than they are kept short as possible.  (Big loops are great antennas and will pick up any EMF and add it to the signal you want to measure.)

If you want to get into RF work, then you will need to be especially careful with probes and technique.

Starting out in the audio spectrum is where I would point you.
« Last Edit: March 26, 2017, 05:25:42 pm by Brumby »
 

Offline Monkeh

  • Super Contributor
  • ***
  • Posts: 5789
  • Country: gb
Re: Scope probes have no ground connector!
« Reply #2 on: March 26, 2017, 05:20:15 pm »
The ground leads for those probes would just have a little sprung clip on them. Honestly though, it's easier to just buy some probes than get new ground leads.

A pair of perfectly functional probes will cost as little as £6 on eBay, £10 if you want them this week.
 

Offline amspire

  • Super Contributor
  • ***
  • Posts: 3632
  • Country: au
Re: Scope probes have no ground connector!
« Reply #3 on: March 26, 2017, 05:23:35 pm »
Probe accessories often get lost.

Anyway, you can get excellent probes very cheaply now.

https://www.aliexpress.com/item/SDFC-1Set-High-Quality-P6100-Oscilloscope-Probe-DC-100MHz-Scope-Clip-Probe-100MHz/32650681057.html

If you can fabricate your own spring clip for the probe, you can make your own ground cables. But you will find it good to have two identical probes.

 

Offline Atheus

  • Contributor
  • Posts: 47
  • Country: gb
Re: Scope probes have no ground connector!
« Reply #4 on: March 26, 2017, 05:29:26 pm »
Oh and I forgot to mention - there's another weirdness - the probe on the left measures 1M \$\Omega\$ end-to-end on the centre pin of the co-ax while the other only 0.5k \$\Omega\$... I thought all probes were high impedance? Is at least one of these safe to use to test the device fully? Is it something to do with the 10x on the probe? I haven't got that far (10x/100x probes) yet.

Re: the existing replies already - thank you! What a great forum. So I'll probably buy two new identical probes, but in the meantime, if I make a solid connection between the alligator clip and the outer co-ax can I use this to test? Or is it too sensitive for simple wire-wrapping or some kind of drilled tab connectors?

/edit: Also is there any specific spec I'm looking for in new probes to match the scope? Or will any generic probe be safe to use?

Pics of scope in action coming ASAP...
« Last Edit: March 26, 2017, 05:39:04 pm by Atheus »
 
The following users thanked this post: ludzinc

Offline Monkeh

  • Super Contributor
  • ***
  • Posts: 5789
  • Country: gb
Re: Scope probes have no ground connector!
« Reply #5 on: March 26, 2017, 05:31:20 pm »
Sure, you can just hook an alligator lead up to it. Tin the end of a bit of wire and wrap it tight if you need.

I spend more time using a steel spring as a ground contact than a lead!

If you flip the switch on the right-hand probe to x10 it should read much higher. This is quite normal. (x10 is usually what you'll use anyway)
« Last Edit: March 26, 2017, 05:33:48 pm by Monkeh »
 

Offline Brumby

  • Supporter
  • ****
  • Posts: 8954
  • Country: au
Re: Scope probes have no ground connector!
« Reply #6 on: March 26, 2017, 05:33:56 pm »
Why would someone remove the clip? Are these of any use without it?

All you need is a reference point - and if the item you are checking is already connected to earth then you can often get away without a ground lead for non critical measurements.  Just remember you might be including a very big earth loop in your signal path.
 

Offline Brumby

  • Supporter
  • ****
  • Posts: 8954
  • Country: au
Re: Scope probes have no ground connector!
« Reply #7 on: March 26, 2017, 05:42:37 pm »
Mind you, at RF, distance matters and you will see approaches like this:

That coiled section near the fingertip is the earth connection.
 

Offline Atheus

  • Contributor
  • Posts: 47
  • Country: gb
Re: Scope probes have no ground connector!
« Reply #8 on: March 26, 2017, 06:08:20 pm »
How about these probes?

https://www.amazon.co.uk/Oscilloscope-Scope-Probes-Probe-100MHz/dp/B00GHIHW0K/

They don't specify compatibility with my scope but they fit the spec unless there's something I'm missing. BNC connectors and up to 100Mhz. Is there a reason to pay more for better scopes at this stage?

BTW what is P6100?

And (from specs) "Attenuation ratio: 1:10" - these are 'x10' probes then?
« Last Edit: March 26, 2017, 06:16:18 pm by Atheus »
 

Offline helius

  • Super Contributor
  • ***
  • Posts: 2829
  • Country: us
Re: Scope probes have no ground connector!
« Reply #9 on: March 26, 2017, 06:10:00 pm »
X1 scope probes are a fool's paradise: their performance is unbelievably poor. There are a few situations where they will work, but not many.

In OP's picture, both probes have ground ferrules around their tips. This is where the ground lead attaches, but they accept other connections, like spring clips.
« Last Edit: March 26, 2017, 06:23:42 pm by helius »
 

Offline T3sl4co1l

  • Super Contributor
  • ***
  • Posts: 13100
  • Country: us
  • Expert, Analog Electronics, PCB Layout, EMC
    • Seven Transistor Labs
Re: Scope probes have no ground connector!
« Reply #10 on: March 26, 2017, 06:27:00 pm »
Oh and I forgot to mention - there's another weirdness - the probe on the left measures 1M \$\Omega\$ end-to-end on the centre pin of the co-ax while the other only 0.5k \$\Omega\$... I thought all probes were high impedance?

Click the "X1/X10" switch. ;)

You need the ground clip to reference the probe to your circuit.  It clips into the shrouded slot near the handle.

You can also (or should be able to) slide off the shroud, exposing a coaxial tip, which can be used with high bandwidth / high precision test points as pictured above.

The scope should have a "PROBE COMP" or squarewave output somewhere on the front panel.  This is used to compensate your probe (search on that for info), and also serves as a reference to verify it's working.  (You don't need a ground clip to measure this signal, because it's already grounded to the scope.  Remember that the scope grounds are all common, and you cannot clip ground onto anything that's not also grounded!)

Tim
Seven Transistor Labs, LLC
Electronic design, from concept to prototype.
Bringing a project to life?  Send me a message!
 

Offline tggzzz

  • Super Contributor
  • ***
  • Posts: 9159
  • Country: gb
    • Having fun doing more, with less
Re: Scope probes have no ground connector!
« Reply #11 on: March 26, 2017, 07:15:05 pm »
If you are new to probes, then the references on
https://entertaininghacks.wordpress.com/library-2/scope-probe-reference-material/
will help.

Start by paying attention to the basic stuff, including types of probes and safety.
There are lies, damned lies, statistics - and ADC/DAC specs.
Glider pilot's aphorism: "there is no substitute for span". Retort: "There is a substitute: skill+imagination. But you can buy span".
Having fun doing more, with less
 

Offline alsetalokin4017

  • Super Contributor
  • ***
  • Posts: 1872
  • Country: us
Re: Scope probes have no ground connector!
« Reply #12 on: March 26, 2017, 10:23:44 pm »
This is what's missing.

But you may as well order a matched set of 1x-10x probes 100MHz from Ebay, they are inexpensive and will work perfectly with your scope, and will include everything you need.
The easiest person to fool is yourself. -- Richard Feynman
 

Offline tooki

  • Super Contributor
  • ***
  • Posts: 3740
  • Country: ch
Re: Scope probes have no ground connector!
« Reply #13 on: March 26, 2017, 11:18:57 pm »
I wouldn't replace that nice Hameg probe with a cheap Chinese one. Yes, the Chinese one will work fine. But the cable on better probes is so much softer and nicer to use!

So I'd just buy some ground clips.
 

Offline alsetalokin4017

  • Super Contributor
  • ***
  • Posts: 1872
  • Country: us
Re: Scope probes have no ground connector!
« Reply #14 on: March 26, 2017, 11:27:05 pm »
And these are available separately where?

He wants to _use_ the 60MHz scope, not sleep with it.
The easiest person to fool is yourself. -- Richard Feynman
 

Offline amspire

  • Super Contributor
  • ***
  • Posts: 3632
  • Country: au
Re: Scope probes have no ground connector!
« Reply #15 on: March 26, 2017, 11:34:51 pm »
I wouldn't replace that nice Hameg probe with a cheap Chinese one. Yes, the Chinese one will work fine. But the cable on better probes is so much softer and nicer to use!

So I'd just buy some ground clips.
Sure, keep the probes, but if a pair of identical 100MHz probes can be bought for $10 in total (see my link), doesn't it make sense to get them? Differential mode works much better on an analog scope to a digital one, but you do want two identical probes. Never hurts having spare probes for the times when you need to use the EXT input.

If the probe hook clip accessories are missing, then definitely get a new pair of probes.
 

Online Ian.M

  • Super Contributor
  • ***
  • Posts: 7759
Re: Scope probes have no ground connector!
« Reply #16 on: March 26, 2017, 11:43:34 pm »
You can probably form a ground clip to fit from some plated steel wire, then its just a 3" piece of flexible black wire, a croc-clip and a bit of heatshrink to make a nice job of it. That will make the Hameg probe usable.

Otherwise, as has just been pointed out, its got two input channels + Ext for external trigger (including trigger view) and X-Y mode, so to make full use of it you really need three probes.  I'd pick up a budget set of 100MHz x1/x10 switchable probes and keep the Hameg one as well.   If you get lucky, you may be able to find a spare sprung hook tip for the Hameg probe - its nice to be able to clip a probe on and leave it, especially when you have multiple waveforms to monitor.

N.B.  hook clips often aren't interchangable between different brands of probe.
 

Offline 2N3055

  • Super Contributor
  • ***
  • Posts: 1811
  • Country: hr
Re: Scope probes have no ground connector!
« Reply #17 on: March 27, 2017, 01:31:47 am »
 

Offline Atheus

  • Contributor
  • Posts: 47
  • Country: gb
Re: Scope probes have no ground connector!
« Reply #18 on: March 27, 2017, 01:41:56 pm »
Click the "X1/X10" switch. ;)

Ah! Thank you! 10 meg. Looks like I have a lot to learn...

You need the ground clip to reference the probe to your circuit.  It clips into the shrouded slot near the handle.

You can also (or should be able to) slide off the shroud, exposing a coaxial tip, which can be used with high bandwidth / high precision test points as pictured above.

... that much I do understand though :) - I was just wondering if there's any reason I can't wrap a wire round this outside co-ax connector (indeed revealed by removing the sheath) just for a once off test of the thing, or if the ground wires have component(s) in them like the co-ax side clearly does. Seems there shouldn't be a problem doing this.

I haven't yet plugged a probe in as I've not been confident enough. I think I will now though, and try something VERY simple.

The scope should have a "PROBE COMP" or squarewave output somewhere on the front panel.  This is used to compensate your probe (search on that for info), and also serves as a reference to verify it's working.  (You don't need a ground clip to measure this signal, because it's already grounded to the scope.  Remember that the scope grounds are all common, and you cannot clip ground onto anything that's not also grounded!)

Thank you again! I was not aware of this tiny tab in a sea of buttons. My primary objective right now is to see if it works properly - because I have nothing plugged in I have not yet seen the trace deflected in the Y direction apart from with the manual adjustment buttons (which only mean the CRT works).

Anyone who wants to know what the faceplate looks like just Google image search PM3055. Or for the extra lazy...

https://www.google.co.uk/search?q=pm3055&safe=off&source=lnms&tbm=isch&sa=X&ved=0ahUKEwis55u1zPXSAhVlDMAKHU3vB-UQ_AUICSgC&biw=1440&bih=776

... that little one on the left says "Cal 1.2V [squarewave sign*]" which must be the thing of which you speak. Just to be clear, I can plug a ground-less probe into the scope, and safely prod this tab to see a square wave on the CRT?

I'm trying to unravel that last sentence about grounding... does something special happen when I use this calibration tab? Or is it simply due to the scope itself being grounded?

The scope ground is obviously the wall/house ground, and lets just imagine I am testing another non-isolated device, also grounded - lets say to the very same power socket extension. The non-isolated component is common ground to the tab on the scope. Can I use a ground-less probe in this situation? If not why not? We would just be measuring relative to wall/house ground, rather than relative to whatever the ground probe would be connected to.

I am aware most of the devices I test WILL be isolated and I will need ground probes, however, just for a test, I'll try the calibration and once I'm sure it works I will continue my reading/watching about scopes and probes. Unfortunately the video stickied (while great and I will watch the whole thing) concentrates on older scopes which do not feature a digital "main time base" button etc.

I assume with your last sentence you're just telling me not to put current up the ground wire. Sounds sensible. But... 'you cannot clip ground onto anything that's not also grounded!'... really? Can't I just measure the difference between any two points on an isolated device like with a multimeter?

Cheers!

~Atheus

/edit: *why doesn't this forum have a square-wave sign? Is that TinyMCE you use for a text editor? You can definitely put extra buttons on TinyMCE. It'd have to be custom because there's no Unicode square wave. Two types of sine and a sawtooth but no square. Who knew.
« Last Edit: March 27, 2017, 01:45:49 pm by Atheus »
 

Offline Atheus

  • Contributor
  • Posts: 47
  • Country: gb
Re: Scope probes have no ground connector!
« Reply #19 on: March 27, 2017, 01:55:57 pm »
Re: alsetalokin4017: thanks for the pic! now I know what the other end looks like I have a chance of finding or making one.

Re: Ian.M: "You can probably form a ground clip to fit from some plated steel wire, then its just a 3" piece of flexible black wire, a croc-clip and a bit of heatshrink to make a nice job of it. That will make the Hameg probe usable."

Excellent. Thank you.

It looks like I have one "nice" probe and one average one. I did wonder because one is significantly sharper than the other. You could put a hole in someone with the Hameg (or measure a very small pin... whatever you're into). I won't buy more until I know a lot more. If it's once-in-a-decade buy then I'll go for quality. Not even sure about different types of triggering (yet!) but I'll probably follow your advice and get two cheap ones and keep the Hameg.

Thanks again,

~Atheus
« Last Edit: March 27, 2017, 02:00:02 pm by Atheus »
 

Offline Atheus

  • Contributor
  • Posts: 47
  • Country: gb
Re: Scope probes have no ground connector!
« Reply #20 on: March 27, 2017, 03:22:56 pm »
It works!!! :P



It's npt much, it's not even square, but it's a signal! My settings will just be way off. What a score for £50 shipped!
 
The following users thanked this post: tooki

Offline Brumby

  • Supporter
  • ****
  • Posts: 8954
  • Country: au
Re: Scope probes have no ground connector!
« Reply #21 on: March 27, 2017, 04:27:28 pm »
That's a good start!

I'd try a faster timebase, just one or two clicks, to stretch the X axis and increase the vertical sensitivity - again just one or two clicks - to stretch the Y axis.  This should give you a nicer display.

As for the signal not looking square - that might just be a matter of adjusting the compensation trimmer on the probe.  If that sorts out this little problem, you are indeed looking very good.
 

Offline alsetalokin4017

  • Super Contributor
  • ***
  • Posts: 1872
  • Country: us
Re: Scope probes have no ground connector!
« Reply #22 on: March 27, 2017, 05:30:08 pm »
1. The trace should go all the way across the screen horizontally no matter what the timebase (x axis) setting is. Try using the Horizontal Position control to move the trace rightwards and get the trace to fill the screen horizontally.

2. At this stage please _do not even consider_ probing the Mains with your scope. This can be dangerous to you and to the scope if you don't do it right, and even pros sometimes don't do this correctly. So ... don't.   Yes, you can probe "ungrounded" stuff like battery-powered DMMs or whatever as long as you provide a "ground" connection to the scope probe, using a clip or wire or whatever. Remember though that "all" the scope's BNC connector outer shields are grounded together and to the scope chassis and thus back to the mains cord ground pin... and thus back to everything else that is connected to your mains wiring ground circuit.

3. A complete probe set will include spring clips that slip over the probe sharp pointy tip and provide a means for grabbing onto small wires so you can do your probing "hands free". So please go ahead and order a pair of the inexpensive Chinese 100MHz probes.

For example: (not necessarily a recommendation just an example)

http://www.ebay.com/itm/2x-100MHz-Oscilloscope-Scope-analyzer-Clip-Probe-test-leads-kit-for-HP-Tektronix-/162220256702?hash=item25c514adbe:g:LgsAAOSwmLlX64uT

Note the accessories in the photos. Spring grabber clips, anti-shorting covers for probing IC pins, color-coded rings to identify probes, compensation adjustment screwdriver tool. Some probe kits will also include short spring groundpins and sometimes even BNC adapter sleeves for the probe tips.

Don't worry about the "for Tektronix" or other mfg. names used by the sellers. As long as they have a BNC connector on the scope end and are switchable 1x-10x and 100MHz rated they will be usable with any modern scope of low bandwidth like yours.
The easiest person to fool is yourself. -- Richard Feynman
 

Offline alsetalokin4017

  • Super Contributor
  • ***
  • Posts: 1872
  • Country: us
Re: Scope probes have no ground connector!
« Reply #23 on: March 27, 2017, 06:07:30 pm »
Quote
How about these probes?

https://www.amazon.co.uk/Oscilloscope-Scope-Probes-Probe-100MHz/dp/B00GHIHW0K/

They don't specify compatibility with my scope but they fit the spec unless there's something I'm missing. BNC connectors and up to 100Mhz. Is there a reason to pay more for better scopes at this stage?

BTW what is P6100?

And (from specs) "Attenuation ratio: 1:10" - these are 'x10' probes then?

Yes, those would be fine. Yes, they are compatible with your scope. No, there is no reason to pay more for better probes at this stage. P6100 is sort of a manufacturer's designation (following the Tektronix part number style) for this class of probes. Yes, these are switchable 1x-10x probes.

By shopping around you can find many vendors selling these or similar probe kits for this price or slightly higher. Some of the accessory kits may vary, some may have the compensation capacitor in the BNC connector and some may have it in the probe handle itself, but I think all of them probably come from the same factory or two in China.
The easiest person to fool is yourself. -- Richard Feynman
 

Online Ian.M

  • Super Contributor
  • ***
  • Posts: 7759
Re: Scope probes have no ground connector!
« Reply #24 on: March 27, 2017, 06:34:52 pm »
*MANDATORY* viewing before you attempt to probe anything that isn't either battery powered or fully floating.

The original discussion topic:
https://www.eevblog.com/forum/blog/eevblog-279-how-not-to-blow-up-your-oscilloscope!/
« Last Edit: March 27, 2017, 06:37:34 pm by Ian.M »
 
The following users thanked this post: tooki


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf