EEVblog > EEVblog Specific

EEVblog #411 - MiniPro TL866 Universal Programmer Review

<< < (394/396) > >>

Wiljan:
I have to read out a AM27C010 DIL32,

TL866II plus have it the list

When pressing Read in Xgpro version 10.90 win7 64bit it complains about Pin Detect Error small red X on all pins except 16 (Gnd) and 30 (NC)

it also complain about wrong ID.

When deselect pindetect and ID check and the read it does read but all FF ( I know the Eprom does work and have content)

If run a self check all is fine

If I put a data pin to gnd (without Eprom) and read it sowhe the right Hex data for the gnded pin

So what's wrong?

Bad_Driver:
I'm very late to this party but I found this topic by accident.
Earlier this year I bought after some advice from another topic a TL866A @ EvilBay - not knowing that this programmer is out of production for more than 3 years
and that there was the risk of counterfeit products.

Fortunately I got a NOS or very good counterfeit product and it has done the job I needed it for - reading out some old EPROMs with the last available software release after firmware successful upgrading and some reprogramming
of very old east german 2732. So far so good.

Than I tried to use it for reading out the code from a ANET A8 mainboard, I got the 3D printer used for less money but have no access to the used firmware.
Now I have to replace the main board (a analog input of the AT1284p seems to be dead) and I tried to dump it with the programmers ICSP port. The
board has a dedicated ICSP port! I double and tripple checked the cabling.
I bridged C22 to overcome the current protection warning but it doesn't work. After trying everything what I learned from this long topic I have to confess that I'm lost.

To get the hex dump for further reprogramming I bought a cheap 3€ USBasp programmer and with AVRDUDE (& AVRDUDESS - I prefer GUIs) the job was done in 5 minutes!

The USBasp stick powers the main board processor what is easy to see.

It assume that the TL866A  ICSP_Vcc supply doesn't work (yes - I crossed the field in the software). But I tried the printers PSU without the Vcc cable with the TL866A with no success as well.

Has someone experience with this kind of problem? Thanks for any advice!

Shock:
Since you suspect it's a power issue have you confirmed this?

You can check if you have an original or clone here, unlikely it being original.
http://www.autoelectric.cn/EN/note.html

Let us know the hardware and software version you are using. What does the software identify the programmer as? Have you performed the CS to A mod on it?

Take screenshots of the software screen before you read and show the results/errors after clicking the read icon. This will help let people know exactly what is occurring.

Wiljan:
Re. AM27C010 DIL32,

As I wrote I can't read it in the 866II+,

I took a scope and did measure the Vdd and it goes to 5V when the menu are set for read 5.0 V so far so good.

But if you measure on all the address pins the only swing between 0 and 3.3 V
The data pins swings between 2.5 and 5V (so it's never going real low)

If I change the menu to lets says read at 3.3V Vdd changes fine to 3.3V
The data pins swings between 0.8 and 3.3V  (so it's never going real low) AM27C010 is a 5V device

I had expected that the address pin had same swing depending as the Vdd and not just 0 - 3.3 always
The output might have the problem with wrong pull-up.

Any sugestions?



Wiljan:
Reading some 27C256 and 27C512 (Fairchild)  I have around does work correct in the 866II+
So when I assume the 27C010 is a OK chip it might not be even though I see it work in the CPU board were it belongs to.
Will investigate a bit more

Navigation

[0] Message Index

[#] Next page

[*] Previous page

There was an error while thanking
Thanking...
Go to full version