Author Topic: EEVblog #476 - Opamp Offset Voltage Measurement  (Read 17648 times)

0 Members and 1 Guest are viewing this topic.

Offline valentinc

  • Regular Contributor
  • *
  • Posts: 119
  • Country: ro
Re: EEVblog #476 - Opamp Offset Voltage Measurement
« Reply #25 on: June 01, 2013, 01:47:55 pm »
In an OP-AMP Application Handbook published by AD they a circuit for measuring offset voltage (attached). Perhaps bias current is the reason for inconsistency here because 1K resistor is only present at inverting input.
 


    I agree with this... Due to the bias currents (that are not zero) and the fact that the non-inverting input is tied directly to ground and the inverting one is tied to ground via a 1K resistor... The bias current + the current from the output (the amplified bias current that comes through the other 100K resistor makes the voltage at the inverting input be higher than that at the non-inverting input, hence you don't measure the real offset voltage, but the offset voltage plus that voltage drop across the 1K resistor...

    To measure the proper offset voltage you must bias the non-inverting and inverting input at the same potential (as in the pictures Alexei posted) ....

    And the current through the output stage of the op-amp probably varies with the supply voltage, and the higher the current through the feedback resistors, the higher the voltage drop...

   
« Last Edit: June 01, 2013, 01:57:08 pm by valentinc »
Valentin
 

Offline onlooker

  • Frequent Contributor
  • **
  • Posts: 385
Re: EEVblog #476 - Opamp Offset Voltage Measurement
« Reply #26 on: June 01, 2013, 02:41:40 pm »
Quote
I agree with this... Due to the bias currents (that are not zero) and the fact that the non-inverting input

I thought it was already mentioned, AD8628's bias current is <0.1nA, with Dave's test circuitry, the inference on the output voltage should be <0.01mV (~=0.1nA x 1kR x 100). That is, the bias/leak current can't explain the discrepancy in the order of ~>0.1mV.
 

Armageddon

  • Guest
Re: EEVblog #476 - Opamp Offset Voltage Measurement
« Reply #27 on: June 01, 2013, 02:52:05 pm »
I do not think that's the best way to measure the offset.
Anyway, it is clear that something is not right in the AD8628 @ 5V.
What do you think about figure 7 on page 6?

Why not ask to Analog Devices, to see what think?
« Last Edit: June 01, 2013, 03:11:00 pm by Armageddon »
 

Offline Alexei.Polkhanov

  • Frequent Contributor
  • **
  • Posts: 683
  • Country: ca
Re: EEVblog #476 - Opamp Offset Voltage Measurement
« Reply #28 on: June 01, 2013, 05:58:28 pm »
Ground needs to move to other side of R1, otherwise you are measuring the full gain of the opamp amplifying the voltage generated across the 1k resistor by the input bias current.
Ops, daaa, Friday night, all out of coffee.
Corrected version gives 95uV on output, which is higher than 480pV as in single supply, but not 0.330mV that was on video.





 

Offline Alexei.Polkhanov

  • Frequent Contributor
  • **
  • Posts: 683
  • Country: ca
Re: EEVblog #476 - Opamp Offset Voltage Measurement
« Reply #29 on: June 01, 2013, 06:40:38 pm »
I think I found one of possible solutions. On simulation (see picture below) I have negative supply -5V, while positive is +2.5V. It gives me +223uV on output.
I had similar problem when I was playing with data conditioning circuit for photodiodes. I eventually got triple output power supply that can make sure that positive and negative rails always match closely to each other regardless of load.
 

Offline Rufus

  • Super Contributor
  • ***
  • Posts: 2094
Re: EEVblog #476 - Opamp Offset Voltage Measurement
« Reply #30 on: June 01, 2013, 07:19:53 pm »
I think I found one of possible solutions. On simulation (see picture below) I have negative supply -5V, while positive is +2.5V. It gives me +223uV on output.

With an absolute maximum supply voltage specification of 6v running it on 7.5v isn't a possible solution.

Did running the simulation do any permanent damage to the AD8628 model?
 

Offline Alexei.Polkhanov

  • Frequent Contributor
  • **
  • Posts: 683
  • Country: ca
Re: EEVblog #476 - Opamp Offset Voltage Measurement
« Reply #31 on: June 01, 2013, 07:52:30 pm »
With an absolute maximum supply voltage specification of 6v running it on 7.5v isn't a possible solution.

Did running the simulation do any permanent damage to the AD8628 model?
Hahahaha, no, no smoke. If I make it +1.5/-3.5V to keep it within spec results are same.

 

Offline Big_Al

  • Contributor
  • Posts: 21
  • Country: gb
Re: EEVblog #476 - Opamp Offset Voltage Measurement
« Reply #32 on: June 02, 2013, 11:30:08 pm »
The circuit is oscillating man !
 Bang a cap across the 100k for compensation.  :)
 

Offline Alexei.Polkhanov

  • Frequent Contributor
  • **
  • Posts: 683
  • Country: ca
Re: EEVblog #476 - Opamp Offset Voltage Measurement
« Reply #33 on: June 03, 2013, 05:02:36 am »
The circuit is oscillating man !
 Bang a cap across the 100k for compensation.  :)
How do you know that? It certainly does not oscillate in simulation. I don't have any 8628 at hand unfortunately to try it out.
 

Offline envisionelec

  • Frequent Contributor
  • **
  • Posts: 269
  • Country: us
Re: EEVblog #476 - Opamp Offset Voltage Measurement
« Reply #34 on: June 03, 2013, 12:02:45 pm »
Parasitic thermocouples? At such low current, even the tiniest dissimilar metal junction would introduce an offset voltage.

Another possibility is that the resistors are self heating and producing flicker noise (pink distribution) whose charge injection interprets as an overall DC offset maybe due to heterodyning with the chopper frequency. Lower tc resistors would likely help for a quick test. One techique is to use an outer chopper with a frequency below the 1/f of the 'inner' chopper.

Possibly repair it with Kelvin connection.



« Last Edit: June 04, 2013, 01:09:01 am by envisionelec »
 

Offline Bored@Work

  • Super Contributor
  • ***
  • Posts: 3932
  • Country: 00
Re: EEVblog #476 - Opamp Offset Voltage Measurement
« Reply #35 on: June 06, 2013, 04:33:58 pm »
Dave, you can endlessly wank with your buddy Chris on the Amp Hour that it doesn't matter to use the wrong definition. Here is a hint for you. If you compare your measurements to data in the datasheet, it would be really clever to compare the same things, not apples and oranges.

And the right definition has nothing to do with academic correctness. Feeding in the offset voltage into the input is what you'd have to do if you care to compensate the offset. A very practical thing, building a voltage divider, adjustable over a small range, to feed into the input.

So whatever you will present in your next video, however you will bend your results until they match the value in the datasheet, you have shown nothing - except that you compare apples and oranges.
I delete PMs unread. If you have something to say, say it in public.
For all else: Profile->[Modify Profile]Buddies/Ignore List->Edit Ignore List
 

Offline IanB

  • Super Contributor
  • ***
  • Posts: 9681
  • Country: us
Re: EEVblog #476 - Opamp Offset Voltage Measurement
« Reply #36 on: June 07, 2013, 06:05:36 am »
By the end of the video I was definitely looking to see a 1 k resistor on the +ve input between pin 3 and ground. What difference does it make to the results if you insert such a resistor?

So apparently it does help a bit, but it's not the whole story...
I'm not an EE--what am I doing here?
 

Offline MaiMariarti

  • Newbie
  • Posts: 1
  • Country: ca
Re: EEVblog #476 - Opamp Offset Voltage Measurement
« Reply #37 on: December 29, 2019, 08:26:11 pm »
Did anyone find a solution to this? Is having an unbalanced dual supply the answer?
Was having no output load the problem (besides the high Z meter)? No solution from ADI?
I guess I won't pick this Op Amp and go with the MAX4239 until this problem is resolved.
If it has this problem, what other problems are there kinda thing...
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf