Author Topic: EEVblog #610 - Why Digital Scopes Appear Noisy - Part 2  (Read 18043 times)

0 Members and 1 Guest are viewing this topic.

Online EEVblog

  • Administrator
  • *****
  • Posts: 31246
  • Country: au
    • EEVblog
EEVblog #610 - Why Digital Scopes Appear Noisy - Part 2
« on: April 27, 2014, 11:10:24 am »
Why do digital oscilloscopes appear noisier than traditional analog oscilloscopes? PART 2
Learn how and why your digital storage oscilloscope display the noise that it does.
In this 2nd installment Dave shows how waveform update rate affects the apparent displayed noise of a waveform, and alters the waveform update rate on an Agilent DSOX3000 to show this.
Also, how sample rate and timebase settings affects the boxcar averaging high-resolution display function.
PART 1 is here:

 

Offline BravoV

  • Super Contributor
  • ***
  • Posts: 6767
  • Country: 00
  • +++ ATH1
Re: EEVblog #610 - Why Digital Scopes Appear Noisy - Part 2
« Reply #1 on: April 27, 2014, 01:51:33 pm »
What if "someday" an One Hung Low scope manucfacturer built a scope with really crappy and very noisy analog front end, or whatever highspeed ADC that was available at Shen Zhen market at that time which happened to have a really bad ADC input noise level, the question is how to tell ?

Or maybe, CMIIW here, these naugthy OHL scope manucfacturers can hide behind this video and use it as an excuse .... "Look !!! Even Dave said so, our scope is not noisy ! "  >:D
« Last Edit: April 27, 2014, 02:00:08 pm by BravoV »
 

Offline nitro2k01

  • Frequent Contributor
  • **
  • Posts: 844
  • Country: 00
Re: EEVblog #610 - Why Digital Scopes Appear Noisy - Part 2
« Reply #2 on: April 27, 2014, 02:29:29 pm »
Single trigger mode will give you a good idea. Also, another possibility, gradually adjusting the trigger level and counting the number of updates you get at the fringes of the noise floor.

Looking back at the previous video, I'm seeing a bunch of blips in the noise floor of the DS1052. (Or DS1102, ha! >:D ) I'm thinking those are ugly, and not simple part of the white noise. Sure, I appreciate the accidental honesty of the scope, but I'd rather they weren't there to begin with. Then again, you get what you pay for and all that.
Whoa! How the hell did Dave know that Bob is my uncle? Amazing!
 

Offline electronics man

  • Frequent Contributor
  • **
  • Posts: 686
  • Country: gb
Re: EEVblog #610 - Why Digital Scopes Appear Noisy - Part 2
« Reply #3 on: April 27, 2014, 02:33:53 pm »
Single trigger mode will give you a good idea. Also, another possibility, gradually adjusting the trigger level and counting the number of updates you get at the fringes of the noise floor.

Looking back at the previous video, I'm seeing a bunch of blips in the noise floor of the DS1052. (Or DS1102, ha! >:D ) I'm thinking those are ugly, and not simple part of the white noise. Sure, I appreciate the accidental honesty of the scope, but I'd rather they weren't there to begin with. Then again, you get what you pay for and all that.

That is just due to a bit "wobbling" because  these things are only 8bit so the nois is likely to be lower than that but you cannot really distinguish between that with an 8Bit ADC.
follow me on twitter @get_your_byte
 

Offline nitro2k01

  • Frequent Contributor
  • **
  • Posts: 844
  • Country: 00
Re: EEVblog #610 - Why Digital Scopes Appear Noisy - Part 2
« Reply #4 on: April 27, 2014, 02:55:13 pm »
Because of how they look, my guess would be a common mode noise problem, for example voltage spikes and insufficient decoupling. Would love to see what those would like in single trigger mode, and smaller timebase and V/div. Of course, I might just be wrong. If they are a real thing, this is of course just a problem with this scope, not digital scopes in general.
Whoa! How the hell did Dave know that Bob is my uncle? Amazing!
 

Offline David Hess

  • Super Contributor
  • ***
  • Posts: 10942
  • Country: us
  • DavidH
Re: EEVblog #610 - Why Digital Scopes Appear Noisy - Part 2
« Reply #5 on: April 27, 2014, 06:46:05 pm »
It is misleading to say that the noise changes with sample rate whether this is limited by record length or not.  Short of implementing an anti-aliasing filter linked to sample rate which some toy DSOs do or doing DSP-Fu like the averaging that high resolution mode uses, it remains the same.  The appearance of the display may change but that is misleading.

The RMS noise is equal to the standard deviation.  A subset of the acquisition record kept through decimation does not change the standard deviation so the RMS noise remains the same.  This is how sampling RMS voltmeters are able to operate into the GHz range while calculating the RMS noise via slow analog or digital computation.  As a practical matter, noise above the Nyquist frequency aliases into the band below the Nyquist frequency.
 

Offline KD0RC

  • Regular Contributor
  • *
  • Posts: 114
  • Country: us
Re: EEVblog #610 - Why Digital Scopes Appear Noisy - Part 2
« Reply #6 on: April 27, 2014, 08:01:31 pm »
Well, I tried to follow along using my DSO-X 2022A, but did not really get the same results.  Once I got down to around 100Hz, I could see the brighter center part of the trace (Intensity set to 50%) but the overall display noise did not decrease.  Is there something about the 2000 series vs. the 3000 series?  Or is the 2000 just inherently noisier? (I would not be surprised, given the price difference...)
 

Offline KD0RC

  • Regular Contributor
  • *
  • Posts: 114
  • Country: us
Re: EEVblog #610 - Why Digital Scopes Appear Noisy - Part 2
« Reply #7 on: April 27, 2014, 08:11:53 pm »
OK, I posted too soon...   I set the time base to 200ns/div and can now see the effect.

Thanks Dave, I really appreciate these VBLOGs - I would never have had a clue, and would likely join the masses in thinking that a digital scope is inherently noisier.
 

Offline Pehtoori

  • Contributor
  • Posts: 21
  • Country: 00
Re: EEVblog #610 - Why Digital Scopes Appear Noisy - Part 2
« Reply #8 on: April 28, 2014, 08:15:38 am »
Boy that Agilent is noisy :-DD
 

Offline digital

  • Contributor
  • Posts: 47
  • Country: au
Re: EEVblog #610 - Why Digital Scopes Appear Noisy - Part 2
« Reply #9 on: April 28, 2014, 09:15:07 am »
Good video Dave I hope that puts the old chestnut to rest.
 

Offline rf-design

  • Regular Contributor
  • *
  • Posts: 57
  • Country: de
Re: EEVblog #610 - Why Digital Scopes Appear Noisy - Part 2
« Reply #10 on: April 28, 2014, 12:36:30 pm »
At 11:45 I could recognize only about 4 different gray levels in the grading. Is that correct?

Is there some doc which state at which probability the gray level change?

I think it is an instrument where the gray level have some number. Like 10%-level1, 1%-level2 and so on.
 

Offline deweff

  • Newbie
  • Posts: 4
Re: EEVblog #610 - Why Digital Scopes Appear Noisy - Part 2
« Reply #11 on: April 28, 2014, 03:46:47 pm »
At 11:45 I could recognize only about 4 different gray levels in the grading. Is that correct?

Is there some doc which state at which probability the gray level change?

I think it is an instrument where the gray level have some number. Like 10%-level1, 1%-level2 and so on.

The InfiniiVision X-series scopes have far more than four colors for intensity grading.  I believe there are actually 128 intensity levels, but it may be hard to distinguish them all, especially on video.  Changing the intensity will effectively move the intensity bins up and down.  I think the most even spacing of bins occurs at 50% (default) intensity.

All oscilloscopes, analog and digital, have noise introduced by the scope.  For most users of scopes in this class of scopes, noise floor is not a main concern in deciding upon a scope.  All the options are probably good enough with noise, so the decision will come down to features and visualization.  When you get into the midrange and high end ($20k+) noise floor becomes much more important.  It is also important as you increase in bandwidth, because higher bandwidths require very serious analog front end design to keep noise down.  And if you are making measurements with that much bandwidth, you likely are very interested in signal integrity, ENOB etc.
 

Offline robrenz

  • Super Contributor
  • ***
  • Posts: 3035
  • Country: us
  • Real Machinist, Wannabe EE
Re: EEVblog #610 - Why Digital Scopes Appear Noisy - Part 2
« Reply #12 on: April 28, 2014, 05:13:08 pm »
Great video Dave!

If I understood these two videos, this is so far all a matter of what is visible on the display or not, independent of the actual PP Noise level of the analog front end. This is not addressing the actual analog front end noise level of a top end analog scope vs a top end digital scope.  An old 7A22 differential amp has 16µV or 0.1 div whichever is greater displayed noise at 10µV/div and upper BW limit of 1MHz. Can you BW limit the Agilent to 1MHz and see what the noise floor is for comparison?

Offline David Hess

  • Super Contributor
  • ***
  • Posts: 10942
  • Country: us
  • DavidH
Re: EEVblog #610 - Why Digital Scopes Appear Noisy - Part 2
« Reply #13 on: April 28, 2014, 08:45:05 pm »
Great video Dave!

If I understood these two videos, this is so far all a matter of what is visible on the display or not, independent of the actual PP Noise level of the analog front end. This is not addressing the actual analog front end noise level of a top end analog scope vs a top end digital scope.  An old 7A22 differential amp has 16µV or 0.1 div whichever is greater displayed noise at 10µV/div and upper BW limit of 1MHz. Can you BW limit the Agilent to 1MHz and see what the noise floor is for comparison?

I would not mind some real measurements of noise as well but the 7A22 is a special case without a common modern equivalent so I would only include it as a sanity check.  It is going to suffer from low frequency noise and drift much more than a higher bandwidth amplifier.

Noise should be limited by the front end amplifier and bandwidth.  Previous measurements I have made of good analog oscilloscopes have followed this pretty closely with the first stage contributing most of the noise.

I have noticed one thing though about DSOs though; if you take peak to peak noise to be 6 times the RMS noise, then my oldest DSOs seem to have about the same level of noise as the newest ones.  That makes my 2440 look pretty good despite its design having a reputation for being noisy.
 

Offline G0HZU

  • Super Contributor
  • ***
  • Posts: 2576
  • Country: gb
Re: EEVblog #610 - Why Digital Scopes Appear Noisy - Part 2
« Reply #14 on: April 28, 2014, 11:17:14 pm »
Sorry to be a neghead but I found these scope noise videos to be more annoying and misleading than anything.

I'm not even sure what the goal of the video is but the noise performance of a scope is set by the noise performance of the front end and the bandwidth. So I can't see how you can compare the traces just by setting the scope to the same settings and then making any claim about analogue vs digital.

If you want to show the differences between analogue and digital scopes wrt how they deal with noise (on the display) then why not deliberately inject a known noise source into the scope? This would provide more control over the comparison.

I have a wideband high level noise source here that goes out to 180MHz but I can also band limit it with external filters. If I do this with an old analogue scope I can see the Gaussian distribution of the noise really easily. I only have a crude old TDS2012 DSO here to compare with but it is just horrible to look at when looking at noise. The analogue scope is far more informative.

The Agilent scope trace in your video looks (cosmetically) horrible too when displaying noise. I'm not experienced enough with high end DSOs to say which is better (analogue or digital) but my TDS2012 is woeful at displaying noise because it can't show intensity gradation like my analogue scope can. I know the modern DSOs can show gradation but I've not tried injecting wideband noise into one yet.

Note: If you inject a very wideband noise source into an analogue scope the trace looks quite pretty because it shows a really clean 'fogging' effect and the fog slowly clears as you move away from the centre of the trace (as expected). It would be interesting to see how a decent DSO would cope.

We have some Tek 4000 series scopes at work I can try this on. Also we have some 6000 series Agilent scopes to compare how the trace looks.

Note: Noise can be your friend too which is why I have various noise sources here and I much prefer to look at noise on my old Tek 465 compared to the rather crude (and technically limited) TDS2012 :)
« Last Edit: April 28, 2014, 11:37:32 pm by G0HZU »
 

Offline G0HZU

  • Super Contributor
  • ***
  • Posts: 2576
  • Country: gb
Re: EEVblog #610 - Why Digital Scopes Appear Noisy - Part 2
« Reply #15 on: April 28, 2014, 11:34:51 pm »
Just to add...
If I inject the 50R noise source via a band limiting (64MHz) LPF into the 50R terminated Tek 465 and the TDS2012 they both show about the same basic 'fatness' to the display.

The big difference is that the TDS2012 DSO fails miserably to display anything remotely Gaussian about the noise and the Tek 465 analogue trace looks 'correct'. So the Tek totally kills the DSO for looking at noise because it provides a very pretty trace that shows the correct gradation across the trace.
 

Offline David Hess

  • Super Contributor
  • ***
  • Posts: 10942
  • Country: us
  • DavidH
Re: EEVblog #610 - Why Digital Scopes Appear Noisy - Part 2
« Reply #16 on: April 28, 2014, 11:56:55 pm »
You may find this interesting when thinking about noise on an oscilloscope.  I am including the TekScope articles mentioned in the video as an attachment.

Measuring RMS Noise with an Oscilloscope



« Last Edit: April 29, 2014, 12:02:39 am by David Hess »
 

Offline G0HZU

  • Super Contributor
  • ***
  • Posts: 2576
  • Country: gb
Re: EEVblog #610 - Why Digital Scopes Appear Noisy - Part 2
« Reply #17 on: April 29, 2014, 12:24:16 am »
Thanks :)

I've already seen this interesting video because I think it was you who linked me to it on another thread. I can't recall if I posted my response back then but after seeing the video I tried this method on my 465 with my noise source with remarkably good results. I did this some time ago.

It's late and I'm off to bed but I did just try measuring the noise floor performance of my 465 by using the rear panel channel 1 output.

I fed the rear output into a spectrum analyser with the scope set to 5mV/div and saw a flattish noise pedestal out to about 100MHz.
The noise measured -136dBm/Hz.  = -56dBm/100MHz = 354uV in 100MHz BW.

I then used a Marconi 2024 sig gen to inject 1mV rms at 10MHz into channel 1 (terminated in 50R) and saw a -30dBm cw signal on the analyser (=7.07mV) so the gain is about x7.

I need to process these numbers but I think it means the noise voltage (in 100MHz BW) on channel 1 on my 465 is about 354/7 = 50uV rms for the 100MHz BW. But I'm tired and my brain is fogging up... I'll recheck all the measurements tomorrow :)






« Last Edit: April 29, 2014, 12:28:39 am by G0HZU »
 

Online EEVblog

  • Administrator
  • *****
  • Posts: 31246
  • Country: au
    • EEVblog
Re: EEVblog #610 - Why Digital Scopes Appear Noisy - Part 2
« Reply #18 on: April 29, 2014, 01:04:05 am »
The big difference is that the TDS2012 DSO fails miserably to display anything remotely Gaussian about the noise and the Tek 465 analogue trace looks 'correct'. So the Tek totally kills the DSO for looking at noise because it provides a very pretty trace that shows the correct gradation across the trace.

That's because the TDS2012 does not have an intensity graded display like better DSO's do.
 

Online EEVblog

  • Administrator
  • *****
  • Posts: 31246
  • Country: au
    • EEVblog
Re: EEVblog #610 - Why Digital Scopes Appear Noisy - Part 2
« Reply #19 on: April 29, 2014, 01:10:12 am »
If you want to show the differences between analogue and digital scopes wrt how they deal with noise (on the display) then why not deliberately inject a known noise source into the scope? This would provide more control over the comparison.

I did that in the previous video.

Quote
The Agilent scope trace in your video looks (cosmetically) horrible too when displaying noise. I'm not experienced enough with high end DSOs to say which is better (analogue or digital) but my TDS2012 is woeful at displaying noise because it can't show intensity gradation like my analogue scope can.

That was the point of the 2nd video, the Agilent looks "horrible" because it is by far the fastest updating DSO on the market.

Quote
Note: If you inject a very wideband noise source into an analogue scope the trace looks quite pretty because it shows a really clean 'fogging' effect and the fog slowly clears as you move away from the centre of the trace (as expected). It would be interesting to see how a decent DSO would cope.

As I showed in the first video, the analog scope can be hiding that noise (or a real signal) from you because the beam is not on the phosphor long enough for it to be visible to your human eye at ambient light levels (hence my use of the camera). Now whether or not you deem this to be a good thing is entirely your own subjective opinion in your own circumstance. But as a sowed in an older third video, these analog scopes can have downsides.
 

Online EEVblog

  • Administrator
  • *****
  • Posts: 31246
  • Country: au
    • EEVblog
Re: EEVblog #610 - Why Digital Scopes Appear Noisy - Part 2
« Reply #20 on: April 29, 2014, 01:13:53 am »
I'm not even sure what the goal of the video is but the noise performance of a scope is set by the noise performance of the front end and the bandwidth.

The point is to show how analog and digital scopes differ in their ability to display signals, and in this case the perceived "noise" or thickness of the trace.
As I have shown, there are almost half a dozen intermixing things that effect how a digital scope ultimately displays that trace.
I think this is very useful stuff to know.
Sorry if you think they are annoying or misleading in some way (which perhaps they are, but it's not an easy subject to explain)
 

Offline David Hess

  • Super Contributor
  • ***
  • Posts: 10942
  • Country: us
  • DavidH
Re: EEVblog #610 - Why Digital Scopes Appear Noisy - Part 2
« Reply #21 on: April 29, 2014, 01:58:05 am »
Thanks :)

I've already seen this interesting video because I think it was you who linked me to it on another thread. I can't recall if I posted my response back then but after seeing the video I tried this method on my 465 with my noise source with remarkably good results. I did this some time ago.

I am guilty of linking it more than once here but previously there has not been much discussion.

I would like to see that noise measurement made on both an analog oscilloscope and several different modern DSOs which have a couple of ways to measure it directly without relying on the visual waveform rendition.  Two of my old DSOs should be able to do it but I lack a good test signal.

Quote
It's late and I'm off to bed but I did just try measuring the noise floor performance of my 465 by using the rear panel channel 1 output.

I fed the rear output into a spectrum analyser with the scope set to 5mV/div and saw a flattish noise pedestal out to about 100MHz.
The noise measured -136dBm/Hz.  = -56dBm/100MHz = 354uV in 100MHz BW.

I then used a Marconi 2024 sig gen to inject 1mV rms at 10MHz into channel 1 (terminated in 50R) and saw a -30dBm cw signal on the analyser (=7.07mV) so the gain is about x7.

I need to process these numbers but I think it means the noise voltage (in 100MHz BW) on channel 1 on my 465 is about 354/7 = 50uV rms for the 100MHz BW. But I'm tired and my brain is fogging up... I'll recheck all the measurements tomorrow :)

The rear vertical output does not necessarily match the bandwidth on Tektronix oscilloscopes (and it will be really slow if not terminated into 50 ohms) and it may only be roughly calibrated.  In addition, since the single ended rear vertical output signal is generated after the input signal is converted to a differential signal, it may suffer from excessive common mode noise.  My 7603 (just like in the video) had a problem with that until I made a design change to improve the common mode rejection of the conversion by more than 20 dB.

I like using the vertical output signal on my Tektronix 7000 mainframes so I can use my 7A22 and 7A13 differential vertical amplifiers with my DSOs.
 

Offline rf-design

  • Regular Contributor
  • *
  • Posts: 57
  • Country: de
Re: EEVblog #610 - Why Digital Scopes Appear Noisy - Part 2
« Reply #22 on: April 29, 2014, 09:41:26 am »

I would like to see that noise measurement made on both an analog oscilloscope and several different modern DSOs which have a couple of ways to measure it directly without relying on the visual waveform rendition.  Two of my old DSOs should be able to do it but I lack a good test signal.


"which have a couple of ways to measure it directly"

So you place a cursor somewhere and get a rms number or in second popup window the distribution?

Give me an example.
 

Offline David Hess

  • Super Contributor
  • ***
  • Posts: 10942
  • Country: us
  • DavidH
Re: EEVblog #610 - Why Digital Scopes Appear Noisy - Part 2
« Reply #23 on: April 29, 2014, 10:55:32 am »

I would like to see that noise measurement made on both an analog oscilloscope and several different modern DSOs which have a couple of ways to measure it directly without relying on the visual waveform rendition.  Two of my old DSOs should be able to do it but I lack a good test signal.


"which have a couple of ways to measure it directly"

So you place a cursor somewhere and get a rms number or in second popup window the distribution?

Give me an example.

Those two ways will work but would usually be applied over a window that could include the entire waveform record instead of multiple acquisition records with the measurement made at one point.

What would be interesting to see how they change depending on sample rate and record length since neither should except insofar as the total time acquired limits the low frequency noise which may or may not be significant depending on the source and noise bandwidth.  If you want to include noise at 0.1 Hz, then the acquisition has to be over at least 10 seconds.

My suspicion is that oscilloscopes that rely on post DSP processing to correct their frequency and phase response are going to have problems making this measurement accurately.  Anti-alias filtering is really going to screw it up.
 

Offline G0HZU

  • Super Contributor
  • ***
  • Posts: 2576
  • Country: gb
Re: EEVblog #610 - Why Digital Scopes Appear Noisy - Part 2
« Reply #24 on: April 29, 2014, 05:05:36 pm »
The rear vertical output does not necessarily match the bandwidth on Tektronix oscilloscopes (and it will be really slow if not terminated into 50 ohms) and it may only be roughly calibrated.  In addition, since the single ended rear vertical output signal is generated after the input signal is converted to a differential signal, it may suffer from excessive common mode noise.  My 7603 (just like in the video) had a problem with that until I made a design change to improve the common mode rejection of the conversion by more than 20 dB.

I like using the vertical output signal on my Tektronix 7000 mainframes so I can use my 7A22 and 7A13 differential vertical amplifiers with my DSOs.

On my 465 the rear CH1 output port appears to have a pretty flat response out to about 100MHz :) Both the noise floor and the signal response looks good to 100MHz. It isn't calibrated but I can use the analyser to calibrate its 'gain'. I can also use the analyser to measure the S/N ratio and therefore predict the front end noise figure when set to 5mV/div and driven from a 50R source.

Note: I'm terminating the output with the 50R input impedance of the spectrum analyser. Also, I found that selecting 20MHz BW on the front panel has no effect on the noise or signal response of the rear panel port because it is tapped off just before the part of the scope that limits the bandwidth to 20MHz when this feature is selected. So the bandwidth at the rear port can't be changed.

I don't know how much the rest of the scope path degrades the overall noise performance but the numbers suggest that the scope front end section has about a 20dB noise figure when set to 5mV/div. That seems pretty good to me.

« Last Edit: April 29, 2014, 05:07:56 pm by G0HZU »
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf