EEVblog > EEVblog Specific

EEVblog #978 - Keysight 1000X Hacking

<< < (185/185)

Tesla02:
Bad news: https://community.element14.com/members-area/personalblogs/b/gough-lui-s-blog/posts/keysight-sbe-follow-up-1-dso-noise-dmm-calibration-post-teardown-more


--- Quote ---DSO Hacking?
I think it’s probably no big secret that the Keysight Infiniivision oscilloscopes have long been the subject of various modifications and hacks to improve bandwidth and functionality. While this is definitely against the wishes of the manufacturer, it seems that individuals doing so have met various levels of success at their own risk.

As someone with a lot of scopes to choose from, I thought it would be interesting to see if the hacks documented for the 1000X series could be applied to the “related” EDUX1052G. The first thing to notice is that the new instruments seem to be Linux based, as opposed to the earlier Windows CE-based counterparts, so firmware/software hacks seem out of the question. Hardware hacks, however, still seem to be a possibility.

A quick search online turned up this post which listed the strapping IDs for this family. As an EDUX1052G, this unit would have an ID of 35. From the family, the logical “upgrade” would be to the DSOX202G which would unlock more memory and bandwidth up to 70MHz. A bit more looking around seemed to suggest the following strapping resistor configurations to be likely valid.

Tearing the unit apart again, I did identify the strapping resistors – although the ones on the board appeared to be a tenth the value listed on the posting. This is no issue, as they function as voltage dividers and only the ratio matters. It is just our luck that changing the 5 to a 3 just means swapping the top and bottom resistor of the second digit – which I managed to achieve.

After performing the modification and restarting, it seemed to have the increased bandwidth and memory, but retaining its original ID. However, it wasn’t entirely successful as the channel buttons and knobs for the math and regular channels did not function as expected, calling up other functions instead. Trying the button test feature, pressing all buttons, I was not able to activate those controls after the modification was done. I suspect this means that the front-panel matrix connection must be different between models despite having the same keypad layout, but I didn’t feel it worth the effort to try chasing that down. I suppose if one always uses the oscilloscope via the remote front-panel, that would be acceptable, but I just couldn’t see that happening for me.

In the end, I’d have to recommend that users don’t try this on their EDUX1052G. Not having a properly functioning front-panel interface is very frustrating, but furthermore, the whole procedure is quite involved and risks damaging the unit. The SMD resistors involved are very tiny – losing them or damaging them would make for a very bad day! Furthermore, the small bandwidth increase is very marginal, although the increased memory would be nice. In the end, I reverted the resistor configuration to the original and called it a day. There may have been a way to make it work … but frankly, I couldn’t be bothered to invest any more effort to try and track it down.
--- End quote ---

Anthocyanina:

--- Quote from: Bud on September 21, 2021, 03:32:10 pm ---Hacking into the WinCE shell:

The attached script allows to drop into the WinCE operating system shell. From there you can browse around and explore the application files/data, run external tools from USB to explore the Registry, run DOOM, etc. You can connect a keyboard or mouse to the USB port. This is more of a tool to satisfy your curiosity rather than anything for normal scope use.

This tool is based on an other fellow's work published earlier in this thread. My contribution was to wrap it in a script to make it simple to use.

--- End quote ---

To try and further explore the scope, I've tried this, but when i connect a mouse or keyboard, they don't work. Do they have to be plugged in at the same time as the usb drive? Thank you!

Bud:
I did not have or use a USB hub, it was likely i unplugged the USB drive after dropping to WinCE Shell and plugged the keyboard or mouse.

Anthocyanina:

--- Quote from: Bud on August 22, 2022, 09:10:49 pm ---I did not have or use a USB hub, it was likely i unplugged the USB drive after dropping to WinCE Shell and plugged the keyboard or mouse.

--- End quote ---

I've tried with two different keyboards, and neither is recognized. not even the lights. Any idea what might be happening? even booting normally and plugging the keyboards does't work

Navigation

[0] Message Index

[*] Previous page

There was an error while thanking
Thanking...
Go to full version