Author Topic: New web site!  (Read 57428 times)

0 Members and 1 Guest are viewing this topic.

Offline tggzzz

  • Super Contributor
  • ***
  • Posts: 10227
  • Country: gb
    • Having fun doing more, with less
Re: New web site!
« Reply #75 on: August 21, 2015, 07:07:11 am »
That "grille" pattern down the sides gave me a headache (literally :( ) within 15 seconds of seeing it. I had the same experience with the RS site. Fortunately both were easily removed using the AdBlock Plus "block image" feature. What's the source of the problem? Simple.

With real-world scenes the eyes move and focus so that images seen by each eye can be fused by the brain into a normal stereoscope image - and there is only a single eye position which allows that. If that isn't possible, the people have "double vision" that can sometimes be corrected by spectacles. I don't have such problems, and have been taking stereo pictures for, gulp, 31 years.

Where there is a repetitive "crystalline" image, there are many different eye positions that will allow the brain to mostly fuse the image, i.e. the eyes can lock onto adjacent repetitions of the pattern. Having your eyes pointing in different directions and the consequent subtle errors across the field of view is, unsurprisingly, extremely painful.

There are lies, damned lies, statistics - and ADC/DAC specs.
Glider pilot's aphorism: "there is no substitute for span". Retort: "There is a substitute: skill+imagination. But you can buy span".
Having fun doing more, with less
 

Online EEVblog

  • Administrator
  • *****
  • Posts: 30082
  • Country: au
    • EEVblog
Re: New web site!
« Reply #76 on: August 21, 2015, 07:13:14 am »
That "grille" pattern down the sides gave me a headache (literally :( ) within 15 seconds of seeing it.

Sorry, everyone seems to like it. I like it.
 

Online EEVblog

  • Administrator
  • *****
  • Posts: 30082
  • Country: au
    • EEVblog
Re: New web site!
« Reply #77 on: August 21, 2015, 07:14:45 am »
Windows Smartphone is also ok, I'm only missing your portrait / logo top left corner.

I have to tweak a few things I think for those new fangled smart phones, and Apple is special of course, have to upload a whole bunch of custom logo image sizes for that it seems.
 

Offline Muttley Snickers

  • Supporter
  • ****
  • Posts: 1999
  • Country: au
Re: New web site!
« Reply #78 on: August 21, 2015, 07:21:28 am »
I clicked on the reflow video from the new main site and it starts playing at 720p, then if I click the play on Youtube from that video it also is at 720p but if I take my normal route it plays at 360p, no big deal it is probably the way you intended. https://www.youtube.com/user/EEVblog/videos

And the find chips banner halfway down on the left has no bottom border or black infill , for me on both IE and Chrome it seems to freeze whilst loading yet everything else below it looks fine, only once did it load with the full border and black infill after a about a minute and a refresh didn't help.

It just loaded but after a refresh it failed again using current Chrome, picture below....... :-//
« Last Edit: August 21, 2015, 08:11:54 am by Muttley Snickers »
 

Offline alexanderbrevig

  • Frequent Contributor
  • **
  • Posts: 588
  • Country: no
  • Musician, programmer and EE hobbyist
    • alexanderbrevig.com
Re: New web site!
« Reply #79 on: August 21, 2015, 07:51:15 am »
It just loaded but after a refresh it failed again...... :-//

This my friend, is the infamous Heisenbug. Nasty bugs they are, they alter their behavior when one attempts to study them.

Offline dunkemhigh

  • Super Contributor
  • ***
  • Posts: 1492
Re: New web site!
« Reply #80 on: August 21, 2015, 08:21:58 am »
The horizontal scrollbar is back, thanks :)

But the page is fixed width (1045px). Can you revert it to dynamic, please?
 

Offline tggzzz

  • Super Contributor
  • ***
  • Posts: 10227
  • Country: gb
    • Having fun doing more, with less
Re: New web site!
« Reply #81 on: August 21, 2015, 08:36:33 am »
That "grille" pattern down the sides gave me a headache (literally :( ) within 15 seconds of seeing it.

Sorry, everyone seems to like it. I like it.

Clearly a false statement!

If you allowed you readers to choose the width that suited their display (as opposed to the site designers arrogantly defining that "what works for the designers will work for everybody"), then the problem would evaporate.

"Just say no to fixed width web pages"
There are lies, damned lies, statistics - and ADC/DAC specs.
Glider pilot's aphorism: "there is no substitute for span". Retort: "There is a substitute: skill+imagination. But you can buy span".
Having fun doing more, with less
 

Online EEVblog

  • Administrator
  • *****
  • Posts: 30082
  • Country: au
    • EEVblog
Re: New web site!
« Reply #82 on: August 21, 2015, 08:43:05 am »
But the page is fixed width (1045px). Can you revert it to dynamic, please?

My website has never been dynamic size, always fixed.
 

Online EEVblog

  • Administrator
  • *****
  • Posts: 30082
  • Country: au
    • EEVblog
Re: New web site!
« Reply #83 on: August 21, 2015, 08:44:38 am »
If you allowed you readers to choose the width that suited their display (as opposed to the site designers arrogantly defining that "what works for the designers will work for everybody"), then the problem would evaporate.

And create other problems.
Fixed width works well on blog based wordpress sites like mine.
That's how it's been for 6 years, and that's how it's staying I'm afraid.
 

Online EEVblog

  • Administrator
  • *****
  • Posts: 30082
  • Country: au
    • EEVblog
Re: New web site!
« Reply #84 on: August 21, 2015, 08:45:11 am »
So no comments at all on the speed improvement?
If not then I will presume it's fixed.
 

Online PA0PBZ

  • Super Contributor
  • ***
  • Posts: 4151
  • Country: nl
Re: New web site!
« Reply #85 on: August 21, 2015, 08:47:21 am »
So no comments at all on the speed improvement?

Looks fine from here now Dave.

Edit: And from Sydney http://www.webpagetest.org/result/150821_7C_F2H/
« Last Edit: August 21, 2015, 08:58:26 am by PA0PBZ »
Keyboard error: Press F1 to continue.
 

Online Andy Watson

  • Super Contributor
  • ***
  • Posts: 1718
Re: New web site!
« Reply #86 on: August 21, 2015, 10:03:25 am »
So no comments at all on the speed improvement?
Huge improvement.
 

Offline dunkemhigh

  • Super Contributor
  • ***
  • Posts: 1492
Re: New web site!
« Reply #87 on: August 21, 2015, 02:15:43 pm »
But the page is fixed width (1045px). Can you revert it to dynamic, please?

My website has never been dynamic size, always fixed.

Sure, but with the previous version it didn't seem to matter because the essential stuff, as opposed to the advertising stuff, was slim on the left.
 

Offline dunkemhigh

  • Super Contributor
  • ***
  • Posts: 1492
Re: New web site!
« Reply #88 on: August 21, 2015, 02:20:21 pm »
Not the web site per se but thr forum - has something changed there? When I click on the email notifications now I get sent to the right page but not the right position in the page. Could the cookie stuff have been affected by the new website?
 

Offline Rasz

  • Super Contributor
  • ***
  • Posts: 2290
  • Country: 00
    • My random blog.
Re: New web site!
« Reply #89 on: August 21, 2015, 03:02:48 pm »
Please get rid of the smooth scrolling.

I see no issues with the scrolling  :-//

imagine using a scope with smooth scrolling  :o

its a lot better today, you could even call it usable  :-+
css is still a mess (euphemism for garbage, but I try to be positive :P)
look at this file for example
http://www.eevblog.com/wp-content/plugins/bws-popular-posts/css/style.css

3 styles 250 bytes, but it adds another three way handshake and delays page load. Your site still loads FOURTEEN different stylesheets + inline CSS. 700 KB in CSS alone.

Code: [Select]
http://www.eevblog.com/wp-content/plugins/sociable/css/sociable.css
http://www.eevblog.com/wp-content/plugins/bws-popular-posts/css/style.css
http://www.eevblog.com/wp-content/plugins/contact-form-7/includes/css/styles.css
http://www.eevblog.com/wp-content/plugins/mobile-navigation/css/generated.css
http://www.eevblog.com/wp-content/plugins/simple-follow-me-social-buttons-widget/assets/css/style.css
http://www.eevblog.com/wp-content/plugins/simple-follow-me-social-buttons-widget/assets/css/icons.css
http://www.eevblog.com/wp-content/plugins/social-media-widget/social_widget.css
http://www.eevblog.com/wp-content/themes/sahifa/style.css
http://www.eevblog.com/wp-content/themes/newtonsChild/style.css
http://www.eevblog.com/wp-content/themes/sahifa/css/woocommerce.css
http://www.eevblog.com/wp-content/themes/sahifa/css/ilightbox/dark-skin/skin.css
http://www.eevblog.com/wp-content/plugins/jetpack/modules/widgets/image-widget/style.css
http://www.eevblog.com/wp-content/plugins/jetpack/css/jetpack.css
http://www.eevblog.com/wp-content/plugins/podpress/style/podpress.css

Then you have 'clever optimisations' like svg and FONT icons, except they are heavier than traditional gif icons because of base64 encoding  :palm:, >200 KB in icons alone, and instead of loading only a couple of ones you actually use your page forces loading ALL of them EVERY TIME ...


then there is js, size total 2.26 MB. javascript files blocking the rendering:
Code: [Select]
http://www.eevblog.com/.. /1pixelout_audio-player.js
http://www.eevblog.com/wp-content/plugins/sociable/js/sociable.js
http://www.eevblog.com/wp-content/plugins/sociable/js/vuible.js
http://www.eevblog.com/.. /addtofavorites.js
http://www.eevblog.com/.. /front-widget.js
http://www.eevblog.com/wp-content/plugins/podpress/js/podpress.js


Cache expiry on most of the stuff set to 4 hours, means everyone downloads it every day every couple of hours.

The way HTTP intertubes* work:
device says 'hey'
-latency between the server and the client-
server says 'hey to you too'
-latency between the server and the client-
device says 'oh hey to your hey'
-latency between the server and the client-
device finally says 'give me goatpron.mp4'

this happens for every single separate file you fetch from the server. That is three times the latency between device and the server per file before even touching the file. Obviously caching helps, but it still adds up.


Its better today, page starts to render after 1.5-3 seconds, it could still be better.








* there are hacks aimed at mitigating this like spdy or http/2, but they suck in other ways


edit: search still doenst work, some weird/stupid plugin returns 404
« Last Edit: August 21, 2015, 03:09:12 pm by Rasz »
Who logs in to gdm? Not I, said the duck.
My fireplace is on fire, but in all the wrong places.
 

Offline gmb42

  • Regular Contributor
  • *
  • Posts: 174
  • Country: gb
Re: New web site!
« Reply #90 on: August 21, 2015, 05:04:13 pm »
this happens for every single separate file you fetch from the server. That is three times the latency between device and the server per file before even touching the file. Obviously caching helps, but it still adds up.

Doesn't your browser support  HTTP Keep Alive and Pipelining?

Both IE (11) and Chrome does, and loading the page uses 10 connections per full page reload, not one per file.
 

Offline German_EE

  • Super Contributor
  • ***
  • Posts: 2302
  • Country: de
Re: New web site!
« Reply #91 on: August 21, 2015, 06:04:18 pm »
The speed issues for me are now fixed and I have a load time of somewhere between two and three seconds. A few MINOR cosmetic tweaks remain:

1) At the top of the page the Home button with the house icon is a little too tall and it overlaps by about 2mm on to the black area.

2) On the same line 'About' is hidden behind the search box depending on the zoom level.

3) In the bottom section 'Buy anything on Amazon & Dave gets 7%' has the text offset to the right by about 1cm.

No problems with the grill background (and I'm normally sensitive to this sort of thing as I have double vision corrected by spectacles).
Should you find yourself in a chronically leaking boat, energy devoted to changing vessels is likely to be more productive than energy devoted to patching leaks.

Warren Buffett
 

Offline c4757p

  • Super Contributor
  • ***
  • Posts: 7805
  • Country: us
  • adieu
Re: New web site!
« Reply #92 on: August 21, 2015, 06:36:03 pm »
then there is js, size total 2.26 MB.

Jesus Christ. JavaScript is text. Do you know how long you have to type to accumulate 2.26 MB of text?* That's just ridiculous. I thought Dave didn't like silly wanky crap that doesn't add anything useful. <voice type="Dave">Maaaaaaaarketing...</voice>

I don't even want to know how much longer it'd take me to load the page if AdBlock wasn't blocking fourteen external items.

Gah... it looks good, I'll give 'em that. I like the general style. They just seem to be impressively unskilled at the actual implementation part. They're decent designers, but they need to hire someone who knows which end of the keyboard goes up.


*I type about 100wpm on average - that's "standard" wpm where a word = 5 characters. It'd take me 284 ks = 78 hours to type it. Seriously?
No longer active here - try the IRC channel if you just can't be without me :)
 

Offline Laertes

  • Regular Contributor
  • *
  • Posts: 58
  • Country: de
Re: New web site!
« Reply #93 on: August 21, 2015, 06:53:33 pm »
Hmm... I like the design.
Though I do agree that your blueish logo doesn't really fit in there, sorry. Maybe do the change to orange(which I like very much) or maye go to a graphite-like color like your background grille(which I like as well, btw.)

One other thing: I believe(darn, I'm not even sure anymore) that the old site had your little "Spoiler links" always showing immediately on the front page. This way, to go to the forum post for a video, it's just one click and one new page load. Now, it's two clicks and two page loads. If you could get at least the forum link back to the frontpage, I'd appreciate it very much.

Speed is perfectly acceptable for me in Germany, both on Android via Mobile Internet and on my Desktop.

All in all:  :-+
 

Offline mamalala

  • Supporter
  • ****
  • Posts: 777
  • Country: de
Re: New web site!
« Reply #94 on: August 21, 2015, 07:24:38 pm »
I don't even want to know how much longer it'd take me to load the page if AdBlock wasn't blocking fourteen external items.

Gah... it looks good, I'll give 'em that. I like the general style. They just seem to be impressively unskilled at the actual implementation part. They're decent designers, but they need to hire someone who knows which end of the keyboard goes up.

For added fun, use Ghostery, NoScript and PrivacyBadger as well. The site immediately becomes unusable, even if you allow scripts from the eevblog domain itself. Ghostery discards 8 nasty trackers, NoScript blocks JS from 12 additional external sites, and PrivacyBadger  drops 9 additional cookies from external sites.

All in all, the new site is a job well done to make it utterly unusable for people that care a bit about their security and privacy.

Greetings,

Chris
 

Offline Rasz

  • Super Contributor
  • ***
  • Posts: 2290
  • Country: 00
    • My random blog.
Re: New web site!
« Reply #95 on: August 21, 2015, 07:41:31 pm »
Both IE (11) and Chrome does, and loading the page uses 10 connections per full page reload, not one per file.

10 connections, ~140 separate objects

HTTP Keep Alive and Pipelining?

sorted by number of objects:
Code: [Select]
eevblog.com
ads.supplyframe.com
pagead2.googlesyndication.com
fls-na.amazon-adsystem.com
pixel.mathtag.com
images.ads.supplyframe.com
s.gravatar.com
tpc.googlesyndication.com
apis.google.com
search.supplyframe.com
analytics.supplyframe.com
media.supplyframe.com
cm.g.doubleclick.net
google-analytics.com
ssl.google-analytics.com
cdn.flashtalking.com
googleads.g.doubleclick.net
z-na.amazon-adsystem.com
aax-us-east.amazon-adsystem.com
paypal.com
fonts.gstatic.com
s0.wp.com
cdnjs.cloudflare.com
servedby.flashtalking.com
keysight.com
stats.wp.com
ad.doubleclick.net
eevblog.disqus.com
a.disquscdn.com
paxinstruments.com
pixel.wp.com
cse.google.com
fonts.googleapis.com
picotech.com
google.com
ajax.googleapis.com
ak1s.abmr.net
saelig.com

43 Bytes 1 pixel spying beacon from paypal.com is one of my fav
btw 1/4 of site size comes from ONE saelig banner :bullshit:
Who logs in to gdm? Not I, said the duck.
My fireplace is on fire, but in all the wrong places.
 

Offline dunkemhigh

  • Super Contributor
  • ***
  • Posts: 1492
Re: New web site!
« Reply #96 on: August 21, 2015, 07:49:03 pm »
WTF! I just typed in a LONG message explaining exactly what's wrong, clicked browse to attach screen caps, and the bloody message was GONE. The forum has changed, and not for the good :(

To recap (and I'm typing this once only - if it goes again it's too much hassle to help you out):

The three screencaps are:

Max - browser maxed.
Min-left - browser not-maxed as normal
min-right - min-left scrolled to the right

You can spot the problem with the youtube windows, particularly give the top one is playing. The old site never did that.

Next, on clicking 'new' in the forum I go to the right page, but always at the top. It's a drap scolling down trying to find the first new post, particularly on a busy thread. I'm losing the will to keep doing that.

Next, clicking the attached picture to a post used to make the picture bigger, but now just pops it  up on a blank page. The old way was better because you could read the message and see the other pictures at the same time you looked at the big one, but now it is view the picture OR read the text OR see another picture.

Some of this may be caused by the need to let google run its scripts: gstatic maybe? Cloudflare? (no, it seems to be Supplyframe) Makes no difference to me: the blighters are blocked and it is too much hassle temporarily allowing them on here just to make your now broken site work like it used to. No way are they going to be allowed a perma-unblock (which on earth do you think I use noscript and the like).
 

Online EEVblog

  • Administrator
  • *****
  • Posts: 30082
  • Country: au
    • EEVblog
Re: New web site!
« Reply #97 on: August 21, 2015, 10:35:27 pm »
WTF! I just typed in a LONG message explaining exactly what's wrong, clicked browse to attach screen caps, and the bloody message was GONE. The forum has changed, and not for the good :(

The forum has not changed in any way.
 

Online EEVblog

  • Administrator
  • *****
  • Posts: 30082
  • Country: au
    • EEVblog
Re: New web site!
« Reply #98 on: August 21, 2015, 10:38:30 pm »
But the page is fixed width (1045px). Can you revert it to dynamic, please?
My website has never been dynamic size, always fixed.
Sure, but with the previous version it didn't seem to matter because the essential stuff, as opposed to the advertising stuff, was slim on the left.

The ads are exactly the same size in exactly the same location as before  :-//
 

Online EEVblog

  • Administrator
  • *****
  • Posts: 30082
  • Country: au
    • EEVblog
Re: New web site!
« Reply #99 on: August 21, 2015, 10:42:30 pm »
43 Bytes 1 pixel spying beacon from paypal.com is one of my fav
btw 1/4 of site size comes from ONE saelig banner :bullshit:

The Saelig banner has not changed, same as before, no one ever noticed it nor complained about it.
And it's only 84KB. Where do you get 1/4 of the site size from?  :-//
« Last Edit: August 21, 2015, 10:52:20 pm by EEVblog »
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf