Author Topic: not receiving email notifications from this board - anyone else?  (Read 2554 times)

0 Members and 1 Guest are viewing this topic.

nemail

  • Guest
Hi there

I didn't ever receive ANY e-mail notifications about new posts to my topics from this forum at all.
Anyone else experiencing this issue?

I'm quite confident that the issue is not on my side, as I am a sysadmin and therefore I SHOULD know what I'm doing ;)
I have full control over my whole email system and I have checked the logs of my inbound smtp gateways (which are the mx records for my domain) and there is NO connection attempt from any IP address at the time where the notification should have been delivered.

I wonder if there is any chance checking the eevblog forum outbound smtp logs to maybe find the "black holes" where the messages are being lost.

I'd love to participate more on this forum but not getting notifications is kind of a show stopper for me..

thanks!
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 15659
  • Country: nz
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: not receiving email notifications from this board - anyone else?
« Reply #1 on: August 25, 2018, 09:43:39 am »
I know of others having problems and it may have started after Dave and gnif shifted to another host for the forum.

Maybe rather than in this board you can shift this thread to:
https://www.eevblog.com/forum/blog/ (EEVblog Specific)

You have a 'Move Topic' button at the foot of this page so you can place it there where Dave is more likely to spot it.
Avid Rabid Hobbyist
 

nemail

  • Guest
Re: not receiving email notifications from this board - anyone else?
« Reply #2 on: August 25, 2018, 07:04:52 pm »
Thanks!

@Dave: if you read this, I am willing to help you/your sysadmin to track this one down, if you need any help with this.
 

Online rstofer

  • Super Contributor
  • ***
  • Posts: 6232
  • Country: us
  • Country: us
Re: not receiving email notifications from this board - anyone else?
« Reply #3 on: August 25, 2018, 07:10:37 pm »
If there is a problem, it must be pretty recent.  I exchanged PMs with a forum member and I did receive email notifications.  This was around August 16
 

Online PA0PBZ

  • Super Contributor
  • ***
  • Posts: 4030
  • Country: nl
  • Country: nl
Re: not receiving email notifications from this board - anyone else?
« Reply #4 on: August 25, 2018, 07:12:52 pm »
Risking to kick in an open door here, but I don't think these notifications are on as default, have a look here:

https://www.eevblog.com/forum/profile/?area=notification;u=139974
Keyboard error: Press F1 to continue.
 

nemail

  • Guest
Re: not receiving email notifications from this board - anyone else?
« Reply #5 on: August 25, 2018, 07:13:51 pm »
If there is a problem, it must be pretty recent.  I exchanged PMs with a forum member and I did receive email notifications.  This was around August 16

obviously this does only happen to very few members. probably some weird international routing issue or some stupid spamfilter.

i have this issue since day one of my registration. i wonder how i got my account activated, though. mayvmbe it started shortly after my registration. can' remember exactly as it has been quite a while.
 

nemail

  • Guest
Re: not receiving email notifications from this board - anyone else?
« Reply #6 on: August 25, 2018, 07:15:10 pm »
Risking to kick in an open door here, but I don't think these notifications are on as default, have a look here:

https://www.eevblog.com/forum/profile/?area=notification;u=139974

nah, all turned on.. but thanks anyway
 

Online rstofer

  • Super Contributor
  • ***
  • Posts: 6232
  • Country: us
  • Country: us
Re: not receiving email notifications from this board - anyone else?
« Reply #7 on: August 25, 2018, 08:07:26 pm »
Have you tried sending a message to yourself?
I just did it and it arrived before I could swap to my email handler.  Practically instant delivery of the notification.
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 15659
  • Country: nz
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: not receiving email notifications from this board - anyone else?
« Reply #8 on: August 25, 2018, 09:09:37 pm »
Have you tried sending a message to yourself?
I just did it and it arrived before I could swap to my email handler.  Practically instant delivery of the notification.
It's not about PM's, they work fine.

Email notifications of replies is threads is the issue and they're set up using Notify at the foot of the page.
I haven't used it myself as 'View Replies' at the head of the page suits my needs.
Avid Rabid Hobbyist
 

Online rstofer

  • Super Contributor
  • ***
  • Posts: 6232
  • Country: us
  • Country: us
Re: not receiving email notifications from this board - anyone else?
« Reply #9 on: August 25, 2018, 10:19:25 pm »
Have you tried sending a message to yourself?
I just did it and it arrived before I could swap to my email handler.  Practically instant delivery of the notification.
It's not about PM's, they work fine.

Email notifications of replies is threads is the issue and they're set up using Notify at the foot of the page.
I haven't used it myself as 'View Replies' at the head of the page suits my needs.

I thought we were talking about the notifications that come by email to alert the member to a forum message.  My bad...

I have never used the thread notification feature.
 

Online rstofer

  • Super Contributor
  • ***
  • Posts: 6232
  • Country: us
  • Country: us
Re: not receiving email notifications from this board - anyone else?
« Reply #10 on: August 25, 2018, 10:20:43 pm »
So I thought I would turn Notify on and post another reply.  We'll see...

Yes!  It works...  Not as fast coming in as the previous test but it got here in a couple of minutes.
« Last Edit: August 25, 2018, 10:23:32 pm by rstofer »
 

nemail

  • Guest
Re: not receiving email notifications from this board - anyone else?
« Reply #11 on: August 25, 2018, 10:21:18 pm »
Have you tried sending a message to yourself?
I just did it and it arrived before I could swap to my email handler.  Practically instant delivery of the notification.
It's not about PM's, they work fine.

Email notifications of replies is threads is the issue and they're set up using Notify at the foot of the page.
I haven't used it myself as 'View Replies' at the head of the page suits my needs.

tried it anyway - no notification for the PM either...
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 15659
  • Country: nz
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: not receiving email notifications from this board - anyone else?
« Reply #12 on: August 25, 2018, 10:29:28 pm »
Have you tried sending a message to yourself?
I just did it and it arrived before I could swap to my email handler.  Practically instant delivery of the notification.
It's not about PM's, they work fine.

Email notifications of replies is threads is the issue and they're set up using Notify at the foot of the page.
I haven't used it myself as 'View Replies' at the head of the page suits my needs.

I thought we were talking about the notifications that come by email to alert the member to a forum message.  My bad...

I have never used the thread notification feature.
It's useful for those that don't frequent the forum much but have say threads that offer discounts, support and the like.
It really needs gnif to setup a new member and check that it's all working properly in both threads not posted in and to notification of reply to one's own posts/threads.

A lot of members have an email icon below our profiles (I don't) but are those links functioning as they should ?
They don't seem to.  :-//
Avid Rabid Hobbyist
 

Online rstofer

  • Super Contributor
  • ***
  • Posts: 6232
  • Country: us
  • Country: us
Re: not receiving email notifications from this board - anyone else?
« Reply #13 on: August 25, 2018, 10:37:40 pm »
Have you tried sending a message to yourself?
I just did it and it arrived before I could swap to my email handler.  Practically instant delivery of the notification.
It's not about PM's, they work fine.

Email notifications of replies is threads is the issue and they're set up using Notify at the foot of the page.
I haven't used it myself as 'View Replies' at the head of the page suits my needs.

I thought we were talking about the notifications that come by email to alert the member to a forum message.  My bad...

I have never used the thread notification feature.
It's useful for those that don't frequent the forum much but have say threads that offer discounts, support and the like.
It really needs gnif to setup a new member and check that it's all working properly in both threads not posted in and to notification of reply to one's own posts/threads.

A lot of members have an email icon below our profiles (I don't) but are those links functioning as they should ?
They don't seem to.  :-//

Well, thread and PM notifications work for me and I have been around here for awhile.  Not a long-timer like most but a couple of years, I suppose.  Certainly from before the server switch a few months back.

I went into my Profile and verified my email address but it would have to have been correct and it was.

Some members don't allow direct email as a Profile option.  I don't.  I get an email notification that a PM is available but I have to come to the site to read it.
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 15659
  • Country: nz
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: not receiving email notifications from this board - anyone else?
« Reply #14 on: August 25, 2018, 10:44:03 pm »
Have you tried sending a message to yourself?
I just did it and it arrived before I could swap to my email handler.  Practically instant delivery of the notification.
It's not about PM's, they work fine.

Email notifications of replies is threads is the issue and they're set up using Notify at the foot of the page.
I haven't used it myself as 'View Replies' at the head of the page suits my needs.

I thought we were talking about the notifications that come by email to alert the member to a forum message.  My bad...

I have never used the thread notification feature.
It's useful for those that don't frequent the forum much but have say threads that offer discounts, support and the like.
It really needs gnif to setup a new member and check that it's all working properly in both threads not posted in and to notification of reply to one's own posts/threads.

A lot of members have an email icon below our profiles (I don't) but are those links functioning as they should ?
They don't seem to.  :-//

Well, thread and PM notifications work for me and I have been around here for awhile.  Not a long-timer like most but a couple of years, I suppose.  Certainly from before the server switch a few months back.

I went into my Profile and verified my email address but it would have to have been correct and it was.

Some members don't allow direct email as a Profile option.  I don't.  I get an email notification that a PM is available but I have to come to the site to read it.
Yeah there's a few things that maybe could have impacted on this functionality but interesting yours seems to work fine. Thanks for checking.  :-+
I know of a couple of others that are having the same issue as nemail whereas once Notify worked fine for them.

nemail, can you get PM's ?
Avid Rabid Hobbyist
 

nemail

  • Guest
Re: not receiving email notifications from this board - anyone else?
« Reply #15 on: August 25, 2018, 11:25:57 pm »
nemail, can you get PM's ?

you mean e-mail notifications for PMs? No.
I do get PMs within the forum (if i log in to the website, I mean), however.
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 15659
  • Country: nz
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: not receiving email notifications from this board - anyone else?
« Reply #16 on: August 25, 2018, 11:32:39 pm »
nemail, can you get PM's ?

you mean e-mail notifications for PMs? No.
I do get PMs within the forum (if i log in to the website, I mean), however.
OK, so something for you is broken as you should get an email advising you that you have a PM.
Double check your account settings and the various switches/tick-boxes within.
Avid Rabid Hobbyist
 

nemail

  • Guest
Re: not receiving email notifications from this board - anyone else?
« Reply #17 on: August 26, 2018, 12:02:56 am »
i agree, something is broken here.

attached you'll find my settings. dunno what possibly could be wrong there...
 

Online tautech

  • Super Contributor
  • ***
  • Posts: 15659
  • Country: nz
  • Country: nz
  • Taupaki Technologies Ltd. NZ Siglent Distributor
    • Taupaki Technologies Ltd.
Re: not receiving email notifications from this board - anyone else?
« Reply #18 on: August 26, 2018, 12:19:09 am »
i agree, something is broken here.

attached you'll find my settings. dunno what possibly could be wrong there...
It looks OK and all I can suggest is to turn lots of them OFF and then Save Profile changes. Then get back into them again and set to ON and then again Save.
Check if that works otherwise gnif will need to look into a possible forum bug.
Avid Rabid Hobbyist
 

nemail

  • Guest
Re: not receiving email notifications from this board - anyone else?
« Reply #19 on: August 26, 2018, 12:27:33 am »
hmm did that, sent myself a PM, didn't get any notification...

edit: did even check my inbound smtp gateways log files. no connection attempt has been made...
« Last Edit: August 26, 2018, 12:29:50 am by nemail »
 

Online rstofer

  • Super Contributor
  • ***
  • Posts: 6232
  • Country: us
  • Country: us
Re: not receiving email notifications from this board - anyone else?
« Reply #20 on: August 26, 2018, 12:31:16 am »
You have turned on "Allow users to email" (or whatever it is called).  Maybe when that is ON, PMs are OFF.  Maybe...
 

nemail

  • Guest
Re: not receiving email notifications from this board - anyone else?
« Reply #21 on: August 26, 2018, 12:32:36 am »
You have turned on "Allow users to email" (or whatever it is called).  Maybe when that is ON, PMs are OFF.  Maybe...

maybe, but I don't receive topic reply notifications either...
 

Offline Brumby

  • Supporter
  • ****
  • Posts: 9125
  • Country: au
  • Country: au
Re: not receiving email notifications from this board - anyone else?
« Reply #22 on: August 26, 2018, 02:40:02 am »
Have you tried an alternate email address - something on a completely different domain?
 

nemail

  • Guest
Re: not receiving email notifications from this board - anyone else?
« Reply #23 on: August 26, 2018, 09:09:22 am »
Have you tried an alternate email address - something on a completely different domain?

yarr, company mail address works. but how does this help?
 

Offline mk_

  • Regular Contributor
  • *
  • Posts: 168
  • Country: at
  • Country: at
Re: not receiving email notifications from this board - anyone else?
« Reply #24 on: August 26, 2018, 09:45:44 am »

Anyone else experiencing this issue?


Since 2 or 3 days no more notifications - exept the PCAD-thread today... and there was a lot of trafic on https://www.eevblog.com/forum/projects/dynamic-electronic-load-project/ since my last notification from 20.8.2018...

from my side I assumed a hickup with yahoo as yahoomail is not that stable from my experience as it should be, so it will be stable in some days again.



 

Offline Brumby

  • Supporter
  • ****
  • Posts: 9125
  • Country: au
  • Country: au
Re: not receiving email notifications from this board - anyone else?
« Reply #25 on: August 26, 2018, 02:26:21 pm »
Have you tried an alternate email address - something on a completely different domain?

yarr, company mail address works. but how does this help?

So .... your preferred email address doesn't work, but your company email address does.  Is that correct?

If so, ask yourself the question: How could that be?  Some of your answers should include scenarios where the forum software is not a factor.

As an example, I encountered a problem which sounds identical a few years ago on another forum using SMF.  It turned out to be an issue with emails to my ISP (who hosted my email) being blocked by a server somewhere along the way.  This is the only partial information I could get and I didn't have the access to be able to determine exactly what the problem was.
 

nemail

  • Guest
Re: not receiving email notifications from this board - anyone else?
« Reply #26 on: August 26, 2018, 02:49:08 pm »
I have full control over my whole email system and I have checked the logs of my inbound smtp gateways (which are the mx records for my domain) and there is NO connection attempt from any IP address at the time where the notification should have been delivered.

it has to be some weird isp (routing) issue or eevblogs outgoing smtp server antispam or something.

there is no error on my side.
 

Online rstofer

  • Super Contributor
  • ***
  • Posts: 6232
  • Country: us
  • Country: us
Re: not receiving email notifications from this board - anyone else?
« Reply #27 on: August 26, 2018, 03:26:42 pm »
ISPs blacklist email domains from time to time.  It's a rather large hammer to solve the problem of spam being generated somewhere in a domain.

So, it is theoretically possible that your ISP is blocking a large number of addresses and EEVblog is caught up in it.

Have you tried something like this?

https://mxtoolbox.com/blacklists.aspx -- note, I don't know what it does exactly and I haven't tried it

I'm pretty sure Comcast uses blacklisting because I haven't gotten any spam in a very long time.  It certainly isn't because the Internet has cleaned up its ways.

ISPs are getting very aggressive in policing the net.

It is reasonably certain the problem is on your end.  Maybe not with your equipment but perhaps with your ISP. 

 

nemail

  • Guest
Re: not receiving email notifications from this board - anyone else?
« Reply #28 on: August 26, 2018, 03:35:43 pm »
my isp has absolutely no control over my emails. i have my own servers and as i'm not located in china, there is no "big firewall" between my servers and the rest of the world.

so no, unfortunately, my isp is not to blame when it comes to blacklisting, etc...
 

Offline drussell

  • Super Contributor
  • ***
  • Posts: 1049
  • Country: ca
  • Country: ca
  • Hardcore Geek
Re: not receiving email notifications from this board - anyone else?
« Reply #29 on: August 26, 2018, 05:00:16 pm »
ISPs blacklist email domains from time to time.  It's a rather large hammer to solve the problem of spam being generated somewhere in a domain.

Yeah, nemail's domain and servers are listed in multiple RBLs.

I have a feeling it will just work once he gets his servers un-blacklisted.  :)

edit:  Also, his reverse resolution for ip -> name doesn't point to his domain, but rather an IP in a dynamic IP address pool.  Many sending entities filter on this, either by name (less common since there are valid uses for multiple names for a server, though it will usually add to the "spam score" when processing a message) or by listings of dynamic IP pools.

While these things should affect mostly outgoing mail, many places are increasingly using blacklists on sending mail to those listed servers also in various ways to try to minimize the flow of spam TO various relays, etc.
« Last Edit: August 26, 2018, 05:17:54 pm by drussell »
 

nemail

  • Guest
Re: not receiving email notifications from this board - anyone else?
« Reply #30 on: August 26, 2018, 07:16:47 pm »
ISPs blacklist email domains from time to time.  It's a rather large hammer to solve the problem of spam being generated somewhere in a domain.

Yeah, nemail's domain and servers are listed in multiple RBLs.

I have a feeling it will just work once he gets his servers un-blacklisted.  :)

edit:  Also, his reverse resolution for ip -> name doesn't point to his domain, but rather an IP in a dynamic IP address pool.  Many sending entities filter on this, either by name (less common since there are valid uses for multiple names for a server, though it will usually add to the "spam score" when processing a message) or by listings of dynamic IP pools.

While these things should affect mostly outgoing mail, many places are increasingly using blacklists on sending mail to those listed servers also in various ways to try to minimize the flow of spam TO various relays, etc.

got a few links for me, please, where i can reproduce your results?
my inbound smtp ip addresses (aka mx records) are pseudo dynamic (at least in the dynamic range) IPs, thats correct. my outgoing mails however are handled through a rented server in a datacenter with proper static ip and PTR record. that ip is not blacklisted as far as i can tell.

never monitored the blacklisting status of my mx record IPs, as i didn't ever hear before of the fact that ISPs may block outgoing mail to blacklisted MXes.

so thanks so far for your analysis but i'm not sure if that isp behaviour (if it is the reason for my issue here) is very smart... i have ordered a business line recently and as soon as I got it installed, at least one of the mx records will be a proper static ip with a proper PTR. i might then remove the second mx for testing.

removing my pseudo-dynamic IPs from all blacklists won't work, I'm afraid, as many blacklists don't allow removing dynamic IPs.
oh, btw i strip the smtp headers on my outgoing mails, so the receiving smtp server only sees the smartmxes proper static IP which has a PTR.
my mailsystem is up and running for years and used by like 20 users without any issues. even communicating with google mail accounts works without any issues...
« Last Edit: August 26, 2018, 08:44:15 pm by nemail »
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf