Author Topic: uSupply  (Read 28298 times)

0 Members and 1 Guest are viewing this topic.

Offline jb79

  • Contributor
  • Posts: 23
  • Country: at
Re: uSupply
« Reply #50 on: November 12, 2016, 03:37:09 pm »
Hi again!

I've put the part with the LM358's and the LT3083 on the breadboard now, for voltage/current setting I'm using potentiometers for the first try, but I think there are some issues.

One of them seems to be U12A, because the voltage at it's output (pin 1) isn't equal to it's input (pin 3). I think the reason is that the opamp is no rail to rail type.  I think there are two options:
1.) give the opamps a slightly higher voltage supply than the rest
2.) Use rail to rail opamp, does anybody know a compatible type that would fit?

My next problem is that there is an output voltage of about 0,7V on pin 7 of U12B even with no input voltage. Maybe this is caused by different resistors (I used 1% resistors with wires for the first try because the 0805 resistors don't fit on the breadbord), but I think the problem is also the LM358, it seems that this type is also not capable of switching down to 0V.

Any suggestions?
I think I've to get the analog part working first, before I try to add all the digital control to it.
Setting a voltage seems to work (down to about 140mV without a load), but only if I disconnect current limiting because of the reasons above.
 

Offline StillTrying

  • Super Contributor
  • ***
  • Posts: 2408
  • Country: dk
  • Country: Broken Britain
Re: uSupply
« Reply #51 on: November 16, 2016, 05:22:40 am »
Any suggestions?

Some of the problems with RevD have been mention in threads on this site. I'd say search, but I can't never find anything here either!
CML+  That took much longer than I thought it would.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf