Author Topic: EEVBlog forum posts "live feed" ?  (Read 1732 times)

0 Members and 1 Guest are viewing this topic.

Offline Inflex

  • Regular Contributor
  • *
  • Posts: 125
  • Country: au
    • Charters Towers Phone & Computer Repairs
EEVBlog forum posts "live feed" ?
« on: January 02, 2017, 11:03:25 am »
On several other SMF forums I participate on, they have enabled or added a "live feed" page which shows you a continuously updating list of what's being posted (usually 5~10 second updates using old refresh rather than AJAX requests though).

I couldn't see one active for EEVBlog but was wondering if there was any chance of having it added?  I enjoy watching the live feeds because it gives me a chance  to be exposed to topics I might not normally go looking for, helps 'widen' the horizons a bit :)

btw, I am aware the main landing page for this forum does have a 'snapshot' of the last N posts at the time of loading, though I'm not sure writing a 10~30 second wget + filter script would be too accepted "Somone's trying to DoS us!"
Magicsmoke abuser | What I repair daily on YouTube | FlexBV
- BoardView
| Paul Daniels
 

Offline ataradov

  • Super Contributor
  • ***
  • Posts: 6352
  • Country: us
    • Personal site
Re: EEVBlog forum posts "live feed" ?
« Reply #1 on: January 02, 2017, 07:56:35 pm »
I use RSS for this purpose.

The link is at the bottom of every page - https://www.eevblog.com/forum/.xml/?type=rss

Or if you want to see only new topics, and not new posts, then use https://www.eevblog.com/forum/index.php?action=.xml;type=rss;limit=20;sa=news
Alex
 

Offline Inflex

  • Regular Contributor
  • *
  • Posts: 125
  • Country: au
    • Charters Towers Phone & Computer Repairs
Re: EEVBlog forum posts "live feed" ?
« Reply #2 on: January 02, 2017, 08:06:53 pm »
I use RSS for this purpose.

The link is at the bottom of every page - https://www.eevblog.com/forum/.xml/?type=rss

Didn't see that until I looked closer and highlighted the text at the bottom there ( not very visible due to the background ).  Interestingly I only get a 403-Forbidden response from it.

I liked the AJAX/refreshing-HTML version because it was easy to just leave it as a tab or separate window on another screen when watching the forums, very easy to keep a finger on the pulse as it actually happened :)
Magicsmoke abuser | What I repair daily on YouTube | FlexBV
- BoardView
| Paul Daniels
 

Offline ataradov

  • Super Contributor
  • ***
  • Posts: 6352
  • Country: us
    • Personal site
Re: EEVBlog forum posts "live feed" ?
« Reply #3 on: January 02, 2017, 08:11:21 pm »
Interestingly I only get a 403-Forbidden response from it.
Me to at the moment. I'm not sure if this is a browser thing or what. My RSS reader seems to be happy. Nut it may not know that this error has happened just yet. The last message I see in the reader is from 32 minutes ago. I will report if RSS feeder sees new messages.

I liked the AJAX/refreshing-HTML version because it was easy to just leave it as a tab or separate window on another screen when watching the forums, very easy to keep a finger on the pulse as it actually happened :)
Well, I use RSS for everything else, so it does not bother me. I have interests other that this forum :)
Alex
 

Offline ataradov

  • Super Contributor
  • ***
  • Posts: 6352
  • Country: us
    • Personal site
Re: EEVBlog forum posts "live feed" ?
« Reply #4 on: January 02, 2017, 08:46:23 pm »
Ok, so forum pre-processor damages links. If you use my link, but copy and paste the text, not the link itself, it will work.

Use the second link, since the first one is already broken in the forum itself.

Let me try it this way - eevblog.com/forum/index.php?action=.xml;type=rss;limit=20;sa=news . Yep, just copy-paste this one.

And for completeness, link to all posted messages - eevblog.com/forum/index.php?action=.xml;type=rss . Be warned, it easily gets ~700 messages a day :)
« Last Edit: January 02, 2017, 08:49:27 pm by ataradov »
Alex
 

Offline Towger

  • Super Contributor
  • ***
  • Posts: 1576
  • Country: ie
Re: EEVBlog forum posts "live feed" ?
« Reply #5 on: January 02, 2017, 09:04:22 pm »
Still seems to be working on Tapatalk.
There was a problem after the Christmas Day attack on the forum there is was still feeding (probably depending on your reader software) the photos from the deleted messages.
 

Offline Inflex

  • Regular Contributor
  • *
  • Posts: 125
  • Country: au
    • Charters Towers Phone & Computer Repairs
Re: EEVBlog forum posts "live feed" ?
« Reply #6 on: January 02, 2017, 09:05:44 pm »
Let me try it this way - eevblog.com/forum/index.php?action=.xml;type=rss;limit=20;sa=news . Yep, just copy-paste this one.

Seems to have worked here.

Quote
And for completeness, link to all posted messages - eevblog.com/forum/index.php?action=.xml;type=rss . Be warned, it easily gets ~700 messages a day :)

That's not too much of a concern.  For me it's mostly I sit back with a cup of coffee, watch all the live feeds from the various sources, and just jump in if I see anything at the time that looks interesting; I'm not really trying to  dig back through the proceeds of the day, just looking at what's active "now"  :-+
Magicsmoke abuser | What I repair daily on YouTube | FlexBV
- BoardView
| Paul Daniels
 

Offline ataradov

  • Super Contributor
  • ***
  • Posts: 6352
  • Country: us
    • Personal site
Re: EEVBlog forum posts "live feed" ?
« Reply #7 on: January 02, 2017, 09:06:31 pm »
Still seems to be working on Tapatalk.
What's working? We are talking about RSS feed. The forum itself is working fine.
Alex
 

Offline ataradov

  • Super Contributor
  • ***
  • Posts: 6352
  • Country: us
    • Personal site
Re: EEVBlog forum posts "live feed" ?
« Reply #8 on: January 02, 2017, 09:09:04 pm »
And what do you know. If you do this eevblog.com/forum/index.php?action=.xml;type=json , you will get JSON feed. Now all you need to do is a simple HTML5 frontend :)

Nope, still XML, it is just browser does not recognize it as RSS anymore.

Here is a full list of things you can do. http://wiki.simplemachines.org/smf/XML_feeds , so no JSON.
« Last Edit: January 02, 2017, 09:13:14 pm by ataradov »
Alex
 

Offline Inflex

  • Regular Contributor
  • *
  • Posts: 125
  • Country: au
    • Charters Towers Phone & Computer Repairs
Re: EEVBlog forum posts "live feed" ?
« Reply #9 on: January 02, 2017, 09:15:59 pm »
How often does the forum update the RSS feed?  I noticed it's already about 20 minutes behind  (I've tried refreshing a few times) :( 

Not sure if this will work if you don't have an account with them; but this is what I'm talking about

     https://www.rcgroups.com/forums/spy.php

It's like a page dedicate to the data we see in the "Recent Posts" section on the main forum landing page, updated continuously within a few seconds of each post being submitted (the RCGroups one cheats a little, it polls every 20~30 seconds and then just feeds out the new posts ever couple of seconds to simulate a more 'real time' feel )
Magicsmoke abuser | What I repair daily on YouTube | FlexBV
- BoardView
| Paul Daniels
 

Offline ataradov

  • Super Contributor
  • ***
  • Posts: 6352
  • Country: us
    • Personal site
Re: EEVBlog forum posts "live feed" ?
« Reply #10 on: January 02, 2017, 09:18:00 pm »
How often does the forum update the RSS feed?
Instantly. RSS is generated dynamically on each request. Yor post is already there followed by a few others.


I don't think you can do anything like that. And I got dizzy after 10 seconds of watching RCGroups thingy.
« Last Edit: January 02, 2017, 09:19:33 pm by ataradov »
Alex
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf