General > General Technical Chat

Cheap Chinese Electronics.

(1/5) > >>

orbiter:
OK the story goes like this..

Today I decided to try out my new eBay purchase, which is basically a hard drive USB converter/adaptor kit. It allows me to connect SATA or IDE hard drives simply via a USB port which is very convenient for swapping data around between various drives. Even before I ordered this thing I understood that the purchase was not going to be for a top quality item, but rather a cheapo China brand unit, and so I also understood that quality control and testing of this adaptor may not have been up to much. However I assumed that these things must have to be tested to some degree, so I got one & thought hey.. It’s only a 12v adaptor, what can possibly go wrong.

One week later I needed to find some data on a few older IDE drives that I had, so I plugged in my new toy and all was great, it worked a treat. I could connect all my drives without having to take the sides off of my main computer, and transferring data was breeze. After around 10 minutes use though I noticed that the little PSU for the adaptor kit was running pretty hot, (not just warm either. Hot!) Around 10 more minutes passed and I was still happily transferring data, when from behind me came a pretty loud BANG!! (Well it sounded  pretty loud as my room is quite quiet) I turned around to find blue smoke filling the air along with a really bad burning electronics smell. Jeez I crapped myself (gladly not literally ? )

The damn cheapo PSU which feeds the hard drives had exploded inside its casing like a small bomb, the LED had gone off and there were now bits rattling around inside the casing. Anyway I was just glad that the thing didn’t actually blow the case apart as there’s a chance it could have set our house on fire :o

So.. on to the evidence… 








I have contacted the eBay seller and he was apologetic and promised to send me another PSU, he did mention that the PSU could have been damaged in transit, although I don’t think so as it was packed very well indeed and this unit has obviously suffered component failure.
 
To be honest, I can see longevity being a problem generally with these things as they run too hot. The hot part I was feeling originally was the transistor heat sink which was resting against the plastic case. Now I’m no engineer but the heat sink doesn’t look big enough to me, and certainly doesn’t do its job efficiently enough to keep the transistor at a reasonable operating temperature.

By the way.. What is the exploded component guys, Is it a fuse of some sort?
 

orbiter

Simon:
hm looks like a germanium diode (typically made of glass) but I can't understand why one would be used in a SMPS or any power supply for that matter. judging by the burn on the board it was more than just that part that failed

orbiter:

--- Quote from: Simon on August 08, 2010, 07:31:50 pm ---hm looks like a germanium diode (typically made of glass) but I can't understand why one would be used in a SMPS or any power supply for that matter. judging by the burn on the board it was more than just that part that failed

--- End quote ---

Yea understood. The only other thing I can see though is the blown out piece of trace and the broken soldered joint. The thing blew up as if it was wired up the wrong way on the 240v side, but it wasn't.

jahonen:
I also thought about germanium diode, but I guess that is some kind of PCB fuse. At least the reference designator on the PCB says "F1". It also looks like that bit of a PCB trace is vaporized, probably the switching transistor closed permanently.

High running temperature is quite sure sign of short-life expectancy. I have personally evidenced destruction of two Chinese 12V 1A SMPS, first failed on high temperature (but fortunately didn't blow up), second failed on un-plugging after long use, and then it wouldn't work anymore probably due to bad capacitors. Then I gave up and made my own from 24 VAC output wall-pluggable conventional transformer (only type that has no components what can go mysteriously bad) and quick-and dirty LM2675 based switch-mode regulator on a veroboard which makes steady 12 volts from rectified and filtered 24 VAC. That has worked ok so far. :)

Regards,
Janne

lhc:
It's a fuse:
http://www.made-in-china.com/showroom/lsd822/product-detailGoOnHiCDfukF/China-Glass-Tube-Fuses-0-5A-30A-.html

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version